ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi8 Pro [GUIDE]HI8 PRO TWRP install & root

Follow Us

[GUIDE]HI8 PRO TWRP install & root

[Copy link]

klop8093|Post time:6-8-2016 02:18:18 View:30400|Reply:56

Lainol| Post time 5-27-2016 05:59:51 | Show all posts
Rooted!!

That's f...ing awesome, thank you son much!
Reply Support Not support

Use magic Report

intenso| Post time 6-6-2016 22:58:44 | Show all posts
Edited by intenso at 6-6-2016 23:22

I have tried this method to get root. It works fine.
However after rooting my camera stopped to work and i got en error message every time i tried to use camera.
I have tried different camera apps from google play, but any of the do not want to work now too.

How about your camera? Does it work after rooting?

My Chuwi Hi8 Pro is dual OS

P.S. WINDOWS OS works good with camera, the problem is with ANDROID only.
My Android ver : cht_cr_mrd_w-userdebug 5.1 LMY47l eng.softteam.20160503.093459 release-keys
Reply Support Not support

Use magic Report

masslon| Post time 6-7-2016 11:34:18 | Show all posts
intenso replied at 6-6-2016 22:58
I have tried this method to get root. It works fine.
However after rooting my camera stopped to wor ...

I also tried this method to obtain root.
I confirm that works well except for the camera problem that does not work .

I could not find a solution, what about you?

My Chuwi Hi8 Pro is dual OS
My Android ver : cht_cr_mrd_w-userdebug 5.1 LMY47l eng.softteam.20160503.093459 release-keys
Reply Support Not support

Use magic Report

intenso| Post time 6-7-2016 12:44:08 | Show all posts
I have found the problem - It is custom recovery.
It does not work correctly with my device (Serial Number with 6040)

I have tried to flash the ROM's
cht_cr_mrd_w-flashfiles-userdebug_P03_ILife_C806_Chuwi_Hi8_E_NG_W_DS_New_V1.0.6_A0
and
cht_cr_mrd_w-flashfiles-userdebug_P03_ILife_C806_Chuwi_Hi8_E_NG_W_DS_New_V1.0.6_A1

After flashing the camera start work again, but i lost custom recovery and root.

So, by mi mind, this method of rooting does not work well for devices with Serial ID PQ32G2216040....
Reply Support Not support

Use magic Report

ayusan| Post time 6-7-2016 14:08:29 | Show all posts
Perhaps , is the cause of the boot.img is older than the firmware that your are using.
You will need to update the "boot.img" included in the HI8PRO.zip.

Try This.
1.Download latest firmware and edit "boot.img".
http://forum.chuwi.com/thread-1157-1-1.html
Latest Hi8 Pro Android Firmware download:

2.Edit "boot.img".
Download bootimg.exe.
http://dark-cyanide-devs.blogspot.jp/2015/01/port-bootimg.html

In Command Window. Type this command and push [enter].
bootimg.exe --unpack-bootimg boot.img

Edit "/inited/default.prop" and change this.
ro.secure=1 -->0

In Command Window. Type this command and push [enter].
bootimg.exe --repack-bootimg

Raname a "boot-new.img" to "boot.img".

3. Update the "boot.img" included in the HI8PRO.zip.

4.Update your Hi8pro to the latest firmware.

5. Install TWRP(updated) and Root.
Reply Support Not support

Use magic Report

intenso| Post time 6-7-2016 22:40:15 | Show all posts
ayusan replied at 6-7-2016 14:08
Perhaps , is the cause of the boot.img is older than the firmware that your are using.
You will need ...

Yes, You are right!

I have changed boot.img according to the your instruction and now it works fine.
I got custom recovery, i got root and have no problem with a camera now.

Thank You for the instruction!
Reply Support Not support

Use magic Report

klop8093| Post time 6-8-2016 01:48:07 | Show all posts
ayusan replied at 6-7-2016 14:08
Perhaps , is the cause of the boot.img is older than the firmware that your are using.
You will need ...

thanks!
file update!
Reply Support Not support

Use magic Report

CrisPuello| Post time 6-8-2016 02:13:16 | Show all posts
I can't get it we install TWRP when device is in android download mode?
Reply Support Not support

Use magic Report

masslon| Post time 6-8-2016 02:14:13 | Show all posts
ayusan replied at 6-7-2016 14:08
Perhaps , is the cause of the boot.img is older than the firmware that your are using.
You will need ...

Hi, i will try the new procedure.

I tried to access the link http://forum.chuwi.com/thread-1157-1-1.html, but is password protected.

what key should I enter?

Thanks.
Reply Support Not support

Use magic Report

CrisPuello| Post time 6-8-2016 02:18:18 | Show all posts
masslon replied at 6-8-2016 02:14
Hi, i will try the new procedure.

I tried to access the link http://forum.chuwi.com/thread-1157-1 ...

Can you read? They give this password many times in the next pages.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list