ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi8 Pro [GUIDE]HI8 PRO TWRP install & root

Follow Us

[GUIDE]HI8 PRO TWRP install & root

[Copy link]

klop8093|Post time:6-29-2017 16:14:40 View:35424|Reply:60

deniasmara| Post time 11-21-2016 05:47:03 | Show all posts
how about root for build number 20160708..... please help me, can I use this method????
Reply Support Not support

Use magic Report

xxxstanxxx| Post time 12-3-2016 13:28:23 | Show all posts

hi, I tried to do the root following the guide on the first page, I installed TWRP 3.0.1.0 with the firmware 32G221608XXXXX 64 bits, once entered into recovery, clicked install, does not see me the sd card, I tried to format it ntfs , fat, fat32, and ExtFAT, nothing, I changed sd putting one of my phone I'm sure it works with TWRP, nothing. what can I do? supersu work if I install in the internal memory which is the only one that sees me? Thank
Reply Support Not support

Use magic Report

xxxstanxxx| Post time 12-7-2016 04:19:56 | Show all posts
ok, i have installed supersu from the internal memory, but now i can't move app on sd using link2sd or app2sd. i have partitioned the sd with all kind of possibility (fat32,ext1,ext2,ext3,ext4) nothing. it is possible to move app on sd with this device??? Thx
Reply Support Not support

Use magic Report

chuwbaka| Post time 12-7-2016 14:15:14 | Show all posts
I also didnt get app2sd or link2sd to work. (Also tried different sd card formats)
The structure of the Chuwi Rom is not android standard. (Thats also why xposed framework dont work.)
Maybe thats here the reason.

Im using foldermount.I use this to move the big obb files to sd.
Foldermount on the tablet is not as easy to use like on my phone (CM13).
Because of the different folder structure (of the hi8 pro), I always have to set the save location manually for every obb file i move to sd.

I didnt tried to move complete apps with foldermount.
And I`m also interested in a working solution for app2sd or link2sd.





Hi8 Pro 32G221608092**    128 GB sd-card 50/50 NTFS/FAT32
Reply Support Not support

Use magic Report

lapinpt| Post time 12-9-2016 14:01:25 | Show all posts
Edited by lapinpt at 12-9-2016 15:20
sourcezax replied at 11-13-2016 15:50
Hi,

I m new user of chuwi HI8 pro (august android, build G22160806)

Excellent guide, much help

a typo in the  dump file name, change  recovery.img  to  dumprecovery.img

adb shell dd if=/dev/block/mmcblk0p4 of=/data/local/dump/dumprecovery.img



rooting tools used
Reply Support Not support

Use magic Report

androide| Post time 12-14-2016 02:52:24 From the mobile phone | Show all posts
Hi friends! My id build is 20160913. I cant root :-(
Reply Support Not support

Use magic Report

usa_Billy| Post time 5-21-2017 14:52:32 | Show all posts
Worked for me. Thank you!
Hi8 Pro PQ32G221606x
Win10 32bit+Android 5.1
Flashed BIOS: .233 64bit CPU Z8300
Reply Support Not support

Use magic Report

dr.diggler| Post time 6-29-2017 13:40:30 | Show all posts
can anybody help? I have twrp v3 installed as described here. Everything works fine but i don´t get access to external SD in recovery mode. I wanted to create a backup on it. I tried several filesystems - nothing changed.
Reply Support Not support

Use magic Report

byzeta| Post time 6-29-2017 16:14:38 | Show all posts
dr.diggler replied at 6-29-2017 13:40
can anybody help? I have twrp v3 installed as described here. Everything works fine but i don´t get ...

SD works os other devices?
Reply Support Not support

Use magic Report

byzeta| Post time 6-29-2017 16:14:40 | Show all posts
dr.diggler replied at 6-29-2017 13:40
can anybody help? I have twrp v3 installed as described here. Everything works fine but i don´t get ...

SD works on other devices?
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list