Hi12 keyboard touchpad issues - Chuwi Hi12 - ChuWi Forum - Forum.chuwi.com
ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 Hi12 keyboard touchpad issues

Follow Us

Hi12 keyboard touchpad issues

[Copy link]

t-bonebl|Post time:5-10-2016 12:20:13 View:22969|Reply:73

Edited by t-bonebl at 4-30-2016 12:03

I bought a Hi12 with the keyboard w/touchpad about two weeks ago on Aliexpress.  Very impressed with this tablet for the price.
Having an issue which some other users seem to share here:  http://forum.chuwi.com/thread-1183-1-1.html

I believe the problem statement is that we would like to turn off gestures for the touchpad (not the touch screen - touch screen gestures are completely different) and cannot in Windows 10.  This results in swipes from the top of the touchpad minimizing windows, swipes from the right opening the action center and swipes from the left opening a multi-window view.  Gestures are probably also considered things like tapping and holding, two finger tapping (to right-click), and two finger scrolling.

Basically, based on what I've read, the touchpad on this keyboard is supposed to have real drivers with software that lets you tweak all of these things.  From the factory (in my case anyways) the unit comes with the generic mouse driver loaded.  If your mouse shows "HID-compliant mouse" in the device manager then you're in the same boat.  WE NEED A REAL DRIVER FOR THIS TRACKPAD AND HOPEFULLY SOME SOFTWARE THAT LETS US TURN ON/OFF GESTURES.

I have tried the Synaptics Generic I2C drivers and they don't let you tweak anything since this isn't a Synaptics hardware device (but they work as a basic driver).  Also, if windows 10 recognizes your touchpad as a "precision touchpad" then windows has a built in interface to let you tweak these items (see Settings->Devices->Mouse & touchpad).  Precision touchpads come on higher end laptops so I didn't expect it to be a precision touchpad - that's not what I'm asking.

Does anyone have a fix or any idea what the touchpad manufacturer of this Hi12 keyboard is?  I've tried looking in the hardware profile...to no avail.  If there was some sort of manufacturer part number or something on the keyboard I'd be able to figure it out.  I'm pretty close to taking the keyboard apart to see what chip is inside...but I'm afraid that is going to just be some generic chip that doesn't have a real driver/software anyways.

EDIT:  Yes I have tried using the driver package in the Hi12 re-imaging instructions on this page.  Those just load as generic drivers as well with no touchpad controls.
Reply

Use magic Report

mickeyjc| Post time 5-18-2016 03:21:25 | Show all posts
If you are too lazy to read the tutorial, I have attached (see attachment) a compiled EXE to address the below common touchpad issues
  • Override swipe down from top edge gesture, that resizes/restores window size.
  • Invert two finger scroll direction, that match Mac style.

Feel free the try it out, please report if it works for you.


Ahk_no_swipedown_invert_scroll.zip

388.49 KB, Downloads: 1080

Reply Support 5 Not support 2

Use magic Report

mickeyjc| Post time 5-19-2016 23:44:54 | Show all posts
Ok, I have compiled another one just to disable the swipe down from edge gesture that restore/re-size the current window.

Enjoy.

Ahk_no_swipedown_only.zip

524.23 KB, Downloads: 1590

Reply Support 5 Not support 1

Use magic Report

Kareshnaka| Post time 5-19-2016 00:35:48 | Show all posts
Edited by Kareshnaka at 5-19-2016 00:38

work4living, this is the revised script that does not contain the invert two finger scrolling. please note that the script also disables that keyboard shortcuts win+d, win+tab, and win+a . Also, dont forget to put this file in the startup folder:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp\

chuwiscripts.zip

509.72 KB, Downloads: 840

Reply Support 1 Not support 1

Use magic Report

t-bonebl| Post time 5-19-2016 06:00:17 | Show all posts
Edited by t-bonebl at 5-19-2016 17:03

I edited a post that had a lot of options/different possibilities to disable hotkeys (registry edits, gpedit, etc. all found here:  http://www.askvg.com/tip-how-to- ... hotkeys-in-windows/).  I tried them all.
The one that worked (and was also the easiest) was the program called SharpKeys which is freeware.
http://www.randyrants.com/2011/12/sharpkeys_35/

I used version 3.5 and just clicked "Add", then "Type Key" on the left and did whatever gestures I wanted to turn off and told it to write them to the registry.  It basically just shut off the windows key which I'm fine with.
Reply Support 0 Not support 1

Use magic Report

grumpy| Post time 6-22-2016 05:12:20 | Show all posts
@Razor, du kannst das script in den Autostart packen, dann wird es bei jedem Neustart automatisch ausgeführt.

Hierhin musst du das Script dann kopieren:
C:\Users\”DEIN USER”\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
Reply Support 1 Not support 0

Use magic Report

work4living| Post time 5-18-2016 20:33:14 | Show all posts
mickeyjc replied at 5-18-2016 03:21
If you are too lazy to read the tutorial, I have attached (see attachment) a compiled EXE to address ...

Thank you!!!  You're a life saver.  It definitely worked for me where it disabled the gesture for "swipe down from top minimizes window".  But it also changed my scrolling direction.  Is it possible to not use the invert two finger scrolling?  I would like to go back to where I use two fingers to swipe from top to bottom on the touch pad actually scrolls down.  Thanks.
Reply Support 1 Not support 0

Use magic Report

Nikojiro| Post time 5-18-2016 01:05:33 | Show all posts
The problem is that the Hi12 is recognized by Windows 10 as a generic HID mouse, so there is no specific driver. We NEED a specific driver so that we can disable gestures if we don't like them.
Reply Support 1 Not support 0

Use magic Report

t-bonebl| Post time 5-11-2016 05:56:40 | Show all posts
mouaisien replied at 5-10-2016 12:20
I think I finally understand what you mean... Is it due to Chuwi's driver or to Windows  ...

The graphic you posted is not what we're talking about.  You are noting the three-finger gestures.  Those would not be a problem to deal with because no one uses three fingers on a trackpad regularly.

The issue is SINGLE FINGER swipes (particularly from the top of the trackpad to the middle/bottom) will send gestures to the OS.  It seems if the gestures are:
Single finger down from the top = restore maximized window or minimize restored window
Single finger front the left edge to the right = tiled active window view AKA "task view" (similar to 3 fingers up as shown in your graphic)
Single finger from the right edge to the left = opens sidebar from the right

^^^^^^^^^^^^^^^^^^^^^these three are the gestures that are annoying that we would like to turn off.

Also, the 3 finger gestures you show are only supposed to work with a "precision touchpad" which the Chuwi Hi12 does NOT have or it would be recognized by the OS as one.
Reply Support 1 Not support 0

Use magic Report

ngperson| Post time 5-9-2016 15:27:01 | Show all posts
t-bonebl replied at 5-4-2016 05:14
Nowhere did I mention disabling the touchpad.  We want to disable the GESTURES that the touchpad i ...

Just got my keyboard today as well.  Great little thing but heavier than I expected.

The gestures are driving me mad already. Swiping from the top of the screen will 'shrink' a window in Win 10.  It thinks it is swiping when you are moving from the address bar in  Chrome (top) to click on something on the screen.

For example, if you type in forum.chuwi.com on the top, then move the mouse down to click on a 'forum', this will constitute as a swipe gesture and end up moving the screen to the 'floating' window size.  Very annoying.  Keyboard spacebar clacking very loud too... but that's a different story.

Still like the keyboard btw, but these gestures and clacking are driving me nuts.
Reply Support 1 Not support 0

Use magic Report

emily| Post time 5-3-2016 19:27:08 | Show all posts
If you want to disable touchpad, please press key" Fn + F12" .
Reply Support 0 Not support 1

Use magic Report

Sky007FR| Post time 5-1-2016 03:42:06 | Show all posts
+1

We need a proper driver to configure/disable these damned gestures...
Reply Support Not support

Use magic Report

hawkinspeter| Post time 5-1-2016 04:51:58 | Show all posts
Me too! A better driver would be appreciated
Reply Support Not support

Use magic Report

PhunkyBob| Post time 5-3-2016 09:12:33 | Show all posts
Yes please!
Give us something to disable the gesture!
Reply Support Not support

Use magic Report

kinander| Post time 5-3-2016 14:07:55 | Show all posts
+1
I agree fully, we need a proper driver so we can disable edge swipe
Reply Support Not support

Use magic Report

t-bonebl| Post time 5-4-2016 05:14:58 | Show all posts
emily replied at 5-3-2016 19:27
If you want to disable touchpad, please press key" Fn + F12" .

Nowhere did I mention disabling the touchpad.  We want to disable the GESTURES that the touchpad is sending to the OS.  Disabling the touchpad does not fix the fact that we are missing a real driver with controls to disable or change gestures for the touchpad.
Reply Support Not support

Use magic Report

t-bonebl| Post time 5-10-2016 10:55:12 | Show all posts
Maybe Chuwi can provide a real driver for this keyboard....otherwise I'm thinking I'll have to take mine apart and see what chip is inside.
Reply Support Not support

Use magic Report

mouaisien| Post time 5-10-2016 12:20:13 | Show all posts
Edited by mouaisien at 5-10-2016 12:23

I think I finally understand what you mean... Is it due to Chuwi's driver or to Windows 10 function?



From this page.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list