Chuwi SD driver - page 2 - Chuwi Hi12 - ChuWi Forum - Forum.chuwi.com
ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 Chuwi SD driver

Follow Us

Chuwi SD driver

[Copy link]

rutgah90|Post time:10-11-2016 00:54:06 View:6926|Reply:23

Motobot| Post time 7-24-2016 09:34:50 | Show all posts
Hi Thomas,
Remove devices (drives) is not the same as remove drivers. If you have the same problem with other SD cards, it is likely an hardware issue of your tablet. When a particular card is a problem, then just throw it into the nearest trash bin and buy a new card.
Good Luck
Reply Support Not support

Use magic Report

rfulbrook| Post time 7-30-2016 12:46:47 | Show all posts
hi i have same issue. sd card slot just stopped working in both android and windows. Tried different cards and resetting drivers. it appears to be a hardware failure. i bought 2 hi12 and the other developed blink of death. Bargain when they work but unfortunately looks like some serious quality control issues with these things.
Reply Support Not support

Use magic Report

Frank-HRO| Post time 8-1-2016 09:38:09 | Show all posts
Some of my SD cards can't be recognized by chuwi hi12 under windows 10 environment.
It shows a "!" in SD Storage Class Controller.

I had make tests:
32 GB - FAT32(okay in Android and Windows)
64 GB - FAT32 (okay in Android and not okay in Windows) and
128 GB - FAT32 (okay in Android and not okay in Windows).

I thing, there is no harware problem (all cards okay in Android), but a driver problem in Windows.

Where can i found drivers for Windows10?

Regards Frank
Reply Support Not support

Use magic Report

Wagz| Post time 8-2-2016 19:26:24 | Show all posts
Frank-HRO replied at 8-1-2016 09:38
Some of my SD cards can't be recognized by chuwi hi12 under windows 10 environment.
It shows a "!" i ...

Try formatting the 64GB card from the windows side using these instructions:
http://www.ridgecrop.demon.co.uk/index.htm?fat32format.htm

Reply Support Not support

Use magic Report

DigitalMD| Post time 8-7-2016 10:28:41 | Show all posts
Thomas replied at 7-24-2016 09:49
Hello,
I have deleted the drivers, than after restart the SD card is found.
But from 10 new stars  ...

software is not intermittent. Hardware can be.
Have you verified this card in another PC? Have you used disk tools to check for errors?
Reply Support Not support

Use magic Report

Vetal| Post time 8-17-2016 06:43:13 | Show all posts
Same problem! Unstable sd card driver!
Reply Support Not support

Use magic Report

Michelebett| Post time 9-27-2016 06:04:47 | Show all posts
MIRACOLO!!!!!d'un tratto sembra funzionare di nuovo! non so come.... non ho fatto niente di nuovo
Reply Support Not support

Use magic Report

Michelebett| Post time 9-27-2016 06:11:12 | Show all posts

Miracle It is arranged by himself
Reply Support Not support

Use magic Report

deejay| Post time 10-10-2016 00:57:45 From the mobile phone | Show all posts
I have the smae issue using SD Card in windows. Seems to be a windows driver error. Device manager shiws exclamation mark. Deinstall and rescan comws up with same fault
Reply Support Not support

Use magic Report

deejay| Post time 10-11-2016 00:54:06 | Show all posts
mine is exactly the same.
keep deleting sd card in device manager and re-booting, only to find sdcard with exclamation mark.
As a note, there are 2 sd card controllers in device manager.
Motobot, have tried all your suggestions...........
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list