New Hibook Pro Owners Thread - Reviews, Experiences - Chuwi HiBook Pro - ChuWi Forum - Forum.chuwi.com
ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi HiBook Pro New Hibook Pro Owners Thread - Reviews, Experiences

Follow Us

New Hibook Pro Owners Thread - Reviews, Experiences

[Copy link]

MightyChuwi|Post time:8-31-2016 06:48:47 View:8457|Reply:49

Edited by MightyChuwi at 9-1-2016 02:04

Hi all I recently received Chuwi Hibook Pro. Bought it from Aliexpress. Not sure if first batch or second. Ram speed is set to 1066 Mhz. Still its fast in windows after couple of days and after completion of updates and background tasks, planning to increase ram apeed to 1600 Mhz but dont feel the need to. Anniversary update failed at preparing the update stage couple of times, will try again and get back. Also the tab is taking 5+ hours to charge to 100% from about 3%, please report your charging times and ram speed. Now to the good stuff, 2k screen is amazing the OGS screen played 4k videos without any lag no light bleed, WiFi signal is ok, bluetooh ok, amazing stereo speakers, with few settings (screen brightness 20% indoors, battery saver) am getting about 8+ hours on screen time from 100% charge. will keep updating this thread.

MightyChuwi

Update : 31/08/2016

with brightness at about 20% (battery saver on) able to get 10 hrs from battery with light browsing and not watching videos. If watching videos continuously then 5 hrs.

Update : 01/09/2016

Update to Anniversary Update using update assistant 28084.


Reply

Use magic Report

donmorsa| Post time 8-25-2016 07:34:22 | Show all posts
Thanks for share your experiences!! please keep doing that while you're using the tablet ;)
Reply Support Not support

Use magic Report

mattjoey| Post time 8-26-2016 20:09:58 From the mobile phone | Show all posts
How do you change the RAM speed?
Reply Support Not support

Use magic Report

MightyChuwi| Post time 8-26-2016 20:37:16 | Show all posts
mattjoey replied at 8-26-2016 20:09
How do you change the RAM speed?

one can change the RAM speed via bios....but its risky and might brick the tablet....few people have successfully changed the RAM speed to 1600mhz and gained a bit of performace speed. For now I donotsee the need to change the speed as am able to do some light browsing in IE11 and other productive stuff.

MightyChuwi.
Reply Support Not support

Use magic Report

Mevlock| Post time 8-30-2016 14:10:21 | Show all posts
Mine came today. Not quite as fast as I would like but I did some of the more obvious Windows tweaks and that sped things up.

Really really nice screen. Busy installing windows anniversary update. Will report back some more findings later.
Reply Support Not support

Use magic Report

MightyChuwi| Post time 8-30-2016 20:59:53 | Show all posts
Edited by MightyChuwi at 8-30-2016 21:01
Mevlock replied at 8-30-2016 14:10
Mine came today. Not quite as fast as I would like but I did some of the more obvious Windows tweaks ...

Welcome to the forum Mevlock. Please tell us how the anniversary update go, and which update assistant you used, My update failed twice with update assistant 9252, yet to try with update assistant 28084. Also can you check ram speed under task manager>performance>memory ? mine is set to 1066 Mhz.

MightyChuwi
Reply Support Not support

Use magic Report

Mevlock| Post time 8-31-2016 02:53:54 | Show all posts
I used version 28084. Ran it from an sdcard, although I'm not sure if that made a difference. It updated fine. Took a few hours though. So I made sure it was plugged into the mains and charging.

Memory was set to 1066 Mhz, so I went into the bios and changed it to 1600. Tablet still booted fine.
Reply Support Not support

Use magic Report

MightyChuwi| Post time 8-31-2016 03:37:05 | Show all posts
Mevlock replied at 8-31-2016 02:53
I used version 28084. Ran it from an sdcard, although I'm not sure if that made a difference. It upd ...

Hi Mevlock, thank you for the update. Are all drivers and devices working fine after the update? also whats the memory percentage in task manager after the update and after intial boot without any programs open? Also have you tested the type C port with usb 3.0 hard drives? are you getting usb 3 speeds? since you have changed ram frequncy to 1600 mhz am afraid your battery performance will go down and you might now acheive USB 3 speeds. But please test it out and let us know.

MightyChuwi
Reply Support Not support

Use magic Report

Mevlock| Post time 8-31-2016 05:04:53 | Show all posts
Edited by Mevlock at 8-31-2016 05:05

Everything seems fine after the update.

Memory usage is around 35% after boot.

I'm waiting for a USB-C to mini USB adapter to come in the post before I can test usb speeds.

The only thing I'm having a problem with is wifi reception. If I'm in the same room as my router or access point it's fine. But reception drops off dramatically in other rooms.

All my other phones and tablets are fine with wifi. But this seems to have poor reception. I'm busy doing some more testing. My house does have very thick walls however.

Reply Support Not support

Use magic Report

MightyChuwi| Post time 8-31-2016 06:48:47 | Show all posts
Mevlock replied at 8-31-2016 05:04
Everything seems fine after the update.

Memory usage is around 35% after boot.

Thank you Mavelok for the update. Good to know everything went smoothly, will update my tab too tomorrow and update you all on the same. 35% memory after boot seems good too. I was in the market to buy the type C otg but could get a good one. Will buy one online soon and update on the same. Yes WiFi on this tab is not the best, am able to receive full reception uptil 20-25feet without any walls there after reception starts falling. Please keep us updated during your testing.

MightyChuwi
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list