ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi HiBook Pro Chuwi Hibook Pro Screen Glitching On Windows 10 Mode

Follow Us

Chuwi Hibook Pro Screen Glitching On Windows 10 Mode

[Copy link]

eldorado_allman|Post time:10-14-2016 21:17:18 View:4251|Reply:51

eldorado_allman| Post time 10-12-2016 08:10:08 | Show all posts
deejay1963 replied at 10-9-2016 07:53
It cannot be a hardware problem as it is working fine in android. Try upgrading the display drivers  ...

I already upgrade to the latest display driver from intel using Driver Easy software but the problem still exists
Reply Support Not support

Use magic Report

tangibleghost| Post time 10-12-2016 16:48:38 | Show all posts
I am having a similar problem. Screen flickers and also very unreliable touch detection, but only in windows. Any ideas?
Reply Support Not support

Use magic Report

Ghosty-JH| Post time 10-14-2016 04:12:37 | Show all posts
Hi, new to the forum, just received this tablet today and getting the same issue, screen is flickering really badly tried all the screen brightness disabling auto brightness etc. nothing is fixing it. which is a shame as this is a really nice device with the keyboard attached.
Reply Support Not support

Use magic Report

eldorado_allman| Post time 10-14-2016 05:59:52 | Show all posts
Edited by eldorado_allman at 10-14-2016 06:05

I read in some post - I forgot the link, the whole glitching thing could be reduced if we press power button repeatedly, like we click the power button and then wait 1 second and click it again, I tried this trick for about a week now.. (I did around 6-7 times clicking the power button on and off everytime I'm entering windows 10 mode -- not shutting it down, just like going into lock mode) somehow I think it works, though the glitch would sometime still appear but not as frequent as before, but still not fixing the issue here's only reducing it a bit, hope there's official help from Chuwi
Reply Support Not support

Use magic Report

Ghosty-JH| Post time 10-14-2016 06:59:12 | Show all posts
I call bs on that, lol.

been playing around after updating to latest windows build (10586.633), and I noticed when Wi-Fi is disconnected there is no flicker, at all, so with that I tried Wi-Fi and straight away flicker is back. s fortunately I have 3 Wi-Fi links I can try.

1, directly to my Wi-Fi hub (virginmedia)
2, to my hub via a power line adaptor (devolo 500mbps+Pass through)
3, my Samsung galaxy s7

here's the results connecting via route 1 works as it should, no flickering at all on any brightness setting. connecting via route 2, flicking all the time no matter what I try and finally connecting via route 3 yields same results as route 2 leading me to believe its a wireless interference issue or similar as I have been typing this post with the keyboard accessory, connected via route 1 with absolutely no flickering at all for close to 10 mins now, the only problem is the signal strength in my bedroom is pooooooop (not even 1 bar, just the dot) lol.
Reply Support Not support

Use magic Report

eldorado_allman| Post time 10-14-2016 07:08:51 | Show all posts
Ghosty-JH replied at 10-14-2016 06:59
I call bs on that, lol.

been playing around after updating to latest windows build (10586.633), an ...

Yeah, probably just my hunch, lol. Have u try it in separate time with the wifi thing? I mean the glitching mostly appear only when we first turn on the tablet, then after about 20 mins or so not so much or even dissapear
Reply Support Not support

Use magic Report

Ghosty-JH| Post time 10-14-2016 07:43:48 | Show all posts
yes I just switched back and forward with all 3 and found it glitch constantly on the same 2 but only for a few seconds on the direct connection, in fact it only seems to glitch on direct connection if I try to do to much i.e. opening to may apps etc. but when I close them it returns back to none glitching. I currently have it charging while I'm typing. and there is not noticeable glitch going on.
Reply Support Not support

Use magic Report

MightyChuwi| Post time 10-14-2016 10:22:06 | Show all posts
Feel sooo sorry for all who are plauged by the screen flickering problem. Did Chuwi start making new batch of Chuwi Hibook Pro or just few bad tablets? Anyway hope Chuwi realizes this issue soon, acknowledges it and provides a proper fix for it. In the mean time try these settings. Open Intel properties (long press on desktop > graphic properties) then power> disable extended battery life fr gaming, display power saving technology, apply. then go back to main menu> 3D here under general settings select performance and then apply then restart the tab. Hope this helps.

MightyChuwi
Reply Support Not support

Use magic Report

Ghosty-JH| Post time 10-14-2016 10:43:26 | Show all posts
Forget what I said, well part of it, left my Hi book pro on the side while charging closed against the keyboard dock for a few hours battery at 99% now, and as soon as I opened it up screen glitches and this is with a direct connection to the Wi-Fi, so I'm not sure if it is just the Wi-Fi causing it, I mean on mine it is definitely better with the direct connection , which is odd as the router is downstairs and I'm upstairs with several walls in-between.

could the walls be dampening the effect of the signal hence less glitches?

just tried what mightychuwi suggested and all were already set as suggested expect the 3d performance which I have now adjusted accordingly.

so some speculation as to what is causing it???

it cant be hardware as it would be constant, as in all the time, with me it seems to be linked to the wifi like its causing interference with the screen, i don't know how this is possible. so that just leaves the drivers, and yes mightychuwi i hope they sort it out as well as this is a fantastic tablet and would be ashame to have to send it back.
Reply Support Not support

Use magic Report

MightyChuwi| Post time 10-14-2016 21:17:18 | Show all posts
Hi sorry that the fix did not work. I was searching the web for similar issues and stumbled upon few forums where people with MacBook's were facing the same issue (maybe because of BOOK in the tablet name hehehe, just kidding) so there people have suggested to change WiFi Channel to a non crowded one and this fixes the issues apparently. I checked my router settings and the Channel is set to 1. 6 is crowded so try using Channel 1. I feel this should fix your problem, as Ghosty-JH mentioned that different routers have different results. Also I feel this maybe due to insufficient shielding of LCD connections from WiFi interference. Check the following link

http://news.softpedia.com/news/How-to-Fix-Flickering-Display-on-MacBook-Pro-Retina-427598.shtml




Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list