ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi HiBook Pro Chuwi Hibook Pro Screen Glitching On Windows 10 Mode

Follow Us

Chuwi Hibook Pro Screen Glitching On Windows 10 Mode

[Copy link]

eldorado_allman|Post time:6-19-2017 07:47:09 View:7317|Reply:58

rms| Post time 2-19-2017 22:38:26 | Show all posts
Hi there, is this really the only way to resolve this screen glitching problem? to disassemble the tablet and moving the cable?
If yes, could you please share some instructions (pictures or video) how to do that. I couldn't find this in forums.
Reply Support Not support

Use magic Report

ghostrider| Post time 3-1-2017 02:10:35 | Show all posts
Hi
Anybody know where you can buy spear parts to the HI BOOK PRO 2 ???

My screen is broken and i need to replace it with a new one model nr : CHWI 526

Hope that you can help :-)
Reply Support Not support

Use magic Report

leo06| Post time 4-20-2017 10:24:47 | Show all posts
datsice replied at 2-19-2017 06:37
This is shielding problem, on our forums we resolved it by disasembling the tablet and moving wifi a ...

I have the same problem, do you have any instructions to opening the case?
Reply Support Not support

Use magic Report

marcolee1314| Post time 5-23-2017 23:26:47 | Show all posts
Edited by marcolee1314 at 5-23-2017 23:28

leo06, do you still using this shitbook??
I just bought it, Yes, May-2017....and i realised this is the most stupid decision i make in this year...

the tablet come with Z8350 <-- upgraded but still awful in performance. wifi speedtest result in 14-22 Mbit/s
the screen glitch still exist...

I cannot return this shit to china for refund/repair due to tax charge and some paper work needs...

So I decide to teardown this shit after reading around the forum (both chinese / english forum).

I found that the "antenna cable" (<--dont know what to call) is weld on the logic board,

I cannot move it without melting the contact between them......

Also, I found the screen glitching only appear when the back case move closely to the board/screen.
The Back case is nothing specifical just plastic, and yes I removed the magnet and nothing change.

Anyone any idea what the next move ?

I will post the pic later.
Reply Support Not support

Use magic Report

marcolee1314| Post time 5-26-2017 00:17:01 | Show all posts
This is What my shit book look like origin.








1st Trial, I re-weld the wifi antenna cable (Dont have steady hand) But glitching remain exist when I place all the thing back together.



2nd trial, I pull the whole cable out and cut the head and tail, re-weld the cable, avoid the cable touch/cross the "Gold flat" cable.
it looks glitching is gone, will update later...

Reply Support Not support

Use magic Report

marcolee1314| Post time 5-31-2017 19:54:29 From the mobile phone | Show all posts
Few days later, i realize i fxxked up the wifi, the glitching is gone due to the weak wifi signal. No connection while I move to next room. So I disassemble again, clean the antenna cable, re-weld it perfectly. Reassemble it, and guess what, glitching came back...so forget to disassamble , just return it and chose the better brand/model
Reply Support Not support

Use magic Report

Hackerjac| Post time 5-31-2017 21:06:55 | Show all posts
marcolee1314 replied at 6-1-2017 04:54
Few days later, i realize i fxxked up the wifi, the glitching is gone due to the weak wifi signal. N ...

If what you have on the last pic in the first post you call welded perfect, you must be kidding me, it looks like shit, you even turned the cabel the wrong way arround
I do NOT work for Chuwi. Please DO NOT pm or email me with problems you may have!
Reply Support Not support

Use magic Report

marcolee1314| Post time 6-9-2017 03:58:32 | Show all posts
Hackerjac replied at 5-31-2017 21:06
If what you have on the last pic in the first post you call welded perfect, you must be kidding me ...

lol... u are right...
That picture is second tried and is the worst trial (That explain why glitching is gone due to the wifi signal fxxked up)
My last trial is much better because I ask someone experience in "weld thing" to do that.

I guess the glitching is not related to cable.
Reply Support Not support

Use magic Report

Mrten| Post time 6-19-2017 07:47:09 | Show all posts
Has anyone managed to fix this? I got my HiBook Pro today and I am facing the same issue... I disabled adaptive brightness, updated the BIOS, updated the graphics card drivers, nothing works. Should I just send it back to Gearbest?
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list