ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi HiBook Pro WiFi connection bad experience on Hibook Pro

Follow Us

WiFi connection bad experience on Hibook Pro

[Copy link]

sonirad88|Post time:2-22-2017 00:55:07 View:766|Reply:2

Hello everyone.
I have my hibook pro for one week and i have big problems with the WiFi connection.

1. On android wifi is satisfying but i have problem when
- device goes to sleep mode (turn off the screen) signal is lost
- i can notice that also the signal drops significantly when you go behind wall
- connection drops all the time and signal is not stable at all
2. On win 10
- singal is very poor, 4m away from the router singal is almost lost
- and the worst experiance is when wifi is on screen starts glitching/flickering very badly

I can see that there are some solutions with turn of that checkbox, enable/disable that option but that is not solution. Also while reaserching i saw that also other brands with win 10 had similar problem but their customer suport solved quickly.

So my question is can customer support provide us software solution to solve the problem, are they working on this issue? or they can simply answer that is hardware problem so we can return our device back and not waist our time.

ps: at least you can do provide us win 10 solution to stop screen glitching when wifi is turned on
Thanks
Niko


Reply

Use magic Report

sitlet| Post time 2-12-2017 21:20:28 | Show all posts
Same WiFi problems here. Works decent in Android, horrible in Windows. I just ended up ordering a nano wifi adapter for Windows. Works great.

Here's the one I ordered:

https://www.amazon.com/gp/produc ... 0?ie=UTF8&psc=1
Reply Support Not support

Use magic Report

sonirad88| Post time 2-22-2017 00:55:07 | Show all posts
sitlet replied at 2-12-2017 21:20
Same WiFi problems here. Works decent in Android, horrible in Windows. I just ended up ordering a na ...

Yes wifi adapter is one solution but i dont use keyboard and have to use otg cable because the adapter is usb2.0 etc.
I have also update to Anniversary update windows and latest graphic and wlan drivers but no big improvement....signal is poor as previous but glitching looks like is little bit reduced.
Also contact emily and chuwi service but they don't have idea what is the issue. I  sent them a video and i'm waiting for response.
I found that other hibook pro users experience  same issue https://www.youtube.com/watch?v=bWhuxku0TFw
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list