ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi HiBook Pro HiBook Pro slow charging (about 24 h)

Follow Us

HiBook Pro slow charging (about 24 h)

[Copy link]

mistermototopo|Post time:6 day(s) ago View:437|Reply:8

Edited by mistermototopo at 2-22-2017 03:34

Hello Everyone,
i have bought a HiBook Pro at December 2016. For a while everything is ok but now I have a big problem:
VERY SLOW CHARGING BATTERY!
If i do not use it, charge about 24 hours or more, if i use it during charging he can not even charging, rather slowly discharges.
I tried to change cable but nothing, I tried to change charger but nothing, then I wrote to Chuwi service but I could not understand what to do with their response. So I joined this forum and I started looking.
I tried to update the bios but the situation has not changed.
I tried to enable S5-drivers but still nothing.
Today I rewrote the Chuwi service because i do not know what to do more.
Someone has had the same problem and solved it?

I forgot to say that the situation does not change if the tablet is turned on or off or if using Windows or Android....
IMG_20170222_101259.jpg
Reply

Use magic Report

mistermototopo| Post time 2-24-2017 02:28:33 | Show all posts
No one has had this problem or can help me?
Reply Support Not support

Use magic Report

sonirad88| Post time 2-24-2017 06:47:58 | Show all posts
mistermototopo replied at 2-24-2017 02:28
No one has had this problem or can help me?

Hi there. I had also problem with the charging the tablet. I solved it with changing the usb cable.
First i try with usb2.0->type C(max 2.7A) and charging was very fast with 2.5~2.7A but charger was heating to much that is not good.
Later i bought new one usb3.0->type C(3A) and charging was on 1.5~1.7 with 5~6h to full charging.
I suggest to to try another cable because quality matters. Hope this helps.
Reply Support Not support

Use magic Report

mistermototopo| Post time 2-25-2017 03:10:37 | Show all posts
I have try with 3 other cable, 2.0, 3.0 & 3.1 but nothing....
Reply Support Not support

Use magic Report

sitlet| Post time 2-27-2017 12:33:25 | Show all posts
What kind of charger are you using? You need to be using at LEAST a 2.0 amp output charger. Even with a 2a charger, it will take a while.
Reply Support Not support

Use magic Report

mistermototopo| Post time 2-28-2017 07:05:23 | Show all posts
I am using the original charger. I tried to use one different with 3A but does not change the result ...
Reply Support Not support

Use magic Report

sitlet| Post time 3-3-2017 20:17:01 | Show all posts
I would not use the original charger. It's very cheaply made. I actually use a charger from a previous tablet. It outputs 2.0a. It takes a while to charge, but nowhere near 24 hours. Also, try changing cables. Even if a cable doesn't appear to be damaged, it might not be outputting the proper amperage.
Reply Support Not support

Use magic Report

mistermototopo| Post time 3-4-2017 10:01:44 | Show all posts
Sitlet, thanks for the advice, but I have already tried cables and chargers that work well with other tablet. I came to the conclusion that the problem is in the bios settings or in the battery. If anyone knew how to set the bios I could do the last checks before trying to change the battery ....
Reply Support Not support

Use magic Report

leo06| Post time 6 day(s) ago | Show all posts
hi, what is battery capacity showing in aida64? Mine is showing as 6500mah
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list