[Hi10 Pro] Windows screen rotation not working - Chuwi Hi10 - ChuWi Forum - Forum.chuwi.com
ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi10 [Hi10 Pro] Windows screen rotation not working

Follow Us

[Hi10 Pro] Windows screen rotation not working

[Copy link]

xoft|Post time:9-7-2017 16:53:59 View:1104|Reply:9

Hello,

I found out that my Hi10 Pro doesn't automatically rotate the screen when switching from portrait to landscape in Windows. In Android, it all works fine. After googling around, the only mention I found of a similar issue was a year ago on a Hi8, caused by a software update and then fixed by a bios update. Does anyone experience the same issue on the Hi10 Pro, and does anyone know of a fix?

I honestly don't know whether my Windows installation was updated or not, I kinda ignore the Windows Update, and didn't mess around with its settings. MS and Chuwi seem to be on the opposite sides here, one says "warranty lost if updated", the other says "cannot disable updates".
Reply

Use magic Report

deejay1963| Post time 3-9-2017 08:53:57 From the mobile phone | Show all posts
reinstall / update the graphics driver and see what happens. also check display settings for the auto rotate setting.
Reply Support Not support

Use magic Report

xoft| Post time 3-9-2017 09:14:59 | Show all posts
I have tried toggling the auto-rotate settings, of course, doesn't help at all.

How do I reinstall / update the graphics driver? Are there any driver files for download? How do I trust such files?
Reply Support Not support

Use magic Report

deejay1963| Post time 3-9-2017 09:18:08 From the mobile phone | Show all posts
download from intel download centre. or use their (intel) auto driver update app.
Reply Support Not support

Use magic Report

xoft| Post time 3-9-2017 09:45:51 | Show all posts
I tried updating the driver from the Computer Management console, it found a new driver and, while installing it, the screen actually rotated back and forth once. But then, nothing again. So it seems it's more like a configuration issue than anything else. I've tried looking for any relevant options in the Intel's control panel, but didn't find anything much. There's an option to manually set one of the four rotations, and another option to set up hotkeys for any of those rotations; I had already disabled the hotkeys before.

I'll try if I can find anything even newer on the Intel site and retry with that.

Thanks for the help.
Reply Support Not support

Use magic Report

deejay1963| Post time 3-9-2017 11:22:24 From the mobile phone | Show all posts
it could be configuration issue, for that check the display settings - allow the pc to auto rotate- setting. it also could be a sensor driver issue, check the device manager for the presence of rotation sensor or if any yellow exclamation mark is next to the sensor item in device manager.
Reply Support Not support

Use magic Report

JAY| Post time 9-6-2017 11:36:48 | Show all posts
Edited by JAY at 9-6-2017 11:39

I too have lost the ability to rotate.

with the new windows update "creator" the option to lock or unlock rotation is gone, disappeared. There is no way to enable to disable the function. before the windows update, the function switch was there and the screen rotated.
This is not a Chuwi issue, it is happening to many different tablets.
Reply Support Not support

Use magic Report

manonegra222| Post time 9-6-2017 12:24:59 | Show all posts
JAY replied at 9-6-2017 20:36
I too have lost the ability to rotate.

with the new windows update "creator" the option to lock or  ...

Possibly changing the driver has caused the problem. I have uploaded the driver and try to install it from the device manager ..

HIDClass.rar

181.23 KB, Downloads: 33

Chuwi Moderator
Reply Support Not support

Use magic Report

JAY| Post time 9-6-2017 15:52:05 | Show all posts
Edited by JAY at 9-6-2017 23:28

I uninstalled the sensor driver and reinstalled the original with no joy.
I checked the registry and auto rotate is set to active.
I tried changing the orientation to portrait and power cycling. Read that that can bring back the auto rotate switch but it didn't
Reply Support Not support

Use magic Report

jtrosky| Post time 9-7-2017 16:53:59 | Show all posts
I just tested this on my Hi10 Pro with fully updated Windows 10 and it still works fine on mine.  I still have a tile in the notification section to enabled/disable auto-rotation.  

Did you start with a Chuwi-suplied version of Windows 10 and upgrade or use a "standard" version of Windows 10 to install it?
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list