ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi10 Hi10 PRO HQ64 TF card not working, any new solutions ...

Follow Us

Hi10 PRO HQ64 TF card not working, any new solutions?

[Copy link]

kingracer|Post time:3-29-2017 04:08:41 View:757|Reply:20

Degriz| Post time 3-18-2017 08:41:09 | Show all posts
Hackerjac replied at 3-15-2017 14:07
I don't really belive its a driver issue, it works for some and not for others, how can that be a  ...

Yeah, I'm not sure its a driver issue either. On my tablet it worked when I first got the tablet. then spent couple of months with the tablet in android and when I booted back to windows it no longer works.

I also have a vague memory of a post claiming that it had something to do  with the exe used to fast switch from windows to remix os back on my older version of this tablet but, on my new version I've never used that app so I doubt thats it either.

My bets are still on a firmware issue. I know that linux ignores bios for hardware settings not sure whether this is also true for uefi firmware but it may be as everyone seems to report it working in android.

I just uninstalled the driver and tried the trouble shooting option in control which reports a problem with the driver but seems to be unable to fix and yet when I try updating the driver it claims the latest version is installed. very strange. always found working with microsnot stuff very frustrating why I don't use it much.

In my experience trying to talk to microsoft in any other way other than forum without being some kind of partner(msdn,technet) won't get you any where.
Reply Support Not support

Use magic Report

Degriz| Post time 3-18-2017 09:54:13 | Show all posts
Just found this.....

SD card is not detected (software)

This is an on-going problem that seems to be plaguing a lot of Cherry Trail devices. It could be a Windows issue (update KB314935 related?), it could be a faulty driver issue, it could be an hardware issue. I guess nobody really knows and the manufacturers keep silent.

Note: It almost certainly is NOT an issue with your type or brand of SD card or how it is formatted, although I'm not saying your card couldn't be faulty.

Partial fix:



In the Bios go to Advanced > System Component and change OS IMAGE ID to Windows.
Then right above that change MS Custom Sdbus Driver to Enabled. Make sure you save your Bios changes.

Then back in Windows 10 go to Device Manager and see if SD Storage Class Controller is properly installed and working:

SD Storage Class Controller
If you need drivers, I uploaded them here: SD Card Drivers. Right-click SD Storage Class Controller and select Update Driver Software... then Browse my computer for driver software and select the folder with drivers you downloaded.

With this change the SD card reader seems to work fine for a while but once you boot into Android it might be faulty again, sometimes even rebooting into Windows doesn't make it work 100% of the time.

Options to explore:
Chuwi has released a bios update that's meant to fix the issue but it really doesn't do much for me.
Using the May bios also seems to break the Bluetooth on Windows (if you didn't update to version 1607 that is) and the card is still not properly detected. If you want to try this bios and still have working Bluetooth you can check this thread on the Chuwi forums by user Loz.


So it seems this is a software issue. I've read on several forums that the firmware changes fixed it for some users unfortunately didn't help me. Also please note that this was from a post about the Hi8 here's the link in case you want to read it there's some useful info in there... https://doalmostanything.blogspot.co.uk/2016/09/chuwi-hi8-pro-everything-you-need-to.html
Reply Support Not support

Use magic Report

Degriz| Post time 3-19-2017 09:24:39 | Show all posts
Well I actually manged to get the sdcard workning again in windows, but its not stable. Windows managed to start the driver properly once or twice last night but couldn't find a filesystem on the card and kept asking me to format it. What I did was put the card into a usb adapter to check whether it was still working, which it was, I then put the card back into the slot and hey presto windows saw it. I rebooted and windows again couldn't start the driver (error code 10).

Today I thought I'd give one more go to get it working, nothing I tried worked. I then thought what I would do is boot into safe mode remove all the drivers and try and install some different ones. Whilst attempting to reboot to safe mode I had to find a keyboard to hit the right key and it seems it timed out and reset back to windows but, the tablet took a long time to reboot and when the Chuwi logo came up there was a circle of dots rotating next to it. When it finally rebooted windows saw the sdcard fine and it work correctly. On the next reboot the sdcard again wouldn't work so I went to the firmware and I thought it might have something to do with the fastboot options but when I looked they were disabled so I enabled and rebooted. Hey presto the sdcard was working, just to make sure every thing was fine I rebooted again and this time the tablet wouldn't boot at all the ChuWi logo would come up, go away and come back again over and over. I thought I'd bricked it some how. I turned the table off by holding the power button, plugged a keyboard in powerd it back on and went back into the firmware to turn fastboot off again. Tablet booted, Phew, took a little while again that circle of rotating dots was there and when the tablet went to windows it also had a circle timer thing and wouldn't you know it the sdcard worked. So once more I rebooted and this time started android (CM) and then booted back to windows and of course the sdcard wasn't working anymore.

I can't replicate any of this I've tried everything that made it work for a while and now it just won't work again.

I don't know where this leaves me, whether its drivers or firmware or perhaps both, I know one thing its most definetly a windows 10 problem. Nothing new learnt there.

One thing I have learnt that this is fixable, I just haven't found out how......

May try going back to a previous build as I found a post that hinted it may be a problem with a windows update, I've tried uninstalling the but after waiting a couple of hours windows reboots and the bloody update is still there.

If I find anything I will post it.
Reply Support Not support

Use magic Report

kingracer| Post time 3-20-2017 06:32:59 | Show all posts
Degriz replied at 3-19-2017 09:24
Well I actually manged to get the sdcard workning again in windows, but its not stable. Windows mana ...

That's a ton of text Thank you for your information and detailed explnation of your method. I've tried to reinstll both OSes for a few times but it didn't work... But when it happened for the first time i've reinstalled Win10 with original Microsoft ISO and then i've installed CM12.1 and sdcard worked for me for a while pretty well but for make it work in both OSes i should completely turn off my device and then boot it up with OS that i need. Then i've tried to install RemixOS and it broke forever So now i'm searching for working conditions too but i don't think it's possible to fix because a few times when windows tried to work with card it just stops in a few minutes.
Anyway, thank you, and keep trying!
Reply Support Not support

Use magic Report

Degriz| Post time 3-21-2017 11:10:32 | Show all posts
kingracer replied at 3-20-2017 06:32
That's a ton of text  Thank you for your information and detailed explnation of your method. I'v ...

Thanks, I will keep looking for a solution.

What I've found now is that the card won't work in Windows if I've rebooted from CM 12.1 to windows but if I leave the tablet off for a couple of overs and boot into windows 10, so far anyway, it seems to work. Now I don't use windows very much so I don't know if after a while it will just stop working.

There is a fundimental difference between how the Linux kernal and windows handle hardware. My understanding is that windows very much relies on the bios/uefi where as Linux does not, at least it didn't back a fews now when I used to mess with Linux kernel alot. So i may be a problem with the way these to OS's interact with initializing hardware.

Anyway I'll post here if anything changes
Reply Support Not support

Use magic Report

kingracer| Post time 3-22-2017 09:12:27 | Show all posts
Degriz replied at 3-21-2017 11:10
Thanks, I will keep looking for a solution.

What I've found now is that the card won't work in Win ...

After my first flashing CM12.1 Windows was working with sdcard pretty well if i turn the tablet off and then choose windows from boot menu, however if i rebooting from cm12.1 - sdcard didn't worked. Now, after a lot of reflashings of both OSes - sdcard working only in CM12.1 but windows cant see it at all, but my main OS should be exactly Win, so i'm keep trying to fix it with different drivers and so on everyday... And also, if i'll find the solution - i'll post it here too, thank you
Reply Support Not support

Use magic Report

Degriz| Post time 3-26-2017 06:14:18 | Show all posts
kingracer replied at 3-22-2017 09:12
After my first flashing CM12.1 Windows was working with sdcard pretty well if i turn the tablet of ...

Yeah, what I've found is that once you run, I'm guessing, any version of android the sdcard won't work in Windows unless you leave the tablet off for a while. I tried shuting down from CM 12.1 and leaving the tablet off for 3 hours but it wasn't enough windows wouldn't see the card although it would recognise the fact that you eject the card and put it back in. At the moment the only way I seem to be able to get it working in windows after running cm is leaving the tablet off overnight, that has consistantly worked for me but its a bit of a pain. Resetting the firmware may work but I haven't treid that yet.

This all leads me to believe that it has something to do with the way that the Linux kernel initialises the hardware device. As I've said before Windows relies heavily on bois/firmware where as Linux kernel doesn't. Although other tablets that don't use the cherry trail processor don't seem to have this problem. could be some to do with the windows drivers not cold starting the hardware device. I've come across that problem before with other devices. Anyway keep fighting the good fight.
Reply Support Not support

Use magic Report

kingracer| Post time 3-26-2017 14:22:47 | Show all posts
Degriz replied at 3-26-2017 06:14
Yeah, what I've found is that once you run, I'm guessing, any version of android the sdcard won't  ...

I left my device turned off for 3 full days and windows still can't see sdcard after direct boot into windows, so it's working not always
Reply Support Not support

Use magic Report

Degriz| Post time 3-28-2017 07:57:03 | Show all posts
Edited by Degriz at 3-28-2017 08:04

Hmmmm, well that's disapointing. So far it has worked for me every time but, there are other problems. Windows can't write to the sdcard, it will attempt to write to it but after a while it throws an error and then often hangs. It reads from the card no problem, might need to reformat the card but don't want to do that as it already has lots of data on it and it's large (128GB).

Have you set the firmware option metioned in one of my other posts? not sure it's necessary but it might be.

In the Firmware go to Advanced > System Component and change OS IMAGE ID to Windows.
Then right above that change MS Custom Sdbus Driver to Enabled. Make sure you save your Firmware changes

On a side note I really f*%&ing hate Windows 10, they removed the ability to access insecure network drives of which I have several without mentioning it so microsnot can go suck my .........

I know that doesn't help you, I'll keep searching and if I find any other solution I'll post it here.
Reply Support Not support

Use magic Report

kingracer| Post time 3-29-2017 04:08:41 | Show all posts
Degriz replied at 3-28-2017 07:57
Hmmmm, well that's disapointing. So far it has worked for me every time but, there are other problem ...

Yup, that's really disappointing And yes, i've tried that checks in BIOS, they doesn't work for me. And i keep searching too, thank you for your time
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list