[Tutorial] How to flash BIOS for Chuwi Hi13 - page 2 - Tutorial - ChuWi Forum - Forum.chuwi.com
ChuWi Forum»Forum Chuwi Download Tutorial [Tutorial] How to flash BIOS for Chuwi Hi13

Follow Us

[Hi13] [Tutorial] How to flash BIOS for Chuwi Hi13

[Copy link]

emily|Post time:7 day(s) ago View:5296|Reply:18

emily| Post time 10-7-2017 22:22:14 | Show all posts
GerryBarry replied at 10-3-2017 05:09
I have just flashed my Hi13 following the instruction to the letter but now I can boot up my tablet. ...

hello, GerryBarry, are you sure you choose the right bios? could you please tell me your serial number so that i can help you contact the service, have a good weekend
Reply Support Not support

Use magic Report

dragonmod| Post time 12-2-2017 09:39:01 | Show all posts
I just had the same problem. My new Hi13 worked for about an hour, windows update and bios update and now it seems dead. No charging led and black screen. tried disconnet the battery and pushed bower and volume button, but nothing happend. Need help, please!
Reply Support Not support

Use magic Report

dragonmod| Post time 12-3-2017 09:21:12 | Show all posts
emily replied at 10-7-2017 22:22
hello, GerryBarry, are you sure you choose the right bios? could you please tell me your serial nu ...

Hello,
I just had the same problem. My new Hi13 worked for about an hour, windows update and bios update and now it seems dead. No charging led and black screen. Tried disconnecting the battery and pushed bower and volume button, but nothing happened. Need help, please!
Reply Support Not support

Use magic Report

franky_franklin| Post time 12-4-2017 10:03:28 | Show all posts
Edited by franky_franklin at 12-4-2017 10:06

Hello, I have the same problem. My new Hi13 worked for about an hour, windows update and bios update and now it seems dead. No charging led and black screen. Tried disconnecting the battery and pushed bower and volume button, but nothing happened. Need help, please!
Q64G45170900857
Reply Support Not support

Use magic Report

emily| Post time 12-4-2017 21:55:29 | Show all posts
dragonmod replied at 12-3-2017 09:21
Hello,
I just had the same problem. My new Hi13 worked for about an hour, windows update and bios  ...

hello, could you please tell me your serial number?
Reply Support Not support

Use magic Report

emily| Post time 12-4-2017 21:56:30 | Show all posts
franky_franklin replied at 12-4-2017 10:03
Hello, I have the same problem. My new Hi13 worked for about an hour, windows update and bios update ...

hello, could you please try this bios:
http://www.mediafire.com/file/yxp9rp7i8nzcvkg/Q64G45170901726.rar
Reply Support Not support

Use magic Report

dragonmod| Post time 12-6-2017 09:30:22 | Show all posts
I cant even install anything due to black screen and no charging led like franky_franklin pointed out. My SN is: Q64G45170900719
Reply Support Not support

Use magic Report

catalin| Post time 12-6-2017 11:39:51 | Show all posts
Edited by catalin at 12-6-2017 11:43

Emily, @franky_franklin and  @dragonmod has 1709 series of HI13 tablet, NOT 1707
I already explained to you that you provide WRONG information about these bioses
Wrong information can kill all HI13 tablet series 1709 with this bios update.

There is NO main bios here that match with 1709 series. Also EC BIOS must be al least
v223 of Intel APL-MRD Intel P1, otherwise all HI13 charging system will be KILLED.
Reply Support Not support

Use magic Report

dragonmod| Post time 7 day(s) ago | Show all posts
@catalin so do mine. I've sent it in for repair/exchange. Hopefully, they sent me a new one very quickly ...
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

12
Return to list
Quick Reply To Top Return to the list