ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 New CHUWI Hi12 is not working

Follow Us

New CHUWI Hi12 is not working

[Copy link]

Steunebrink|Post time:6-7-2017 10:22:55 View:206|Reply:2

Today I received my new Chuwi Hi12 but even after  charging it for several hours, it will NOT start up, nothing I don't even see a led flashing or something.

HELP what can I do ...???
Reply

Use magic Report

manonegra222| Post time 6-7-2017 07:34:29 | Show all posts
Edited by manonegra222 at 6-7-2017 16:37

It is strange that it does not do anything since they usually arrive with 60% of battery and start without problems. If you connect the charger and do not turn on the led intermittently it is advisable to charge for a few hours to see if the LED starts to blink always with the USB connector fully plugged in.

Finally try holding the power switch for 30 seconds. Release it and hit the button again three times. Finally, put the charger and turn it on again.


You can also read this thread: http://forum.chuwi.com/thread-3965-1-1.html

Chuwi Moderator
Reply Support Not support

Use magic Report

technisol| Post time 6-7-2017 10:22:55 | Show all posts
With the charger unplugged it takes 2-3 seconds of holding the power button on to see the LED light solidly.(no blinking)  If the charger is plugged in, holding the power button for no more than 6-7 seconds should show boot activity on the LCD screen...   Otherwise try the long press in excess of 20 seconds and then three brief presses and it should hopefully boot.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list