ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi13 USB C port issues

Follow Us

USB C port issues

[Copy link]

pmelo|Post time:7-26-2017 03:55:14 View:725|Reply:17

I bought a USB c hub and it worked for a couple of days.
it doesn't work anymore. Tried other hubs, pens, nothing works using the port type C. Only charging..
Some say it's because of the length of the male type C but mine worked a few times... is there drivers I could reinstall or something?
Reply

Use magic Report

emily| Post time 7-20-2017 18:36:00 | Show all posts
hello, could you please tell me which kind of tablet you bought?
have a good day
Reply Support Not support

Use magic Report

pmelo| Post time 7-20-2017 20:21:45 From the mobile phone | Show all posts
Chuwi hi13
Reply

Use magic Report

Techdragonz| Post time 7-23-2017 06:04:18 | Show all posts
Have you forced anything? Pictures would be great?
More info?
I'm not weird. I'm limited edition | I'm glad to be of your service | Contact me if you need any help
Reply Support Not support

Use magic Report

Techdragonz| Post time 7-24-2017 10:58:37 | Show all posts
Btw, length of the cable rarely brings issues like this, expect if it's like ultra long.
Does charging through the USB C hub work? Or doesn't it support this?
I'm not weird. I'm limited edition | I'm glad to be of your service | Contact me if you need any help
Reply Support Not support

Use magic Report

pmelo| Post time 7-25-2017 00:56:18 | Show all posts
Edited by pmelo at 7-25-2017 01:02



not sure what else i can show you. the hub should have a blue led when connected. like it did the first few times i used it.
and yes, back when it worked, i could charge the tablet through the hub. if i connect the charger to the hub now, it powers the hub's led but nothing happens, it's neitheir detected by windows and it doesnt charge.

the charger is the original. i bought another one and doesnt work. the charger is pumping out 5v (blue led) instead of 12v according to the manual

this is the charger https://goo.gl/pyFC26

also, ive noticed the usb c area gets pretty hot, warm even when the device is in sleep mode which is weird..

Reply Support Not support

Use magic Report

artowi| Post time 7-25-2017 01:08:42 | Show all posts
Welcome to the club.  See the 'Hi 13 getting hot and short battery life' thread.   
Your EJ898A USB PD-Controller chip got roasted.
Reply Support Not support

Use magic Report

pmelo| Post time 7-25-2017 01:20:12 | Show all posts
artowi replied at 7-25-2017 01:08
Welcome to the club.  See the 'Hi 13 getting hot and short battery life' thread.   
Your EJ898A USB  ...

that's probably why hubs dont work and the new charger cant negotiate to 12v and limits it to 5 huh?
what should i do? contact chuwi by email?
Reply Support Not support

Use magic Report

artowi| Post time 7-25-2017 01:35:48 | Show all posts
I think you should claim warranty because I don't think you did anything wrong.  Did you use the original KEYU charger?  I think the original charger is a very poor design and responsible for killing many HI13.   

Don't open the tablet and void your warranty!  It seems impossible to get the EJ898A chip and it would require special tools and skills to replace on the mainboard.   CHUWI most likely install a new mainboard so make sure to backup all data.
Reply Support Not support

Use magic Report

masshuu| Post time 7-26-2017 03:55:14 From the mobile phone | Show all posts
Did you try attaching the chuwi charger? I read that the charger wood kill other USB devices
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

12Next
Return to list
Quick Reply To Top Return to the list