ChuWi Forum»Forum Chuwi Notebook Discussion Chuwi Lapbook 14.1 Chuwi LapBook 14.1 - Huge performance problems!

Follow Us

Chuwi LapBook 14.1 - Huge performance problems!

[Copy link]

TheJohn|Post time:The day before yesterday 11:16 View:157|Reply:4

Hi guys,
I have some serious troubles with my Chuwi LapBook 14.1.

Once that I finished the first configuration in the english language, I tried to download the italian from the settings but both Windows updates and the language pack goes stuck on 20-25%.

I decided to format the HDD and install a Windows 10 Home Single Language Edition through the Media Creation Tool, but after all this I got a OS so slow that I can't do anything: a single letter typed with the keyboard takes almost 10-15 seconds to display in Word or any other program.

Obviously the brand new Windows 10 Italian didn't come with all the drivers, so I restored all of them with a backup made with Driver Max when the PC was with Chuwi's Windows 10.

What should I do? Thanks in advance!
Reply

Use magic Report

manonegra222| Post time 8-7-2017 13:20:50 | Show all posts
If you have installed the version Single language will not be activated because it does not match the version that came from factory that is Home multilanguage. I would reinstall this version, then the drivers and finally go to Windows update and do all the updates. If after this is still slow, tell him and we will look for the cause.
Chuwi Moderator
Reply Support Not support

Use magic Report

Gajack| Post time 8-7-2017 16:44:27 | Show all posts
Hi,

You really should use Windows 10 from factory to get a windows activated, and install drivers from here : http://forum.chuwi.com/forum.php ... ypeid%26typeid%3D55

And just wait a little more when you download italian language maybe


buona fortuna con il tuo problema!
Chuwi Moderator,

PM me if you have any questions ;)
Reply Support Not support

Use magic Report

TheJohn| Post time The day before yesterday 00:22 | Show all posts
Hi guys, thanks for the response!

Unfortunately, I've tried to reinstall the Windows 10 from factory but the problem persist: the PC is really, really slow...
Reply Support Not support

Use magic Report

Gajack| Post time The day before yesterday 11:16 | Show all posts
can you send a screenshot of your task manager, tab performance?

Thanks you
Chuwi Moderator,

PM me if you have any questions ;)
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list