ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 Chuwi Hi12 tablet keyboard - numeric keypad - Fn-key ...

Follow Us

Chuwi Hi12 tablet keyboard - numeric keypad - Fn-key not working as expected

[Copy link]

MartinJMalliet|Post time:1-29-2018 17:54:18 View:826|Reply:3

Edited by MartinJMalliet at 1-29-2018 15:23

Normally, with NUMLOCK 'on', the numeric keypad appears on the dedicated keys of the keyboard when pressing (and holding) the Fn-key (for typing numbers); releasing the Fn-key lets you type letters again. - On my Hi12 tablet keyboard it's always numbers that appear, whether I hold the Fn-key or not. To switch between normal (letter) typing and number typing, NUM LOCK must each time be toggled 'off' and 'on' again!

Reply

Use magic Report

manonegra222| Post time 1-29-2018 15:44:24 | Show all posts
You can alternate, activating or deactivating the numbers on the keyboard by pressing Fn + Num LK
Chuwi Moderator
Reply Support Not support

Use magic Report

MartinJMalliet| Post time 1-29-2018 16:06:52 | Show all posts
Yes, I know, that's what I meant by toggling NUM LOCK 'off' and 'on' again each time. But that is not what I want. I want the normal mode of operation that I'm used to: NUM LOCK always 'on' and holding the Fn-key to type numbers, releasing the Fn-key to go back to normal typing. From what I googled, this may be a BIOS setting of the Fn-key. But I don't know how to enter the BIOS on this tablet computer: pressing the F2-key when booting does not work for me (probably because the tablet keyboard is not yet recognised at boot time).
Reply Support Not support

Use magic Report

MartinJMalliet| Post time 1-29-2018 17:54:18 | Show all posts
I found the way to enter the BIOS at boot time: by pressing ESC on the attached tablet keyboard within 2 seconds after startup. But I found no setting for the Fn-key, only a setting for 'Bootup Numlock State' which I changed from 'on' to 'off'. But that didn't really change anything, just the state of NUM LOCK after booting (to 'on' strangely enough, while with the (default) BIOS setting 'Bootup Numlock State' set to 'on' the NUM LOCK is 'off' after booting when entering the password, which is for the better). I find this behaviour strange, because with NUM LOCK 'off', the Fn-key does give you the arrow-keys of the numeric keypad, releasing the Fn-key gets you back to normal typing. Why isn't it the same for numbers when NUM LOCK is 'on'?
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list