emily Publish time 4-24-2017 02:00:52

How to solve "the tablet can not turn on"

Edited by emily at 4-24-2017 02:02

If your tablet can't turn on, please try to following methods:

1. Tablet without power (less than 1% of the electricity)
If you press the power button, you can plug in the adapter charging for half an hour to 1 hour then trying to boot to see whether there is improvement;

2. Adapter or data line is bad
In other equipment (such as mobile phones, equivalent current and voltage plate) to test whether the normal charge, if not normal, please replace the adapter, charging line.

3. False crash status
Plug in the adapter tocharge the tablet , charging time is about 1 hour ,then long press the power button for 15 seconds to reset, after 5 to 10 seconds to restart the tablet.

4. the press button is broken
The power button is broken, no touch, leading to the power button can't normalbe used, need to assemble the machine shell key or FPC ribbon cable again.

5. USB Charging Defective
You can check USB interface whether it is abnormal, such as damaged, pinhole offset, plug the USB cable charging and feel loose, you can be sure thatthe USB interface is bad, resulting in plug-in adapter is not charging,it need to replace USB interface;

6. the battery is bad
Plug in the adapter after the charge indicator has a flash, boot prompts 100% power, the adapter pulled outit immediately shutdown, this phenomenon is a bad battery problem,you can replace the battery;

7. the display is bad
Turn on the tablet, the back of tablet appear light display, forced long press the power button for 15 seconds can also appear a normal backlight prompts to turn off, the tablet this phenomenon is in consequence of bad display, you can replace the display;

8. the display FPC cableis bad
The customer accidentally thrownthe tablet in the cause of using it, or the battery loose lead to the display FPC cable fall off,resulting in the machine does not boot, need to disassemble the flat battery power and re-insert the FPC cable, or bad cable need to replace the cable.

9. BIOS drop out
Need to disassemble the machine with a jig on the computer to brush BIOS, it can not directly use U disk to operate;

10. bad motherboard
The motherboard is bad, and the hardware needs to repair

If it can't still solve your problem, please contact your seller and return it for repair, or email to service@chuwi.com.

Spekkie Publish time 5-19-2017 05:07:24

I have This problem:
4. the press button is broken
The power button is broken, no touch, leading to the power button can't normalbe used, need to assemble the machine shell key or FPC ribbon cable again.
And my cable is broken(see picture).
Where can I get a new one?

ZenBalancer Publish time 4-25-2017 10:38:03

An example of this thread being used for troubleshooting relevant issues: https://forum.chuwi.com/thread-3981-1-1.html

And one equally specific situation that doesn't seem to be covered by the content here of the OP thus far, so perhaps can lead to further expansion or refinement to include this situation: https://forum.chuwi.com/forum.php?mod=redirect&goto=findpost&ptid=2895&pid=22555&fromuid=19651

Rorence Publish time 5-8-2017 00:02:00

After reading the whole post, I have learned more about this topic. Thank you so much.

emily Publish time 5-19-2017 19:12:17

Please cotnact your seller and return it for repair.
Or email to service@chuwi.com

Spekkie Publish time 5-20-2017 04:45:43

emily replied at 5-19-2017 19:12
Please cotnact your seller and return it for repair.
Or email to

Sending it back will take much to long...
I have send an email to service@chuwi.com, but no response yet...

Compasscard Publish time 9-19-2017 13:31:59

Edited by Compasscard at 9-19-2017 13:33

Ribbon cable working (measured)
Battery at 8v = +- 90% full
No charger light, likely because battery is full
Tried the trick with power button long press
Tried with docked keyboard, but that doesn't help either
USB port is only powered for 15s after power button press (used a small usb led light)
No display nor backlight
No burnt components on motherboard and measured all R0 resistors. None bad.
Adapter does output correct voltage
No corrosion on the brand new USB-C port
5V rail available for 15s after power press
3.3V rail available for 15s after power press
CPU remains ice cold
No voltage on main bios eeprom (should get 1.8v) after power press
No voltage on main capacitor (330 µf / 16v) after power press
Unplugged/replugged battery... that's not it either...

I'm pretty sure it's a mainboard voltage regulator issue, but without schematics it's practically impossible to trace the problem.
So the list isn't very helpfull. It's a bit pity that the thing died after a couple of days without an obvious reason...
A part of the schematic would be helpfull (power conversion from battery to rails) and a bit of documentation on that KBC/EC controller ITE8987E would also be usefull.
Sending it back is no option, very expensive and little chance it will ever arrive.

kc2koj Publish time 9-19-2017 15:55:26

HOW CAN I FIX...my hi10 wont boot or charge.....someone told mei might have to flash with programmer. is this the right way to fix this problem or should i send back to factory..WORK ONLY FOR A FEW HOURS THEN DIED...i think windows was updating when it died...can you please tell me the bios and os files i need to flash my hi10 dual boot ..

DaDutch Publish time 10-27-2017 14:33:45

Edited by DaDutch at 10-27-2017 14:42

Spekkie replied at 5-19-2017 05:07
I have This problem:

And my cable is broken(see picture).

I have the same problem. The flatcable makes a sharp bend and is pretty hard to remove from the connector. I wanted to look behind the motherboard to see if something was broken there, since the USB2 port is dead and had to disconnect the power/volume flatcable and it tore. My own fault. But still something that should be fixable. So I asked Chuwi support where I could buy one.

Chuwi support response:
i am sorry , we don't have this , thank you

Address:2end Floor,Bld 3,Lijingcheng industrial Park , The East of Gongye Road ,Longhua,Shenzhen,China
Website :en.chuwi.com

My Hi12 is worthless due to a $1 part.

If Chuwi is trying to become a serious player, they will have to seriously step up their after-sales and service. For instance keep some spare parts behind for breakage. Or give some to online stores to sell.

Señor_Lobo Publish time 12-2-2017 03:59:05

Good afternoon, I am the owner of a Chuwi Hi10 plus tablet for 3 months, at first I was very happy having a tablet free of faults, since a few weeks the tablet sometimes costs a lot to turn on or on but with the screen off It is hard to react being sometimes almost impossible to use, today every time the screen is turned off I can only use it because the screen does not react and I have to connect the charging cable wait and try until it wants to work Any solution?
Pages: [1] 2 3 4 5 6 7 8 9
View full version: How to solve "the tablet can not turn on"