pietroroman Publish time 5-30-2019 13:33:48

Type C usb does not charge aerobook after reset

Hello

I have an aerobook and to move my system to the 256GB SSD I just reinstalled everything from scratch (downloaded a clean windows image from Microsoft) as suggested somewhere else.

Windows update found all the drivers and the system works fine (I even activated secure boot from the bios).

All work fine - except for the type C usb, I can't charge the computer from that port anymore.

Any idea on how to solve? I tried to look in the bios, activated a "type C support" voice but that didn't solve the problem.

Thank you!
Pietro

manonegra222 Publish time 5-31-2019 00:01:36

Before the clean installation, did you try port C to load? What charger are you using? The useful charger for that port is not a conventional 5V charger. 2A. It must be Power Delivery.
These are some examples:

Chargers and powerbanks PD already tested with the Aerobook and that work:
Gvoo: https://amzn.to/2VY9rB2
Zimer: https://amzn.to/2IdqvON
Blitwolf: https://amzn.to/2Xh0gx5
Zimer: https://amzn.to/2VYI2Pu
Dodocool Battery: https://amzn.to/2wwUZFL

pietroroman Publish time 6-1-2019 04:50:36

Hi Manonegra

thanks for your help.

yes before the clean install the usb c port used to charge the device - I have tried with the same charger that worked before and now it does not work.

Thanks!
Pietro

manonegra222 Publish time 6-1-2019 05:28:09

pietroroman replied at 6-1-2019 13:50
Hi Manonegra

thanks for your help.


I suppose you made a copy of the drivers before reinstalling the system.if so, reinstall the USB C drivers
Pages: [1]
View full version: Type C usb does not charge aerobook after reset