ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 Charging Issue

Follow Us

Charging Issue

[Copy link]

gulfv|Post time:9-1-2016 20:14:55 View:5804|Reply:40

technisol| Post time 8-30-2016 14:23:05 | Show all posts
Edited by technisol at 8-30-2016 14:28

DigitalMD, your post #19 symptoms, especially the power LED behavior, sound very similar to the ones I mentioned in post #14, yet mine eventually restarted, albeit with a completely discharged battery...  WEIRD!
If nothing else, one can be assured that there is hardly ever a dull day as a Hi12 owner...  ;-)
Reply Support Not support

Use magic Report

LMCH| Post time 8-30-2016 18:11:10 | Show all posts
DigitalMD replied at 8-30-2016 15:17
Try everything you can, but this sounds like a component failure in the power supply section. I"ve  ...

I don't think it's a power failure, it seems able to power up the cpu to check the power button (unless that part is managed by a secondary power-management microcontroller).
I'm using the the original USB harger and cable and everthing was allright until it started acting like that after a full recharge.
Maybe there's some rearming fuse for overvoltage protection  that doesn't rearm properly until it's fully discharged or something like that ?
Reply Support Not support

Use magic Report

technisol| Post time 8-30-2016 22:55:41 | Show all posts
I don't know LMCH, but I think it's something else.

As I understand it, according to photos that Motobot pointed out a while back and my subsequent downloading and reading of the spec sheets, the internal battery pack protection is on that little circuit board at the top of the battery pack.  The two ICs there shut off the incoming charging path when a certain voltage is reached on each individual battery and allow them to charge no higher than that, they also open another circuit from each battery pack individually to the battery leads coming out of the pack if either battery is discharged below a certain level.  This is purely a safety function as I understand it.

Now, that being said, it also seems apparent there are other circuits in the system having to do with shutdown, charging, etc. because even when working correctly Win 10 controls charging and my Hi12 varies between 95-99% charge, and Win 10 displays: Not Charging, which has been explained by others as a Win 10 thing when it is unable to identify the battery pack.  Sounds reasonable, not positive it's completely accurate, but fair enough as I see no connections other than battery leads coming out of the battery, i.e., no obvious communications pathway.  I have no real problem with this, just wish the high and low cutoffs were adjustable as a lot of data seems to indicate charging no higher than 80% may be better for battery life long term, especially if you're not going to need full battery capacity and mostly run while charging as I do, but the Hi12 doesn't seem to charge at a very high rate anyway while running the machine so I'm not going to stress out over it and everything is probably working as intended.  I am a little puzzled that if the adapter provides enough power to run the Hi12 while not charging just how the battery level manages to drop to 95% during that period...  so perhaps there is an issue there.

The weird thing is when you encounter a situation like the one you're in and the one I experienced...  Similar symptoms on the LED -no indication at all despite being plugged into a known and tested good charger, but I didn't think to check USB voltage as I really thought I'd somehow gotten the Teclast BIOS brick despite preparations taken to stave that update off and just spent about 45 minutes trying power button sequences while watching some TV as a last resort while putting off ordering the equipment to flash the bios to the chip externally... and just got LUCKY that it started up before I ordered the programmer and voltage converter.

Now, whether these little bugs have anything to do with the other situation reported in the early days by some owners that charging while running their tablets burnt up the BIOS chip and required replacement I cannot say, but go back and read the threads and do some Googling, etc.  From what I read, it seems likely that spate of incidents lead to the infamous "You can't use the tablet while charging" statement by Emily.  Pardon the quotes if those were not in fact her exact words, but something to that same meaning.  I assumed(could be dangerous) that early problem had been corrected and have used my Hi12 while charging as I have EVERY OTHER TABLET/LAPTOP/CELLPHONE I'VE EVER OWNED... and this goes back to the late 80s early 1990s.

Whether your issues and mine are in fact the same I cannot say, but it might be worth 45 minutes of button twiddling while it's charging to see what happens...  Best of Luck.

If that BIOS chip was damaged it's going to require replacement/reprogramming and if there was an issue with earlier boards you'd be better off returning the entire unit and having them replace the Mobo with the updated version.
Reply Support Not support

Use magic Report

LMCH| Post time 8-31-2016 14:39:21 | Show all posts
I've got one of the newer dual boot ones (delivered in the first days of  august) and before recharging after shutting in down it was running Android, not Windows, that's why I think it must be something more likely in the firmware than a Windows 10 issue.

On desktop/notebook pc some firmware settings are stored on battery backep cmos chip, while in these tablet/ultrabook device it's stored on the same NOR-flash where bios/UEFI firmware is stored, I guess that by reflashing it
they simply restore those settings to some failsafe values, because there's no way a"battery issue" is gonna trash the (rarely written) NOR-flash chip.

Anyway, I've done a full discharge (by attaching a "led light" to the USB 2.0 port) until the battery fully discharged (or the battery undervoltage protection kicked in, now I'm leaving it recharge a bit and later will try repeaing the on/off sequence to see if I can get it back to life.
Reply Support Not support

Use magic Report

technisol| Post time 8-31-2016 17:53:47 | Show all posts
Wishing you absolutely the best of luck!  I won't say it was the longest 45 minutes of my life or anything, but it was a frustrating time while I was trying to get it to do something while I thought it had bricked.

Well, with the newer version I'd hope that the BIOS chip overheating while charging issue had been solved...  no problems with mine.  Can't imagine what they could have done to cause it in the first place considering how well most parts are documented these days.

In your case, possibly mine as well, I think it more likely a case of it getting into a "locked" or raceway state and needing to be cleared by a button hold combination.  I basically held the power switch in for 30 seconds plus and then tried 6-7 seconds a few times to see if I could get a "Chuwi" boot screen.  Rinse and repeat.  I threw in a few of the 10 seconds holding it off and then 3 rapid presses as well and just kept trying over and over...  Not terribly scientific, but with no feedback whatcha gonna do?  ;-)  I figured 30 seconds would be the absolute longest period anyone would design in as a failsafe, and had read of the 10 seconds and three rapid presses in the forum.

Have you thought to try getting it into DNX(?)fastboot mode by holding both volume buttons or either(I forget which, but think it's both) down while holding the power button in for 5-7 seconds?

If a button sequence doesn't do it, maybe it's time to consider ordering that BIOS flash chip programmer/level shifter or crack the case and see if you can spot the soft power controller chip and check the docs for a reset sequence?  Best of luck.  
Reply Support Not support

Use magic Report

matt| Post time 8-31-2016 21:26:18 | Show all posts
deejay1963 replied at 7-31-2016 22:55
Also tablet not charging after 95% is windows issue not tablet hardware issue. Windows cannot correc ...

Mine charges until reaching 100% with the Samsung adapter, so it is most likely a charger issue
Reply Support Not support

Use magic Report

technisol| Post time 9-1-2016 09:15:22 | Show all posts
Edited by technisol at 9-1-2016 09:21

Oh, mine will charge to 100% too -with the tablet off or in Android as I recall, but most often I see it ranging between 95-99% when the charger is plugged in and the tablet is running Win10.  It'll discharge to 95% while running and displaying "Not Charging" and then switch over to charging until it creeeeeeps up to 99% and then cycle again.  Someone suggested it was a Win 10 thing when it couldn't identify the battery pack.  Probably a safety measure based on a hard coded cutoff voltage of 4.15 they said, IIRC.  Sounds about right as most lithium batteries I've measured have ranged around 4.1Vdc fully charged, give or take a tenth of a volt.  However, that cycling behavior is a bit odd at best...  I hope it is not leading to early battery deterioration through accellerated charge cycles.
Reply Support Not support

Use magic Report

LMCH| Post time 9-1-2016 15:33:46 | Show all posts
technisol replied at 9-1-2016 02:53
Wishing you absolutely the best of luck!  I won't say it was the longest 45 minutes of my life or an ...

AFAIK DNX Fastboot kicks in during the Android boot sequence, if the firmware "hangs" before launching that boot sequence AFAIK it's not possible to activate it.

If I understood correcly there's an initial boot loader that after some critical checks launches the "Android or Windows" bootloader (to select OS boot sequence)
THEN if you choose "Android" it launches the initial Android bootloader (that checks for POWER_ON + VOL_PLUS to launch DXN fastboot)
OTHERWISE if you choose "Windows" it launches the bios/UEFI bootloader.

As weird as it seems, there is a chain of bootloaders instead of a single one (even on "simpler" ARM chips there are actually 3..4 bootloaders with what we
"see" as the bootloader being the last in the chain).

Reply Support Not support

Use magic Report

LMCH| Post time 9-1-2016 15:39:21 | Show all posts
technisol replied at 9-1-2016 02:53
Wishing you absolutely the best of luck!  I won't say it was the longest 45 minutes of my life or an ...

While you were trying over and over the various power-on combinations, did you kept it connected to the USB charger and/or the external keyboard ?

Maybe it doesn't work for me because I'm missing something in the exact procedure to follow.

Reply Support Not support

Use magic Report

technisol| Post time 9-1-2016 20:14:55 | Show all posts
Edited by technisol at 9-1-2016 20:21

Connected to USB charger the whole time, except when I first checked the adapter, and I believe the original Hi12 keyboard.  I know it was connected to the keyboard when the issue occurred and I'm pretty sure I left it connected as I had no case or tablet stand at the time, nearly positive.
Personally, I'm bothered by the whole seeming randomness of the whole experience, but at least it only happened once.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list