ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 Charging Issue

Follow Us

Charging Issue

[Copy link]

gulfv|Post time:10-11-2016 17:54:44 View:6321|Reply:40

LMCH| Post time 9-17-2016 14:57:36 | Show all posts
Some updates about my problem.
I've tried everything and as last effort I did a full discarge, then recharge and reopened the device to directly check the battery terminal with my multimeter and got 4.1V (i.e. the "fully charged" voltage).
As I previously wrote it boots, it must be doing at least a minimal configuration of the AXP288C (the power management chip) ... and then nothing.
Either it must be the Insyde firmware (had previous bad experiences with firmware developed by that company, it seems they reused firmware originally developed for x86 personal computers without considering that tablet are quite different and must have different recovery modes) or something burned in the AXP288C chip or detected a nonexisting power failure because of a borderline power configuration.

I've ordered another Chuwi Hi12 because I really like this device, and the second one seems working OK so far, but, damn!
It's really depressing how what's likely a little quirk can kill a nice device like this.

Reply Support Not support

Use magic Report

technisol| Post time 9-17-2016 17:44:06 | Show all posts
Edited by technisol at 9-17-2016 19:06

So, are you going to pick up the chip programmer and voltage adapter for the BIOS chip and give it a go?  Despite the USB ports powering up, etc, during boot it still sounds like it's not booting completely.  Find a cheap "slow boat to China" method to send it back to Chuwi?  Or what is your next step?  Seems a shame to keep it as a spare parts source only.
Reply Support Not support

Use magic Report

LMCH| Post time 9-18-2016 12:51:08 | Show all posts
technisol replied at 9-18-2016 02:44
So, are you going to pick up the chip programmer and voltage adapter for the BIOS chip and give it a ...

I already have a ch341a programmer and a level converter, next option is checking if a bios rewrite will do the trick
and as last option keeping it for spare parts.

I don't have the skills required to safely desolder and resolder the bios chip so I will try to reprogram it in-place, but first I will check if there are  know diagnostic/debugging/programming ports or board traces, it would be easier (and safer) that way.
Reply Support Not support

Use magic Report

technisol| Post time 9-18-2016 15:24:43 | Show all posts
Edited by technisol at 9-18-2016 15:36

I believe others have done it successfully in situ...  If that's unsuccessful perhaps you can get a general electronics repair shop to swap the chip -perhaps preprogrammed.  Anyone capable of component level repair of cellphones, tablets or HDTVs with hot air rework tools should be able to help you out for a minimal fee if the BIOS chip got fried -it's not like there are hours of disassembly work involved to get to it.  However, if the hole in Borger's power/volume switch assembly is any indication you might want to watch out when prying any clips that may be near the buttons...
It surely might be educational to clip onto the old chip and read out the contents and do a compare with what was supposed to be programmed in it.

I know you can find a step by step guide for the reprogramming -it's been linked to in this forum and, I believe, at techtablets.
Reply Support Not support

Use magic Report

DigitalMD| Post time 9-20-2016 03:23:02 | Show all posts
It's unlikely that BIOS programming will fix this but its worth a try. Beyond that its the power / charge control section and probably not repairable without schematics.
Reply Support Not support

Use magic Report

LMCH| Post time 9-23-2016 14:41:47 | Show all posts

I've openend the tablet again, removed the heat spreader (or EM shield ?) to have easier access to the NOR-flash SPI chip containing the firmware
connected ch341a chip programmer  + 1.8V level converter + SOIC8 clip and after flashing the latest firmware
it booted up like nothing happened.

So at the source of the problem it's likely there was some ACPI firmware  fuckup!  

The last time it was working correctly BEFORE not being able  to boot anymore with led OFF happened the following:
I running Android with charger and external keyboard connected (I have the latest metallic one),
then i turner off the tablet (shutdown, not suspend) leaving the keyboard and charger connected
and closed the tabled+keyboard like you do wth a notebook computer.
Later I disconnected the keyboard FIRST and then the charger to move it to another place in the house, reconnected the charger, tried to turn the tablet on and ...nothing.

I guess that by having the external  keyboard connected the firmware must be in some low-power ACPI mode, non a complete shutdown, not suddenly at least.
(while I tried to bring it back to life with the triple quick pressure + long pressure of the power button I noticed it didn't shut down completely after the long pressure if the
keyboard was connected).

I guess that while powering down the ACPI firmware stores some status data in the NOR-flash and if the (supposedly) "fixed" hardware configuration at the next boot changes suddenly, the initial bootloader
goes into some sort of panic mode and stays there until the NOR-flash chip is rewritten completely (rewritting the bios and writing "safe" dfault parameters for ACPI/hardware status data).

Usually on PC/notebook devices there's a special "emergency recovery" or "panic mode recovery" sequence to tell the device to boot using "safe" parameter for everything
exactly for situations when something like this happens, maybe Insyde (those that provided the bootloader, IIRC) didn't tell Chuwi what is the sequence of actions to activate it or it kicks in only AFTER the initial bootloader
(the one that allows to choose between booting Android or Windows) selects the successive bootloader to execute ?

Anyway, a NOR-flash rewrite seems to do the trick ... if you have the right tool and know how to do it properly.
Reply Support Not support

Use magic Report

technisol| Post time 9-23-2016 21:51:00 | Show all posts
Edited by technisol at 9-23-2016 21:57

Hey, CONGRATULATIONS, Dr. Frankenstein! (what, too soon for Halloween?  More like Fron-ken-steen around here anyhow...)  So glad for you, and wondering how I got away without having to reflash BIOS when I experienced what sounded like the same circumstances...  Maybe I just got lucky and hit the mystery sequence or something.  Always said I'd rather be "lucky" than good.  One can always work on the skills side of things to improve.

At any rate, I hope you have no further issues.  Best of luck!
Reply Support Not support

Use magic Report

LMCH| Post time 10-4-2016 13:20:44 | Show all posts
More details on what caused the problem with my tablet.

a) I PRESS THE POWER-DOWN BUTTON for a complete shutdown
b) I SELECT "complete shutdown" from Windows 10
the tablet seems to shutdown, the keyboard led stay lit fro a few more seconds and then it turns off
looking carefully I noticed the display is just "black" with backlight still on (i.e. display is still active, just showing a black screen, lets' call this "undead status" )

At this point if I keep pressed the power on/of button for a few seconds (about 10..12 seconds) the screen backlight will go completely off
and only the charging led in the tablet will still be active (and will turn off when disconnecting the USB charger).

What caused my problem was NOT realizing the display wasn't really off (i.e. there was something running at ACPI firmware level), disconnect the keyboard, the disconnect the USB charger
while the tablet was still in "undead status"   
When i later connected the USB charger and tried to turn on the tablet, guess what, it wasn't off, but still "undead" and probably waiting on some condition to completely power off or something connected to the standard shutdown sequence.

I guess that part of the problem must be related to power management firmware mishandling the optional pogo-clip keyboard like it's an always connected component (like in a notebook) or something like that
or maybe when the USB charger is connected the "OS level shutdown" code does not send a proper shutdown request to the keyboard microcontroller (while the successive long press handled by firmware sends the correct request ? ).

Anyway, by detaching the keyboard BEFORE powering down or by checking is the tablet is really OFF (check if the screen is really off instead of "black with backlight active" and doing a long press to power it off completely)
it seems everything shuts down correctly.

Reply Support Not support

Use magic Report

technisol| Post time 10-4-2016 20:25:37 | Show all posts
Well, perhaps you've simultaneously identified the keyboard drain issue and the shutdown/startup issue, now if CHUWI will listen maybe they can find a fix and roll out an updated firmware to fix both issues.  I have the original plastic keyboard, and when I had my power on problem it was connected and my battery was completely drained when I finally did get it to power up again.  I see a lot of consistency there.  You may have identified the issue, now Chuwi/the company who provided the firmware needs to find the underlying cause and fix it.  I'd say nicely done!
Reply Support Not support

Use magic Report

LMCH| Post time 10-11-2016 17:54:44 | Show all posts
Another update about the shutdown problem.
AFTER the latest Windows 10 updates it seems to shutdown completely  without having to press the power on/off button to "force" a complete shutdown, maybe it's just luck or one of the
windows patches fix this problem because something like that happens with other devices too
(maybe it depends on the sequence of shutdown commands sent to the various devices connected to internal buses and to external ones ? ).
Now the keyboard led stays up a bit as before, but when display goes completely off the keyboard led goes off too.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list