ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi10 Root Chuwi HI10 Pro/VI10 Plus by yener90

Follow Us

Root Chuwi HI10 Pro/VI10 Plus by yener90

[Copy link]

yener90|Post time:10-6-2016 04:24:30 View:13526|Reply:42

Edited by yener90 at 10-10-2016 08:44

I tried lots of ways to root this tablet.
Finally succeed.
This package contains a modified kernel. It is required to let the tablet boot with modificated system drive.I'm not responsible for any damages.

Thanks @kostyamat. I used his way to root this tablet. But needed to edit most of the files, to get this done with our tablet ... -kostyamat-t3368642

HI10 Pro
VI10 Plus

Unzip the archive to PC, but try not to use special characters or folder names with space  in the paths to files. Better way is unzip to a folder in the root of drive C: or D:
Turn on ADB-debugging: "Settings"-"About Tablet" >-> Taps under the item "build number" until the caption appears "you became a developer"-> Return one step back-> enter the item for developers "-> Enable" USB debugging ". A popup may appear on tablet. Set remember and press ok. Also enable OEM unlock.
Connect the device to the PC.
Install the Intel driver IntelAndroidDrvSetup1.10.0.exe

  1. Unlock_Bootloader.bat - It will unlock the bootloader. Carefully follow the description of the script and on the screen of the tablet. ATTENTION! All settings, programs, as well as all data on internal SDCard will be removed! Data on external MicroSD and Windows will not suffer. After unlocking the device will reboot in factory recovery, which does not display anything (stupidly black screen with backlight), the process may take up to 10 minutes, then the device will reboot into Android.
Tablet is now reseted, enable ADB Debugging and OEM-Unlocking again

2. Outside_boot-TWRP-recovery.bat - The device will be rebooted into the temporary session of TWRP-recovery, to Internal sdcard will be placed - install it using TWRP. Previously, you can make TWRP backup (recommended!)

3. Flash-TWRP-recovery.bat - (It is optional) TWRP-recovery will be permanently flashed into the Tablet. (Not recommended! Some time firmware will  update, TWRP cannot install OTA-update)

4. Flash-ORIGINAL-recovery.bat - (It is optional) Flash back to the original Recovery.

SuperSU is required for this!
  Download this file, copy to your tablet and flash it in recovery using TWRP.
Xposed doesn't work. Don't try it.


Use magic Report

kninez| Post time 9-25-2016 05:22:47 | Show all posts
I just managed to root mine using your instructions/files. Thanks a lot.
Reply Support Not support

Use magic Report

Quetsch| Post time 9-26-2016 04:19:45 | Show all posts

Your guide worked flawlessly.
Got full root rights now. Thank you so much!
The script for adding exFAT and NTFS support worked. Had the issue that only tha last plugged in USB device was mounted.
After fiddling around with Paragon I noticed once I switched to permissive mode the scripts work as intended.

Thanks again to you yener90, you made this device lots more useful!

PS: I noticed the Atom Z8300 has HEVC decoding support. And indeed I can play a 4k HEVC movie under Windows 10 with less than 10% CPU utilization with default player. HEVC vids encoded in 10bit or higher however are not HW accelerated!
Reply Support Not support

Use magic Report

Scalpos| Post time 9-27-2016 04:05:22 | Show all posts
Is there any chance could be used with Dual Boot Hi10 (not Pro version) ?
Reply Support Not support

Use magic Report

yener90| Post time 9-27-2016 07:56:57 | Show all posts
Try it out, i believe it should.
Only SuperSU is required. If you have any other root tool, it will not work.
Reply Support Not support

Use magic Report

Chuddywoody| Post time 9-27-2016 13:05:49 | Show all posts
This should work fine for the hi10 dual boot tablet.
Reply Support Not support

Use magic Report

Jerr| Post time 10-1-2016 06:13:12 | Show all posts
This worked flawlessly on my hi10 pro. Thank you very much! Can't live without my busybox
Interestingly, my device -- brand new from GearBest, model 529 (eu), serial 0123456789ABCDEF (haha.) -- seems to have had the bootloader unlocked from factory. The unlock script printed "Device is already in target state" and did not reset the internal memory on reboot, and TWRP booted without trouble.
I installed the filesystem utilities but haven't tested them. I was hoping to mount the Win10 partition but the eMMC does not appear in /dev/. I'm not very familiar with android... how would one mount the Win10 partition?
Reply Support Not support

Use magic Report

yener90| Post time 10-1-2016 11:57:19 | Show all posts
Edited by yener90 at 10-1-2016 11:58
Jerr replied at 10-1-2016 06:13
This worked flawlessly on my hi10 pro. Thank you very much! Can't live without my busybox
Interes ...

use ... ragon.mounter&hl=de
Managed to run stock android

Reply Support Not support

Use magic Report

Scalpos| Post time 10-3-2016 08:24:28 | Show all posts
Edited by Scalpos at 10-3-2016 08:49
Chuddywoody replied at 9-27-2016 13:05
This should work fine for the hi10 dual boot tablet.

Well, I gave it a try, no success... NTFS HD was not recognized. In order to prevent any data loss/corruption at Android level, I made a full TWRP backup.Unfortunately, when I restored it (I saved all available partitions, and so restored them all), I lost everything: both Android and Win10 systems were gone and the tablet was unable to boot properly (no power on, neither blinking led when charging it, I thought a moment I bricked it, but leaving it off a moment, I was able to power it on again). I probably messed up the UEFI settings.
I had to completely reinstall Android (flashing system.img) but the Win10 entry was missing in boot menu. With a bootable thumbdrive I did a backup of the Win10 partition, then reinstalled Win10 from scratch (in order to get back Win10's boot menu entry) and finally restored the previously saved partition...
I could try again but I do not seem to understand what's should be saved with TWRP, partitions wise, in order to restore the Android part without screwing everything ? So any idea about which partitions have to be selected in order to be able to have a safe restore point ? I quickly did some tests with System and Data partitions only, but it does not seem to be a good combination. It returned to the aforementioned boot loop state...

PS: I never had such unlucky experience with TWRP bkp/restore and my Android phones...
Reply Support Not support

Use magic Report

Opty| Post time 10-6-2016 04:24:30 | Show all posts
Thank you very much @yener90
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list