ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi10 Hi10 Pro Windows 10 Charging Issue

Follow Us

Hi10 Pro Windows 10 Charging Issue

[Copy link]

okthen|Post time:1-4-2018 14:41:30 View:14559|Reply:46

tron1| Post time 8-1-2017 05:13:33 | Show all posts
Edited by tron1 at 8-1-2017 05:15

Removed by mistake
Reply Support Not support

Use magic Report

unixbob| Post time 8-18-2017 08:00:26 | Show all posts
I have had some success with this problem.  I had the problem with a Chuwi Hi 10 Pro where it would charge in Android but not in Windows.  If I charge in Android and reboot to Windows then it continued to charge.  If I just tried charging in Windows the screen would pulse brighter and darker.

Unrelated to fixing the charging problem, I tried to connect Android to my laptop over ADB to update Android and my desktop PC wouldn't recognize the tablet.  No device at all in device manager.  A bit of searching and it was suggested that it's a USB 3 problem.  I ordered a USB-C cable that said it was only USB 2.0 compatible.  That fixed the adb problem and now my desktop can see the android tablet

However out of curiosity I rebooted the tablet into Windows and plugged the new cable into a wall charger and now it looks like the new cable has fixed the windows charging problem.

I've only just performed this test so need a bit more time to see if the issue is fully fixed.  But results are promising so far
this cable DID NOT work ... e?ie=UTF8&psc=1

This cable WORKED ... e?ie=UTF8&psc=1
Reply Support Not support

Use magic Report

jjuniormestre| Post time 8-26-2017 09:47:35 | Show all posts
Use a usb-c cable for usb 2.0 (the usb c for 3.0 does not work properly) I recommend the blitzwof cables (just cut the plastic and metal base around the plug slightly to fit all in the chuwi because the usb- C of the chuwi is slightly deeper than normal)
Reply Support Not support

Use magic Report

ChiefOtter| Post time 1-4-2018 04:18:34 | Show all posts
Edited by ChiefOtter at 1-4-2018 05:59


so I was encountering the same problem with charging under windows 10 with my Chuwi Hi10 pro. The 5v 3amp charger and cable originally sent to me by the seller appeared to be enough to charge under windows 10 if you used the default installation of the O/S and had the power preferences set to best battery life and not best performance.
After upgrading the O/S though this just stopped working and the battery would discharge on power albeit slower than on battery.

After reading through a bunch of thread and a bunch of others I purchased the following two items. Props to UnixBob for the cable recommendation! ... lpage?ie=UTF8&psc=1 ... 0_s01?ie=UTF8&psc=1

These two arrived today and I'm now successfully charging under windows 10 , power mode set to best performance. This machine has the latest win 10 updates as of the time of posting. As an aside I don't know how much the patch to fix the intel processor bug will effect win 10 on these type of devices not sure if the cherrytrail is in the same bunch of processors that are borked but that's a different matter.

I will be approaching my seller for a refund of the cost of the proper charger and cable. Maybe you guys can do the same.
Reply Support Not support

Use magic Report

ChiefOtter| Post time 1-4-2018 07:10:49 | Show all posts
Edited by ChiefOtter at 1-4-2018 08:08

Little update, charged from 38% through to 99% whilst set to best performance and streaming a 10hr video from youtube. The battery meter either stays at 99% , or will briefly report discharging..and then return to no message or say 3 mintues until fully charged. Never seems to make 100% but i'll take it charging at all under windows!

**update to the update **

So it did eventually hit 100% and then went back to discharging the battery even though plugged in. It got back down to around 95% and I didn't see it kick the charging back in. However the blinking charging light was fixed and not flashing so I'm not sure really what was going on. My next test will be to see how low the battery percentage has to get before it decides it needs to charge.  

I did however , reboot the tablet into android which started charging at 95%, rebooted back into windows and once again it started to charge claiming a 3hr and 38 minutes charge time for the remaining 5%. There's something very wrong with the O/S bios determination of the battery calibration.
Reply Support Not support

Use magic Report

2433red| Post time 1-4-2018 12:39:02 | Show all posts
Edited by 2433red at 1-4-2018 12:40

Hello! Hi my chuwi charger broke and I ordered a USB type c cable that doesn't fit in my chuwi at all. The cable that you linked, did you have to cut it or did it fit in the chuwi straight away?.  If you did trim it can you please give me me advice Step by step on how you did this? Thank you
Reply Support Not support

Use magic Report

ChiefOtter| Post time 1-4-2018 14:41:30 | Show all posts
Using the cables as/is without any modification. My tablet is a HQ64G421709XXXXX variant. Not sure if that'll make any difference.

My further observations are that the tablet will charge to 100% , drop down to 95% and then start charging again. That appears to be the current state with my tablet. Not sure if it'll be consistent across all tablets and variants.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list