ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi HiBook Pro Chuwi HiBook Pro NOT CHARGING on Windows 10 Home (Sc ...

Follow Us

Chuwi HiBook Pro NOT CHARGING on Windows 10 Home (Screen flashing)

[Copy link]

alexvaltchev|Post time:2-15-2017 03:28:26 View:4693|Reply:14

I just received my new Chuwi HiBook Pro, all packaged and nicely delivered. Everything was great until I plugged it in to charge.

The screen started flashing bright and dark every second, and when I click on the battery icon it says "Not charging".
I have the latest version of Windows 10 Home that came with, with all updates done to the latest.
I restarted the computer, did not help. I shut down the computer, did not help.
It did get worst, when it got belowe 5% of battery, a screen came up to plug in the charger. So I did... and started flashing and beeping and flashing and beeping... I got video to show, screenshots as well. Any information you need. The only time it does charge, is if the table battery die and turns off. Then I plug the charger and boot to Windows!

HOWEVER, on Android it works just fine. No problem there, is charging and is working fast. On Windows does not charge, and is kind of slow... So I came here and saw this post:
I then, reinstalled Windows, hoping this will help. And NO, same problem!!!
There was no any extra drivers installed or programs, apps... nothing! Just fresh install. PLEASE HELP! - Chuwi HiBook Pro not charing on Windows 10 Home - above 20% battery (part1) - Chuwi HiBook Pro not charing on Windows 10 Home - bellow 5% battery (part2)


Use magic Report

Domcat| Post time 12-18-2016 05:54:34 From the mobile phone | Show all posts
Hello. I had the same problem but I solved it with a better quality cable bought on amazon
Reply Support Not support

Use magic Report

alexvaltchev| Post time 12-19-2016 04:04:32 | Show all posts
OMG, you are correct! I did try my charger from my Microsoft Lumia 950 phone which is the same USB type C, 5V 3A, and it did work. IT was not just the cable, but the charger itself as well, BOTH defective! I had to buy high quality charger + cable to make it work. Chuwi so disspoainted...
Reply Support Not support

Use magic Report

TeutonJon78| Post time 1-7-2017 21:26:53 | Show all posts
I ran into this same thing. I don't think it necessarily relates to the quality of the charger, as I'm using a pretty good one that came with my phone and hasn't had any problems otherwise.

What I noticed is that the icon over the battery meter kept switching with the screen flashing. What seems to be happening is that the battery is toggling between charging and discharging, and the flickering is the backlight switching between the two power modes. I think there is either some bad driver, or some faulty hardware/manufacturing causing the problem.

If I shutdown and restart the computer, then it has no problems working the next time. I noticed that when I was reinstalling windows that it always triggered it as well, when the system would go into configuring the devices. Perhaps the battery driver is just getting into a bad state as well.
HiBook Pro (CM12.1, W10 1803)
Reply Support Not support

Use magic Report

Synimagic| Post time 1-9-2017 21:27:51 | Show all posts
I am having this problem tool -- I had it on a first tablet, I bought a second tablet and it worked fine until I unknowing installed KB3199986  which seems to cause the problem again.   This seems to be a Microsoft problem -- anyone know how to fix this. I have tried new cables and chargers and I have the same problem.
Reply Support Not support

Use magic Report

3NCORE| Post time 1-11-2017 13:37:25 | Show all posts
Just make sure you are using a good quality USB-C cable and a charger that outputs more than 2.0A (Mine is 2.4A). This should do the job. I had the same issue before replacing charger and cable. No problem with wether Android or Windows since.
Reply Support Not support

Use magic Report

alexvaltchev| Post time 1-12-2017 07:56:52 | Show all posts
I have a cell phone Microsoft Lumia 950 that comes with good charger + cable, output 5V at 3A and is working great. Never have that problem, it is charing  always at whatever state. However, usuing the original Chuwi charger even after replacing the cable I still get this problem. Somehow Windows is detecting lower power that the neccessery 5V 3A and is indicating it. The problem is not in windows, its in the cable and charger. I bought cheap ones from eBay for $15 and still get the problem, but with the original Microsoft one for my phone never get a problem!!!
Reply Support Not support

Use magic Report

bigboywatts| Post time 1-12-2017 14:31:24 | Show all posts
Hi. I have exactly the same issue!!

Can you tell me what charger you purchased and I will buy the same one. I really hope it fixes it for me too.

Thanks for your posts
Reply Support Not support

Use magic Report

alexvaltchev| Post time 1-23-2017 11:37:58 | Show all posts
I am using the original charger from my phone,  Nokia Lumia 950. The charger I bought online still isn't working with th included cable, so I cant recommend it to you. Screw you Chuwi, for cutting us short on it. Why being so cheap OMG! Sorry dude, but so far only my phone charger works, the other 2 I bought turned out NOT to be 5V at 3A and that is exactly what you actually NEED!
Reply Support Not support

Use magic Report

solarisrulez| Post time 2-15-2017 03:28:26 | Show all posts
Mine is also not charging, see my YouTube video that I made with 4 different charging methods:

00:00 - Charging with a 2A power bank
01:15 - Charging with the 3A Chuwi USB-C factory charger and cable that I got with the tablet
02:53 - Charging with my 2A OnePlus2 charger and USB-C cable
03:28 - Charging with a Sony 1.5A charger with OnePlus Micro-USB to USB-C adapter

Please help!

Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Return to list
Quick Reply To Top Return to the list