ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi8 Pro [CM13]Marshmallow 6.0.1 for Chuwi HI8 Pro

Follow Us

[CM13]Marshmallow 6.0.1 for Chuwi HI8 Pro

[Copy link]

Fernando823|Post time:12-22-2017 08:34:26 View:10236|Reply:87

stas2z| Post time 12-21-2017 13:26:53 | Show all posts
Edited by stas2z at 12-21-2017 13:43

ok, ic some fresh info for me, 10x
it'd be brilliant if you will install cm13 rom from this thread that works for your hardware and also dump dmesg
and also
  1. adb.exe shell cat /proc/interrupts > irqs.txt
  2. adb.exe shell ls /sys/bus/acpi/devices/* > acpi.txt
Copy the Code
from a working rom
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-21-2017 14:23:04 | Show all posts
Reply Support Not support

Use magic Report

stas2z| Post time 12-21-2017 15:04:57 | Show all posts
Edited by stas2z at 12-21-2017 15:17

@Localhorst86

ok, backup system/boot first

flash this one and check tp/cams

https://yadi.sk/d/CcmwgHCY3QqeFT
if it still dead, show me dmesg again





Reply Support Not support

Use magic Report

Localhorst86| Post time 12-21-2017 20:56:34 | Show all posts
TP and cam didn't work:

https://pastebin.com/N4xxqShi
Reply Support Not support

Use magic Report

stas2z| Post time 12-21-2017 22:25:19 | Show all posts
ok
both cams are init fine this time with proper port/lanes/order
but im not sure about TP, your dmesg is not from start, probably it's missing some init messages
Reply Support Not support

Use magic Report

stas2z| Post time 12-21-2017 22:56:06 | Show all posts
Edited by stas2z at 12-22-2017 01:03

@Localhorst86
hm, seems like silead driver occupies the i2c bus, so ive recompiled it without silead, please check reuploaded patch https://yadi.sk/d/CcmwgHCY3QqeFT
also ive added a camera tweak for atomisp module, probably it will help to bring it up
upd:
i found another chipone driver
here the the kernel to test with this driver enabled
https://yadi.sk/d/ZpKj_txD3Qr8ac
you can boot it without flashing with cm13 installed
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-22-2017 01:08:06 | Show all posts
Edited by Localhorst86 at 12-22-2017 01:24

@stas2z: the patch you provided with https://yadi.sk/d/CcmwgHCY3QqeFT makes the touchscreen work on 608 models. The camera still says it can't connect. Since I am currently not at home I can not provide a dmesg log right now or test wifi properly, but it does pick up the company wifi.

Once I get home I will be happy to give you another dmesg log
EDIT: I'll also test the third patch you uploaded once I get home.
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 01:15:35 | Show all posts
@Localhorst86
great news, i will wait for dmesg
please spend yet another minute to test new driver, ive made a patch with it to flash via twrp https://yadi.sk/d/CpfB1yTP3QrAMY

if it will work too, i will be able to enable both drivers (silead and chipone) in the one kernel to make my kernel compaible both with 608 and 708
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 04:46:42 | Show all posts
Ok, nevermnd, ive modified both drivers to load only if matching acpi record exists
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-22-2017 08:34:26 | Show all posts
Edited by Localhorst86 at 12-22-2017 08:57

The last one you posted didn't have working TP

here's the dmesg for the only working kernel with TP but without camera: https://pastebin.com/HpW1fs8g

EDIT: btw, I'll keep using the build as is (without working cameras) for the next few days. Don't feel like you need to put a lot of effort into this. I would say it's perfectly usable without cameras, please enjoy your holidays.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list