ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi8 Pro [CM13]Marshmallow 6.0.1 for Chuwi HI8 Pro

Follow Us

[CM13]Marshmallow 6.0.1 for Chuwi HI8 Pro

[Copy link]

Fernando823|Post time:12-22-2017 14:50:18 View:10237|Reply:87

stas2z| Post time 12-22-2017 08:58:56 | Show all posts
ok, last TP related test
https://yadi.sk/d/-rI6OfDl3Qs5Mi
it's a kernel with silead and working chipone drivers enabled with acpi matching support
if it works for you, i will include it both to my kernel by default

Reply Support Not support

Use magic Report

Localhorst86| Post time 12-22-2017 09:25:56 | Show all posts
Edited by Localhorst86 at 12-22-2017 09:28

unfortunatelly, that doesn't work, either

https://pastebin.com/rbis3vg8
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 10:45:48 | Show all posts
Edited by stas2z at 12-22-2017 10:48

yeah, it was a my fault, ive forgot to set proper option in config (built non-acpi silead driver)
but after enabling it i found some acpi detection issues (and seems like thats why another driver don't wanna work), so i will fix em tomorrow maybe
about cameras, logs are brilliant and it works from the kernel side, need to check android side to find how to fix it
can yo give me a link to the official stock android firmware archive that 100% works for your tablet?
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 10:58:30 | Show all posts
p.s.
anyway, if it'd be not so time wasting for you, give me yet another try result with this kernel
https://yadi.sk/d/-rI6OfDl3Qs5Mi
it's just a workaround with loading order of non-acpi drivers, but it works for me (silead AFTER chipone) and hope it can work for yr hardware (silead have not gonna occupy i2c before chipone loads)
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-22-2017 13:56:26 | Show all posts
You're not wasting my time. If anything, I am wasting yours.

The latest kernel for TP doesn't work either.
https://pastebin.com/vn1suEFZ

Unfortunatelly my stock twrp backup doesn't want to work anymore and I don't have a twrp flashable image for the stock firmware. I was never able to get the  Chuwi android stock firmware to flash. So the image I am using that has working cameras is the one from the first page of this thread.

However, the one I had working 100% originaly was the official stock firmware linked in this thread:
http://forum.chuwi.com/thread-1157-1-1.html

http://www.mediafire.com/file/o8 ... ro_64bit_August.rar
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 14:25:34 | Show all posts
Oh shi
Youve booted build #108, but the latest is #111, that i wanted to test, probably i uploaded a wrong file, damn
Will upload proper image in a few minutes
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 14:30:21 | Show all posts
Edited by stas2z at 12-22-2017 14:32

no, the image _here_ is #111seems like it's not my fault this time

plz check, it have to be 9525248 bytes long


upd. yeah, your previous log is for #108 too
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-22-2017 14:41:52 | Show all posts
How can I make those TWRP flashable? Apparently I can't get them to only boot using ADB.
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 14:43:16 | Show all posts
3.0.2.0 can flash images, not only zips
Reply Support Not support

Use magic Report

stas2z| Post time 12-22-2017 14:50:18 | Show all posts
Screens...
IMG_20171223_015103_836.jpg
IMG_20171223_015106_606.jpg
Reply

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list