ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi8 Pro [CM13]Marshmallow 6.0.1 for Chuwi HI8 Pro

Follow Us

[CM13]Marshmallow 6.0.1 for Chuwi HI8 Pro

[Copy link]

Fernando823|Post time:12-25-2017 02:39:32 View:10261|Reply:87

Localhorst86| Post time 12-23-2017 00:09:11 | Show all posts
Edited by Localhorst86 at 12-23-2017 00:13

Ok, I tried flashing the latest one again, here's the pastebin:
EDIT: TP didn't work
https://pastebin.com/xNkUdscv

note: i stichted two dmesg logs together at approx. the 16 second mark since after a full boot dmesg was already filled and purging old entries.
Reply Support Not support

Use magic Report

stas2z| Post time 12-23-2017 01:28:54 | Show all posts
damn, gslx68X (silead tp) occupies bus again hah, what an annoying driver
ok, will work on acpi detection to prevent silead touch driver start when it's not present in acpi table
Reply Support Not support

Use magic Report

stas2z| Post time 12-23-2017 11:38:56 | Show all posts
ok, it's a final (99%) attempt to get both TP drivers to be in a one kernel
https://yadi.sk/d/-rI6OfDl3Qs5Mi

ive built silead driver as loadable module and init it after userspace is ready by checking sysfs acpi table, and it loads ONLY if proper record found, ive tested it
chipone driver still statically built, and run at late init, it makes 3 attempts to start and exit if fails (for silead hw revisions). So im almost sure this workaround will work
Reply Support Not support

Use magic Report

stas2z| Post time 12-24-2017 02:24:39 | Show all posts
Uploaded updated Lineage build with increased hardware compatibility
https://yadi.sk/d/Y_FqDIET3Qtqv7

* silead and chipone touchpanels supported
* rtl8723 and bcm43438 radio drivers included
* ov2680 ov5648 and gc2355 camera drivers included
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-24-2017 12:18:35 | Show all posts
Unfortunately that boot image and flashable OS image doesn't work on the 608 model. I get bootloader error code 01 and need to return to recovery to Flash the older working image.
Reply Support Not support

Use magic Report

stas2z| Post time 12-24-2017 12:40:20 | Show all posts
Edited by stas2z at 12-24-2017 12:54

yeah, shame on me, sorry, it's my fault, ive accidentally damaged boot before uploading
will fix it in a few minutes
EDIT: redownload it and try again
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-24-2017 23:33:30 | Show all posts
OK, the latest build boots and works. TP is working, however cameras are not. One thing I noticed (in the previous build as well): the physical home button seems to register in android but it doesn't act as a home button. Using an app called "button mapper" I can assign the key to act as a home button, though.
Reply Support Not support

Use magic Report

stas2z| Post time 12-25-2017 00:14:54 | Show all posts
Edited by stas2z at 12-25-2017 00:18

nice to hear TP is working fine

about buttons
have you have to add it as "add button" in the button manager? if yes, what code it shows when adding? "HOME", "MOVE_HOME" or anything else? and tell me a number in ( )
and show me dmesg please to check cameras
Reply Support Not support

Use magic Report

stas2z| Post time 12-25-2017 00:46:08 | Show all posts
ok, seems like i found an issue with home button
ive unified key codes for both drivers, so it should work
if you don't wanna reinstall it, you can fix it for your tp locally

remount /system to read/write access
adb.exe shell mount -o remount,rw /system

then just use stock file manager in root mode to modify /system/usr/keylayout/Generic.kl
find a
  1. key 102 MOVE_HOME
Copy the Code
entry and make it
  1. key 102 HOME
Copy the Code


also ive reuploaded a build, to prevent home button mess in future
Reply Support Not support

Use magic Report

Localhorst86| Post time 12-25-2017 02:39:32 | Show all posts
Edited by Localhorst86 at 12-25-2017 03:25

here's the pastebin for the dmesg:

https://pastebin.com/PJqqgGgK

Yes, the button is called MOVE_HOME
I'm gonna try modifying the keylayout.

Update: successfully changed the keylayout. Home button works as expected now.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list