ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 SD Card problem (partially Solved)

Follow Us

SD Card problem (partially Solved)

[Copy link]

Elle|Post time:10-16-2017 01:11:38 View:13254|Reply:67

AdamKosterski| Post time 8-29-2017 13:06:08 | Show all posts
Sorry guys, if this question seems daft, but I presume you all know that the card goes in upside down and that it has to be pushed in all the way until it clicks in?

It's probably stating the obvious but you never know, maybe some of you might be doing it incorrectly, best, A
Reply Support Not support

Use magic Report

Rain44| Post time 8-30-2017 20:48:52 | Show all posts
It was working perfectly at firts.....then all of a sudden the card would not read any more. So what changed ? Was is WINDOZE UPDATE???? I HATE THAT THING!!!

Does anyone know any program or tweak to STOP WINDOZE UPDATE ???
Reply Support Not support

Use magic Report

Motobot| Post time 8-30-2017 22:16:57 | Show all posts
Rain44 replied at 8-31-2017 07:48
It was working perfectly at firts.....then all of a sudden the card would not read any more. So what ...

Most likely this is not related to Windows updates. Accept the fact that you have lost the cardreader forever and calm down.
Reply Support Not support

Use magic Report

William| Post time 9-22-2017 15:04:22 | Show all posts
when I go to the link for the drivers it just downloads some kind of driver repair scanner software, not the drivers themselves. Am I missing some trick to download just the drivers? thanks!!
Reply Support Not support

Use magic Report

technisol| Post time 9-27-2017 23:05:31 | Show all posts
Edited by technisol at 9-27-2017 23:23


I have to disagree.  I think the problem is 100% software for at least the majority of users.  My card reader worked perfectly all the way through updates from the version of Windows 10 that was originally installed on it for over a year, with 64 & 128GB cards.  Never a problem.  When an MS update screwed the pooch on my machine and I ended up having to "nuke and pave" and then install your Spring Creator's Update package is when the issue popped up for me.

I'm not blaming you in any way, in fact I was very grateful to find your package and not have to jump through hoops with separate driver installs until I wanted to scream, but there is some fundamental difference that was kept all the way through every update I installed that somehow was no longer there in the version you supplied, again, not your fault.  I contend that either M$ introduced a bug into Win 10 code at some point past the original version of Win 10 that came on these machines last summer, of a type that only gets introduced with apparently a full nuke and pave type situation, i.e., my contention is that whatever code differs was never updated or changed from the original version of Win 10 if one only installed Windows Updates OR Chuwi had some non-standard code or files in the original install that are no longer present in versions sourced directly from M$.  Those seem to really be the only plausible explanations for why it broke on my machine at exactly the point where I had to nuke and pave and re-install, granted a sample of one is not ideal, but it's what I have to work with.  I believe there is a difference in code or modules running on a machine that has only received Windows 10 updates and one that has had a newer version of Win 10 downloaded and installed.

My conjecture is the difference in code occurs above the driver level and somehow functions with the 8.1 drivers.  Perhaps there is a Chuwi file floating around in the original version of Windows supplied that no one has spotted the need for if installing a clean M$ version of Windows 10.  If the file was not a normally updated part of Windows 10, I could see how Windows Update might miss updating and changing it with normal updates if they are only interested in updating the files that need to be changed for newer versions and the "Chuwi patch" was introduced at a low enough level that it never got updated by Windows Update.

It's remotely possible it's coincidence, but of a highly spurious nature.  If someone had the time and the machine to do it on, it would be a very interesting experiment to see if one could find the original version of Win 10 that was supplied on the machines and install it to see if it resolved the issues with the SDHC on an Hi12 with the issue.  If it doesn't then I'd have to contend that it was somehow involved with an ACPI BIOS change that only comes about if one nukes and paves, rather than just installing updates from the original version which worked with (nearly?) everyone's SDHC card readers.

At least that's the way it looks now.  I think people need to get after M$ and cause enough public outcry to get them to devote some resources to resolving the issue or we need to lob the ball back into Chuwi's court if it can be proven there was some persistent jiggery-pokery done in the verson of Win 10 originally supplied to get the SDHC card readers working above the driver level.  The trouble seems to be that the party at fault has little or no interest in resolving the issue.
Well, that's my story -albeit pure conjecture, and until I hear something more plausible, I'm sticking with it!
Reply Support Not support

Use magic Report

witman| Post time 10-6-2017 00:53:25 | Show all posts
In BIOS change to PCI mode
Chipset- southbridge - SCC SDIO support
Chipset- southbridge - SD Card support
Reply Support Not support

Use magic Report

doodzilla| Post time 10-6-2017 05:39:01 | Show all posts
Man, whoever solves this issue would be a bigger hero than Avengers and Justice League combined. Sorry for the crap English. Just making a point hahaha.
Reply Support Not support

Use magic Report

technisol| Post time 10-7-2017 13:30:18 | Show all posts
Edited by technisol at 10-8-2017 10:53

Not a solution.  I tried both settings, thought I had set one once before from another thread, but both were set as  ACPI.  So I set them to PCI, verified they were set after restart and still had problems if I went to latest 10.whatever drivers...  The mystery continues.  Where the hell are Fred, Daphne, Velma, Shaggy and Scooby-Doo when you need them?  
Reply Support Not support

Use magic Report

technisol| Post time 10-12-2017 20:16:48 | Show all posts
Edited by technisol at 10-12-2017 20:18

More mystery SDXC jazz tonight...  I booted my Hi12 and the 128GB SDXC would not work with the drivers it worked with last time it was shut down?   Very odd.  Rebooted and Win 10 performed an update to Version 1703, OS Build 15063.674: a KB4041676 cumulative update...  Still no SDXC card.  Tried setting it back to the Win 8 drivers that previously worked, the 6.3.9600.16408, rebooted and still no dice...

Stumped, so I uninstalled the three SDXC device drivers,but didn't delete them, expecting it to boot back up with the 9600 series from Win 8.x installed.  Imagine my surprise when it rebooted and SDXC worked, but now with newer 10.0.15063.608 drivers!  So far odd, but it's apparently working with the new drivers...

WEIRD!  But, maybe there was something to that update?  Interesting anyhow.  I'm not sure if "May you live in interesting times" is really a Chinese curse or just apocryphal, but with respect to the Hi12 it may just be!
My best to you all.
Reply Support Not support

Use magic Report

witman| Post time 10-16-2017 01:11:38 | Show all posts
That was a solution for me until latest Windows update that now places in Device manager on third place some SDA driver...
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list