ChuWi Forum»Forum Chuwi Notebook Discussion Chuwi Lapbook 14.1 Query for custom OS boot fix

Follow Us

Query for custom OS boot fix

[Copy link]

koziolku|Post time:12-13-2017 06:56:43 View:887|Reply:8

Dzień dobry, good day.

I bought a LapBook for someone recently. Have been tinkered with it for a while and realized that there are different revisions of hardware. Mine is as follows:
Specific UEFI version tells me that I will not be able to achieve access to booting Linux option in firmware setup, since I haven't got proper firmware update for my revision for my hardware. There is a UEFI update for LapBook 14.1, but for different device revision, since the UEFI version symbol is different than mine - so I think it won't be able to flash it, and even if I'd be, I'd rather brick my device as some users stated they did.
I though that I will be able to run at least Defender Offline, which is Microsoft's bootable AV solution, but no luck - after the first try, following error appeared:
What I want to ask (demand) for is to make user able to boot Linux (and other systems) from USB on every 14.1's revision. I stated it as a demand, because right now I can't even boot AV software besides system, which is considered as a security impairment. I have no idea if there's any workaround for this, but I'd love to see possibility of booting custom OS on a computer (not a tablet).

I sent my doubts via contact form on Chuwi website, would like to recommend others to ask it for, because right now we even can't boot proper antivirus software. :-(

Use magic Report

Ernst| Post time 8-17-2017 04:49:48 | Show all posts
Yep. The LapBook 14.1 (code name NA14) has become quite a mess. There are now at least 3 different versions and the last version (probably the one you have) has a bug that in combination with the Intel HD Graphics driver, the CPU uses around 6 Watt when idle... with a battery life of only 3 hours as a result. This has been disclosed to Chuwi, but no answer yet.

Don't try to flash a BIOS of the older revision; I doubt it is possible, but if it is you will brick the system.

If you have the latest revision, there is also no M.2 slot for an SSD.

To install any other OS you indeed need a BIOS setting to disable Secure Boot. The first two revisions have this setting in the BIOS, apparently the latest revision does not have this setting?

As I said; it is a mess of three different revisions with all sorts of different BIOS versions... and no statement from Chuwi whatsoever about differences between the versions of hardware and BIOS. Could be that the OEM (Hampoo) simply does not inform Chuwi...
Reply Support Not support

Use magic Report

koziolku| Post time 8-18-2017 02:59:25 | Show all posts
Hello, @Ernst,

No, I did not want to flash UEFI/BIOS right now - as I said, I am aware of the things you mentioned. I read official download topic, and as people might write things for whatever reason, I believe that there is no clear statement about all the things that need to be done.

About the Secure Boot - I have this option stated as Disabled, as picture in attachment shows.
In this situation I am not sure if I will be able to reinstall Windows, either from official source or from Chuwi's website. I realized lack of M.2 slot as well, but it is not as important as the possibility of recovering the computer to proper state.

So, I repeat: Chuwi service, please repair said bugs in all revisions' software (either Windows and UEFI). It's nothing good that you remove the M.2 slot from newer revisions, but the inability of repairing or recovering the software with legacy methods is even worse.
Reply Support Not support

Use magic Report

baron1| Post time 8-20-2017 12:31:24 | Show all posts
Hello, I have also recently purchased this laptop and i can see that there is at least 3 types of hardware revision and 3 types of BIOS that can be installed.
The one you have (2nd version) and the one i have (3rd version) seems cannot run Linux because there is no option in the BIOS menu.
Also there is other people trying to chase this in this thread:

But there doesnt seem to be a response from Emily or Chuwi
Reply Support Not support

Use magic Report

baron1| Post time 8-24-2017 07:48:43 | Show all posts
any update ?

Use magic Report

opla| Post time 8-25-2017 05:06:19 | Show all posts
I am eager to hear news on the issue, before returning the lapbook to Gearbest
Reply Support Not support

Use magic Report

baron1| Post time 8-29-2017 11:30:44 | Show all posts
we are all waiting, still no response.
Reply Support Not support

Use magic Report

tom55day| Post time 9-17-2017 01:46:43 | Show all posts
there will be no response on the power management buy.  I'll eat my hat if they do.

Even if they reply it will say re-loads windows
power off/on
update drivers

just junk templated answer that re nothing to do with the issue.
Reply Support Not support

Use magic Report

baron1| Post time 12-13-2017 06:56:43 | Show all posts
Still no update. Seems this laptop is a lost cause !
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list