ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi12 Chuwi hi12 won't boot - no LED - battery ok

Follow Us

Chuwi hi12 won't boot - no LED - battery ok

[Copy link]

geoffroy77|Post time:12-14-2017 22:34:58 View:936|Reply:6

Hello,

I have been reading through the forum and tried multiples things but I am still stuck, so I am hoping someone might have some tips for me.

WHAT HAPPENED?
My wife used my tablet last week (in windows 10 mode, not android). I think she initiated shutdown but closed the lid before it completed. She left it for the night with a USB mouse plugged. In the morning when I took the tablet, the LED was flashing. I long pressed the power button and then the LED stopped blinking. Since then I have not been able to boot the tablet.

WHAT IS THE SITUATION
LED stays off, even if I plug the tablet to the charger
I have tried the 3x press long press 15sec, 30sec, press volume  up with power.. nothing worked
I opened the case to check the battery: it is charged (I measure 4.1V on the red and black wires going from the battery to the board)
I tried to plug a keyboard to a usb port (to do the F7 keypress trick) but I do not think it is being powered. When I plugged my phone to the usb port, I see the USB giving power for 1sec, then no power for 1 sec, then again power for 1 sec, etc... It looks like the USB ports are not giving constant power, which is why the keyboard is not working...

I am about to give up as I think I have tried every possibility I could read about here... If anyone has a suggestion, that would be very welcome!

Thanks!
G.
Reply

Use magic Report

geoffroy77| Post time 12-14-2017 12:40:52 | Show all posts
Hi everyone. So following the advice I ordered the tools needed and succesfully reflashed my bios... Unfortunately the problem persists.

Battery is charged and providing power to the MB. I have the feeling something is preventing the tablet to switch on. To show it I have made a small video with a led light connected. As you will see if I press to power on, the light is blinking. If I long press to turn off, it stops.

https://youtu.be/CWaoF2gef7U

Anybody some more idea or shall I just dump it?

Thanks!
G.
Reply Support 0 Not support 1

Use magic Report

hmcheng542| Post time 11-6-2017 13:00:37 | Show all posts
Same thing happened to mine, not a battery depletion issue. Reflashing the BIOS chip using methods posted in this forum fixed it. Good luck.
Reply Support Not support

Use magic Report

technisol| Post time 11-7-2017 06:59:37 | Show all posts
Try charging just the tablet for a while(at least an hour) then do a long press of at least 20 seconds, followed by three quick presses and see if it boots.  Rinse and repeat while plugged in.  Do this without the keyboard connected as it will leech power.  Someone else wrote in another thread to tape the power button down and charge for a while as well...  I have not tried this, but when my Hi12 got stuck last year the method I posted above worked.  Best of luck.
Reply Support Not support

Use magic Report

ruetino| Post time 11-14-2017 08:35:10 | Show all posts
hmcheng542 replied at 11-6-2017 13:00
Same thing happened to mine, not a battery depletion issue. Reflashing the BIOS chip using methods p ...

hi bro,

I'm having similar issue, being different is where my battery was drained.

Would you point me to which BIOS that you've flashed? Dying to give it a try.
Reply Support Not support

Use magic Report

hmcheng542| Post time 11-15-2017 09:28:34 | Show all posts
BIOS can be downloaded from this forum, here:

https://forum.chuwi.com/thread-1160-1-1.html

Make sure you pick the correct one. My H12 is a Z8300 dual-boot, the original BIOS has worked out fine.

It is kinda weird as far as the battery, mine was fully charged at 4.2v, still could not boot up despite all sorts of button pressing. A drained battery might be a different issue; although a corrupt BIOS seems the common denominator.

Good luck flashing!
Reply Support Not support

Use magic Report

technisol| Post time 12-14-2017 22:34:58 | Show all posts
Well, it's a long press for 15 seconds followed by three quick presses...   I'd try taping the power switch down and charging for a while, but if it's charged, it's charged.

When mine went kerplooey, it took around 45 minutes of trying that sequence while charging until it started up, but my battery was seriously depleted, 0 when it finally booted and that after 45 minutes of charging and trying the sequence.  Been fine ever since, but I am very careful not to close the lid before it switches to fast charging indicated by the LED flashing.

The only other thing I can think of is that someone was recently quoted $85 for a motherboard from Chuwi.

Best of luck!
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list