ChuWi Forum»Forum Chuwi Notebook Discussion Chuwi Lapbook 14.1 Rev3 touchpad fail

Follow Us

Rev3 touchpad fail

[Copy link]

oriol.herrera|Post time:12-10-2017 12:41:45 View:368|Reply:2

Hi all,

Last week I bought Lapbook 14,1. When I turn on first time it works all perfectly but the second time touchpad gets die. Thinking about what could be the problem I dissasambled it and i revised the flat connector. When I turned it on it still die I try to make a bios reset in order to discard bad bios configuration bus still die. Next thing I tried is to disconnect motherboard battery supply in order to make a hard reset. When I reconect it and tryied i fond that it works perfet but 2 days later gets die another time. Now i've put myself in engineer mode and I analizing wiring and i can see that the battery cable and flat touchpad cable are crossed, thining that it could make noise interferences knowing the sensitivity of touch panels I've decided to shield using aluminium foil the battery cable.

Anyone have the same problem? I want to solve it, if I have more information I could solve it better.

I will keep reporting.

Use magic Report

oriol.herrera| Post time 11-7-2017 11:55:48 | Show all posts
Hi all,

Cable shield doesn't worked. Now I see that in Win 10 in device manager that there is an I2C touchpad that have troubles... I'm reinstalling windows now.

I will keep reporting
Reply Support Not support

Use magic Report

Stellage| Post time 12-10-2017 12:41:45 | Show all posts
Did reinstalling Windows work? Did you do a Factory Reset?
Same problem with the I2C device in device manager.

Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list