ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi Hi8 Pro [HOW TO] Solve SD Card Not Recognized

Follow Us

[HOW TO] Solve SD Card Not Recognized

[Copy link]

Wichu|Post time:4-22-2018 11:43:54 View:2357|Reply:8

Edited by Wichu at 4-18-2018 11:12

Hello Everybody,
Please do not use this post to discuss, ask or answer, because it is going to extend long and longer and at last, at the 15th page it could become confused. Its purpose is to be able to add more precisions, perhaps version 2, version 3, etc. when necessary
I have created a post aside: “About: HOWTO solve Sdcard not recognized”, where I would be glad to receive your impression, result and advices, for me to write here-after the “following version” when needed.


And please reserve here the place to do so.
Thanks in advance.
- Do call me ‘witch oooo’ (With you) -
Reply

Use magic Report

Wichu| Post time 4-18-2018 11:28:03 | Show all posts
Edited by Wichu at 4-18-2018 13:08

PREFACE :
I bought at +mas 2017 a Chuwi HI8 pro, Dualboot Win10_32bits, (build firmware Oct2017)
The tablet was not a real need and surely not for work (I already owned Laptops for that) but for its so low price, it is a nice gift from me to myself !
I am pretty happy of this purchase (except for the speaker which is a bit weak).


I am French (and obviously  my tablet is set in French language). So, for explanations I will "talk much by images" and sometimes will indicate things in french, but pictures will also help.
I apologize if my English is not that fluent. But it's also voluntary because easierly translatable in Google translate page (copy and paste this link in it)

My skillful is rather in Web developing (HTML, PHP, SQL etc.) than in system language but I am an inquisitive person and especially, I have time to read,read, read !

I have found “A” solution to solve this SD problem,
but it is surely notTHE” ULTIMATE SOLUTION, 100% EFFICIENT  
I (we) must surely investigate more, and after reading tons of same issues in hundreds forums of all brands (this one of course, but also Asus, Dell, Lenovo, HP, etc.), I think the solution will only pass if we eliminate quickly some nonsense that I have raised, to focus on "the" real cause (if any).
Thus, even if corrections proposed would take only some couple of seconds, please understand that it is much more important to understand things and WHAT NOT TO DO (repeat or waste time).
(in myjob, we cannot escape from unattended reaction or bug while programming, to be efficient in debugging, the first step is to determinate where IS NOT the problem, rather than where is the problem)

It is why,instead of going directly to solution, containing of this guide begins first:
   1. WHAT TO KNOW ?
   2. WHAT NOT TO DO ?(rather, not to repeat)  
   3. To lead to: WHAT TO DO, TO SOLVE SD PROBLEM IN WINDOWS ?
          VERSION 1: is an "emergency first aid medication", taking perhaps 15 seconds to perform.
   4. Following by: WHAT TO DO, TO SOLVE SD PROBLEM IN ANDROID ?
   5. A paragraph apart, to precise, in case IF IT DOESN'T WORK  ?
   6. Then: WHAT TO DO IF THIS “QUICK SOLUTION” DOESN’T WORK ?
          VERSION 2: is for rebellious system that first aid hasn’t cured… which requests thus, surgical operation in the bowels of its system…

Thanks in advance to take time. Let’s go...
- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

Wichu| Post time 4-18-2018 11:56:24 | Show all posts
Edited by Wichu at 4-18-2018 12:00

1. WHAT TO KNOW ?
As there are so many Sdcard types (SD, SDHC, SDXC), Windows in a good state of mind, has wanted to regulate this matter and upon arrival of Windows 7, he begun. Following by numerous complaints from manufacturers (among them, well known Sandisk who saw his card unrecognized). A patch has been made immediately.
But Windows has still continued (fortunately) its perpetual search for better work.
Here is what I found from somonte in domain:
"Realtek’s USB card readers can be stubborn sometimes.
The issue that happened for quite a few users was that when they inserted their card, everything works. However, once you browse the media or start copying files, the media is lost. The SD card is mounted again after a short while, and then unmounted, resulting in an endless loop. This happened with quite a few of Realtek’s USB 2.0 and USB 3.0 card readers, and the cause for the problem are the drivers. This situation usually occurred on devices by Medion, which is a Lenovo subsidiary, and the KB3156421 Windows update was the cause behind the problem.
However, the problem appeared again with the Windows 10 Anniversary Update.
The cause of the problem, this time, was Realtek’s drivers, and with releasing the 10.0.10586.31225 driver, they fixed the issue.


Anyway, even if the system doesn’t use Realtek (I still have tried…), this article reveals 2 remarks:

  • Windows has wanted to "do something" while writing the Window 10 system and results has surely worked very fine ... in laboratories !
    But it cannot know in advance which hardwares (processors, keyboard, display, USB, etc ...) will be chosen by manufacturers to be mounted on motherboards. Which may sometimes cause conflicts !
    i.e. a new file, controlling SDcard “sdport.sys” appears only with Windows 10 (It doesn’t exist yet in Win8). It surely improves something ? That perhaps some motherboards  must be adapted with?
    Nota: while preparing this post, I once more had a discreet update (last week). The 3 files involved in this debate (dumpsd, sdbus, sdstor) have climbed from 16299.248 to 251. This has still not corrected SD problem ! (Not really true… You will see later)
    Also, I have read that Windows doesn't want... Doesn't know... Is not able to... Please. (I am defending my job)
    I think they are rather working to...


    (I have read article stating that most first range motherboards, even having 64bits core still turn with some 32bits parts. Thus, as bright as a “standard” Windows 10 can be, it may certainly not turn the same way on so different motherboards ? Please do not accuse Chuwi (the Hi8 uses such a motherboard), almost all manufacturers  (perhaps 2 or 3 times more expansive) have met same problem of SD disapparence)

  • 2nd remark, when someone is "big" enough like Realtek, he can complain to Windows for corrections !
    And only some, like Samsung are strong enough to be able to intervene directly in the source code to adapt it to their components.
To carry on investigation not blindly, let’s continue to … WHAT NOT TO DO !
- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

Wichu| Post time 4-18-2018 12:57:20 | Show all posts
Edited by Wichu at 4-19-2018 15:03

2. WHAT NOT TO DO ?
2.1 Please stop stubborn with this MS CUSTOM SDBUS DRIVER in Bios setting !

It is somehow a big non-sense.
By ENABLE this option, you are thus promising to feed the beast with something "custom" (means personal  driver one ? Manufacturer's one ? "MS" in this context doesn't mean strictly or only "Microsoft", but rather drivers developed for "Windows world" which is obviously "Microsoft world".
What are you giving to the system to eat ? NOTHING !
If actually, factory setting is "Disabled", it simply means that manufacturers has no "custom driver" to propose yet (and expect Windows will do)!

Another non-sense: I haven't seen anywhere on web, or anybody saying that, in DUALBOOT (thus my Hi8), when requesting BIOS (rather UEFI):
•    While starting Windows, you will fall in "MENU BIOS WINDOWS SIDE" ! Which is slightly different with…
     (The MS Custom SDbus Driver, is of course, effectively present on this side: Advanced/System component tab)

•    While starting Android, you will fall in "MENU BIOS ANDROID SIDE"… Which has more or less supplementary options.
And Android as we all know, uses Google/Linux coding. How could a "MS" CUSTOM …  EXIST in this world ??? (remind, MS = Windows world?)

More amazing when I read advices to revert "OS IMAGE ID" option from "Android" to "Windows" ??? This option in this context, only shows informations of the "other side" (windows). Those values, if changed, would not and CANNOT be saved ! Because informations, are exactly what they are supposed to  be:
only INFORMATIONS  !

Nota:
for people who want to continue in this matter, please know that I have already tested to ENABLE this option with:
- ALCOR Multi card Driver, REALTEK one, RICOH one and JMICRON one
None of them has given any difference. Thus, try others ones
(I admit that "sometimes", after doing "something", people have said the tablet suddenly "sees" SDcard.
I think, it could be explained by … What will be seen the "emergency first aid").

                                ///////////////////////////////////////////////////////////
                               // By the way, as we are in BIOS discussion, please identify the option "Fastboot".
                               // Factory setting is on disabled, which is a good thing.
                               // We recall for it soonly.
                               ///////////////////////////////////////////////////////////


2.2 Please do not re-flash the BIOS:
I correct myself: I do think that the BIOS is problematic.
So, YES, we may (or must) "update"… but with another (new created) BIOS.

Re-flashing (not to mention the risks, error of versions, etc.) …to re-load the same Bios ? What for ?
To corrupt a bios is almost impossible (especially if you have never entered in it, which was my case before this problem). Unless you have destroyed it by doing something not recommended ?

Apparently, I have read that people who have done, haven't improved anything.
If you still want to do, be careful with version. Do not mix-up  Z8300 and Z8350 processor firmware.
My Chuwi HI-8, is Z8350, and actually there is no newer Bios Firmware.


2.3 Please do not waste your time to update Drivers again and again.

Your system has already got the most uptodate Drivers… of "STANDARD" WINDOWS !
The perpetual "Error code 10" (driver cannot start) in Device Manager, doesn't means problem on "this" Driver, but inform of a conflict between 2 or more drivers/hardwares !
i.e. Everybody has experienced this "Yellow triangle error" on sdstor.sys driver and has updated it again and again ?
You will see nextly this driver is working perfectly well ! The guilty one is sdbus.sys, responsible to prevents him from fulfilling its mission !

Nor wasting your time by trusting in those "automatic drivers checking programs", which go through your system (depositing along much advertisings and maybe some trojans if not viruses ?), to finally tell you ... what Windows has already said or what you have already known !
There is NO new drivers than what you already have got ! Especially with Windows 10 ! The KING of (to much) UPDATE !

2.4  Do not pay attention to those unproductive advices:
like cleaning SD contacts, formatting, etc…
** By now, who still doesn't know yet that FAT 32 (due to Dualboot Android) is the only format to use ?
** Who haven't experienced these tests ?


                                                testSD.jpg

** Who haven't got this simple reasoning ?

                                                 testSD2.jpg

2.5  Do not repeat that Android is seeing that your "SD card is blank or has unsupported file system…":
Android is not a doctor ! Its role is not to analyze malfunctions.
Facing to every problem, it picks in its “notifications bag”, what he has got… Among perhaps only 2 or 3 instances (more or less accurate), prepared in advance, to cover tons of possible situations.
This notification,  is actually the "most understandable" to explain that you… need to unplug SDcard. That's it !
"Most of the time" your SD is not blank and even, the FORMATTING proposed would not format anything !
(I have said "most of the time", because I admit that I have experienced many times SD card turned RAW or even with bad sectors while Android use.
Understand that after plug and unpluging hundreds times for the tests, often wildly due to nervousness or lack of patience... This could occur and has occured. Where "most of the time", the (well known) Windows "Check File System" program has corrected merely).

This brings to the next tip-off:


2.6  Do not (avoid to) unplug straightly a SDcard "not recognized" (Android side):
even notified like that, system may be still trying to work with ? Prefer to shut down first, before unpluging…
If not, at the next insert, the notification may finally be true: YOU just have yourself corrupted SCcard…


2.7  Do not incriminate without asking ourselves questions:
** All of us must admit that the tablet, out of box (or in the first SDCard plugging) has worked ?
** All of us admit that one day, suddenly, we noticed that SDcard has disappeared ? What has changed ?
Due to update ?
   •    ANDROID ? Impossible, Android Updates do not exist on tablets!
   •    WINDOWS ? I think not. Windows mind is not to spoil but rather to improve.


If you have taken time to read till here (and I thank you to do so), you should actually admit this:

•    There may always be possible unattended problem with drivers or unlucky "broken" hardwares from factory (or tablet forgotten in washing machine ?)... Those rare irregularities remains "rare irregularities" and would be treated separately.
•   But when a program (informatic) has worked, and suddenly turns bad, the cause is mainly "working instructions", initially declared, have been altered (lost or forgotten by dayuse, or if corrupted, are due to external intervention: malware or involuntary personal defects).
•   A driver (system file, i.e. sdbus.sys) cannot be corrupted inside ! It can only be replaced by another one. Its disfunction could only be caused by "wrong or missing instructions" said upper, preventing it to work properly !
•   These instructions are given by .dll files, or recorded in registry. The need now is to recuperate them again... (hoping they are still valid).

•     I think that you are now, very very closed to find, alone, where is the problem… Are you ?

See you next
- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

Wichu| Post time 4-18-2018 13:49:01 | Show all posts
Edited by Wichu at 4-21-2018 12:29

3. SO, NOW, TIME IS WHAT TO DO, TO SOLVE SD PROBLEM, IN WINDOWS ?

Too much blah blah blah to finally propose method which will take less than 1 minute….
Once more sorry (and thanks to understand).
Here is, VERSION 1: EMERGENCY FIRST AID STARTING
(No risk)

After doing tons of admirable or unavowable things, I came back to this manipulation to check reactions of system while booting... What was my surprise to see that it turns fine !
Is it for me, only ? And for how long ?
Anyway, here it is:

3.1 Reminder:
** As said upper, the fastboot option in BIOS is set on "disabled".
** The last update of concerned files: sdbus.sys, dumpsd.sys and sdstor.sys have climbed to 16299.251. And my Chuwi is 32bits.
Check your actual drivers ? Or still give a try to actual ones, before to search this max version.
(Personnally, I think, but not sure I have already experienced this manipulation (perhaps incorrectly at that time ? ) in previous version, 16299.248, without real result.
Correction: as I have recently voluntary "lost" SD card, I could see that doing with 16299.98 works. Not tried yet Anniversary version 14393. But perhaps after doing special thing first, will be explained in Version 2


3.2: Understanding:

** System files, as i.e. sdbus.sys or sdstor.sys, etc. complete basic tasks depending on specifics instructions (powering, why, when, how to work, etc…) which are prior declared by others files, those with termination .dll.
** It happens that some instructions may be altered by daily use, either half-lost or simply "forgotten" ... (hoping not corrupted by malwares)
** Unlike older versions, the magnificent Windows 10 has particularity (set by default) to do not shut down completely, but stay in an intermediary sleeping stage to be able to restart quicker. It is the "FAST START UP" Option.
(one may already wonder, how to "reload forgotten instructions", if Windows never restart from zero ?)
i.e. The system file sdport.sys, new arrived with Windows 10, manages in powering and some specific functions the SD port obviously, but also some others harwares (display, etc). It receives working instructions from the file: sdhcinst.dll (read on article from Microsoft technical site)...
Begin to see solutions ?

3.3: Thus, first thing to do: (also) disable "fast START UP" in Windows:
** If you don't know how to, here is the way. (Question: do we keep this option always disabled  in future ? hum…)

                            fast start.jpg

3.4: Re-UPDATE concerned Drivers:
(I don't know if it is a real need ? But please let’s be quite sure to do not pass aside)
** Everybody knows how to update a driver, right ? Like this:

                         update driver.jpg
** NO, I do prefer to propose what I call, a Hard Update ! Reinstalling drivers from Zero,
So, still beginning by going into "DEVICE MANAGER" and developing  the branch "SD HOST ADAPTERS"

                         reinstalldriver.jpg
(Don''t be afraid, it is a regular manipulation in Windows. System will reinstall all, while rebooting)
** Do not accept when system proposes to restart, until all drivers have been uninstalled
NOTA: I have forgotten to also uninstall those related ones in Storage Controllers branch (sdstor.sys, etc...), during this (successful but non-voluntary) manipulation.
If you are curious enough, by reading the INF file sdstor.inf, you will see that it does awake sdhcinst.dll, mentionned upper.
But after check, when you have uninstalled the first ones, they disappear from Device Manager. So...


* Then, close all tabs and (without willing to do anything else, except to) Restart the system
In case of "rebellious system", perhaps redo once or twice.
ADD: I have noted, restarting with the SD card inserted in slot could sometimes be more efficient. Try twice ways

3.5: So ? What is result now?
** If it works ? You are the winner. By doing like that, departing from Zero and reinstalling drivers while booting, you have asked to system to reload all instructions (hope they are all right ?).

** If it doesn't work ? Sad day. So rendez vous to Section 5, down here or further into section 6 / Version 2
- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

Wichu| Post time 4-18-2018 14:06:54 | Show all posts
Edited by Wichu at 4-21-2018 12:27

4. Then, WHAT TO DO TO SOLVE SD PROBLEM IN ANDROID ?
(CONTINUING ON VERSION 1: Android side,)
Strangely, after doing this previous manipulation, at first rebooting to ANDROID, for THE FIRST TIME, the system has stopped in a screen (perhaps 30 seconds) with notification (in French of course, something like…):
“ANDROID is preparing the storage section” ???
I do not mean the small usual notification rectangle, but a big one
I precise, there was NO Sdcard inserted in slot !

Never seen this screen before. Even when I have solved the problem through others methods.
Does it mean that there is actually “a new relation” (not existing before) between OS ?
Amazing, a relation between 2  different OS (Linux/Windows) ? Unbelievable !

To (happy) end with a very nice surprise:
everything works ! (talking about Android, of course)


Problem now, is that it will be very difficult to continue to investigate… when things work perfect !

5. But it still remains a problematic, that I cannot explained yet ?

(But yourself,  perhaps ?)
Understand:
I have a SDXC (only one !) 64GB SAMSUNG EVO, SPEED 3 (which is one of the best in market, actually)… But unfortunately, dreadfully tortured during all these tests, savage plug and unplugings,  corrupted, repaired, formatted hundreds times…  and corrupted again and again… But always recovered (I think so ?)

When I said:

                                  testSD.jpg

It is not really true !
It's voluntary because I wanted to create a more significant contradiction.
I should have added in the section "WHAT NOT TO DO", a complementary paragraph: Do not claim that your SD works well with an USB adapter ...
Just because...
USB or “long SD” slot are using differents drivers (USB3.sys, etc.) than those for micro SD slot (sdbus.sys, etc.).
Thus if problem is from Drivers, it is once more, another big non sense !

Anyway, let’s say that this small piece of plastic called “SDHC”, can only contains a maximum of 32GB.
Over 32,  there are only “capacity doublers”.
Is it only a “compacting” program which allows the card to now carry an "X" instead of SDHC? Or another specific technology ? Does it need another way to be powered ? Adapted drivers ?
Are actual (microsoft) SD drivers (on “my” system) unable to work with SDXC ?
Or is My actual SDXC card so corrupted, that it cannot be read by “this” SD SLOT, but still workable fine through USB adapter ?
(I precise that at outboxing, The SD has worked fine)

Unfortunately,  actually I cannot attest whatever (for you)…
- This (X@!%) SDXC (thus over 32GB) is still not recognized (in Windows nor Android) !
- Unless I invest in another new SDXC, to verify my upper questions ? (nextly)
- In the meantime, if your SDXC (64GB or Upper) doesn’t work properly, try then with smaller capacity (means 32 GB or LOWER, means SDHC)


If it still doesn't work, Rendez Vous in Version 2
Thanks in advance for your time.
- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

Wichu| Post time 4-18-2018 14:09:38 | Show all posts
Edited by Wichu at 4-24-2018 07:01

Second Round, Version 2: Surgery Operation
6. IF IT STILL DOESN'T WORK ?
Anyway, it was not a waste of time. This method will also be used many many time in Version 2, so useful to have done it first.

Whew ! I just have successfully destroyed again the tablet (means lost SDcard), to be able to continue tests (And I know now how to… lost it)
This problem comes everytime for me, when tablet while "on use", runs off automatically due to low battery. Take care about it !
Also when it meets a "diificulty" leading to a brutal shut down, SDcard disappears after restart. I.e., "lickering" while pluging charge cable in connector (perhaps reverse polarities touch each other. Personnally, I only "plug", when tablet is off) or when the program "Intel Android Device" on laptop (used to link to tablet) is stuck for I don’t know which reason… the tablet black out immediately. After starting, the problem of SD is back !
Admit that it is not normal !

Anyway, it is always a consequence relted to “powering” (Remind, sdport.sys manages powering)


REMINDER:
   Firsty, you agree that we are talking about something which HAS WORKED in the past !
•    You agree the problem could be caused by something elsewhere than those related in WHAT NOT TO DO section
•    You agree that a system files (i.e. sdbus.sys) cannot change alone , only can be replaced by another one (malwares, or update from Windows)
•    And you understand that system files need instructions to work. And instructions are the only things which may have changed to lead to these conflicts.
You say "YES", somebody comes behind you and says "NO": instruction has been changed for a job ? This "somebody" is mainly another program which has loaded up over or others values, involuntarily.


If so, there are only 2 solutions !
1. Reload initial instructions. I could perhaps identify those .dll instructions files, but I am not skill enough to "command" a reloading.
2. Or use another driver, which do not use these actual instructions !
This, we can do !

Let’s announce clearly that, the problematic comes from (only) driver: sdbus.sys ! (The others ones (dumpsd and sdstor) related to it work fine)

When I said "I have found a solution…" It is not true !
I didn't found anything by myself, but only found by reading others and comparing !
I just have created a "shorter" and safer HOWTO
By the way, I thank those people to have put me on tracks.

After having tested lot of drivers (from windows XP to now, and also Ricoh, Nvidia) and found some working (but cannot guarantee in the duration), I prefer to stay and propose Microsoft World. Among them, I have stopped at: drivers of "beginning Window 8.1", which works fine (for me).
Informations:
- Sdbus.sys, from First Win 8.1 version = 6.3.9600.16384 till 17031, I think, at that time, was built to "work alone",  or with less instructions (less to spoil !)
- Then  from 6.3.9600.17255 and later, following to Windows 10 and till now, drivers have changed, involving surely some more drivers and instructions (which create our actual problem).

Second Round, Version 2: Surgery Operation
There is basically No Risk, knowing that:
-    you can, at anytime come back to original by doing the allowed manipulation: "EMERGENCY FIRST AID Restart" explained previously.
-    The only risk is "wrong file"while copying/pasteing. Sdbus file is essential in starting, if wrong one, it stops !
What could be "wrong file" ? Mixing-up 32/64bits. Your thirsty desire to do too many risky tests, leading to mixing-up, errors ?
And very, very, very rare case of files not completely downloaded/unzipped… means corrupted
Thus, I will propose 2 same zip folders, to download, in case.
But the document joined, also explains how to recuperate to restart system
-    The only difficulty in this matter (if you haven’t done yet) is to take ownership on the folder where you will manage files. You can find many tutorials on Web
-    But I still write the usual caution sentence: "you do it in your own risk…"


    ////////////////////////////////////////////////////////////
     // CAUTION: after having done so many things, I could propose some working, but to complicated.
     // Some working... a while, some working... I don't know why
     // Some I cannot repeat twice same miracle... I have stopped at this one, because...
     // I am almost 99% sure it will work for everybody ... in Windows ! (32b)
     //
Because, it surely doesn't use entirely actual instructions of those actual windows drivers.
     // (The equivalent 64b, should also work, as read on this site)
     // The snap is, actually, I still do not understand relation between Android and Windows !
     // I can only say, actually, my Android… Works fine (after returning in "proper latest  version of Windows")… till next problem !
     // It is always from ANDROID side that lost SD first occurs... then extends on both side ! Android punishes by hiding SD at
     // every brutal shut down. It is also him which "better" turn raw SDcard, More capricious and fragile !
     // At everytime I reverse back towards this (Win 8) version, which recognize immediately SD… in Windows only
     // Since, perhaps more than 50 successful and immediate first shots ! To say how this driver could be "solid" !
     // Afterwards, I need to fight to death to reach again "proper latest version" in both side... until next caprice of ANDROID !
     // I imagine there is an ununderstandable relation between them, and those new drivers are set for this relation ?
     // Unfortunately, instructions for them to work are surely too fragile, leading to continual conflict.
    // But we have to continue, right ?
    // So for people who has "ANDROID ACTUALLY WORKING AND WINDOWS NOT WORKING",
    // I don't know if this method is very recommended ?
    // They WILL (99%) retrieve SD recognized again in Windows, but I cannot guarantee reaction of Android afterwards
    // And for those people, I would be very pleased to have a copy of theirs drivers to compare.
    ////////////////////////////////////////////////////////////

THESE SIMPLE STEPS, in  next section, WILL ANSWER QUICKLY TO YOUR QUESTION :
Because if it doesn't works, why to go further ? (If so, please wait for Round 3, when we find another solution)

I join below:
*    2 ZIP folder with lot of different versions drivers from Windows 8.1 to Windows 10, in 32 and 64 bits, for you to see… and to test if you are curious ?
Once more, be careful when choosing 32 or 64 bits.
CustomDrv1.zip (846.09 KB, Downloads: 138)
- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

Wichu| Post time 4-21-2018 15:32:57 | Show all posts
Edited by Wichu at 4-24-2018 07:18

Continuing:
6.1 STEP BY STEP:

STEP 1.    CHECKING YOUR DRIVER VERSION
In Device Manager, develop line SD HOST CONTROLLERS
Right-click on (whatever) one of controller drivers and select Properties, then click on Driver tab
select host controllers.jpg
Please understand:
** The first DRIVER TAB shows version of "informations file" (termination ".inf", i.e. sdbus.inf) which normally should bear the "highest number" (latest update recorded in your system, for windows to choose directly among others).
** The following DETAIL DRIVER TAB, when clicked, shows version of "system files" actually used for the job (termination ".sys"). Click on each  "dumpsd.sys" or "sdbus.sys" to verify each driver version

Knowing:
.inf file = instructions to download drivers in system (to which folder ? what to write in Registry, etc…) . It doesn't work anymore afterwards (except when another update is requested). Means they are not necessary to "everyday" system function.
.sys file = drivers, necessary to system to function, and loaded at each start.


Listen:
IT HAS NEVER BEEN SAID, NOWHERE, OR PROHIBITED OR OBLIGED THAT THE DRIVER VERSION MUST  BE EXACTLY THE SAME (date and number) AS INF FILE ONE !!!
Windows could perfectly launch itself, its own UPDATE, containing different drivers, from different origins, having different number of version ! The only obligation for not confusing the system, is that the version of each new .INF file must be higher than the previous one.
So replacing a system file by an older version is not forbidden... since the system has integrated a studied manipulation to return to initial state recommended by Windows (This function exists when you click on "update driver" in Device Manager).

STEP 2.    RENAMING (Hardly recommended) THE DRIVER: sdbus.sys
Go to folder:  DRIVERS (inside WINDOWS / SYSTEM32)
* Retrieve the file named: sdbus.sys
* Remember, in this matter, NEVER, NEVER delete a file !  Always rename a file under another name. (in case of problem later, you will thank me)
*  Thus, rename the actual file sdbus.sysby sdbus.sysa (I like to add an "a" because "a"=actual, but you can choose whatever way you want)
This manipulation, RIGHTLY, will let you know… if you are allowed or not, to do it !
Sometimes, you are allowed without any problem (by acting as Administrator), sometimes you meet an absolute refusal, depending on settings (you have done previously ?) in system, some folders may stay locked by Windows for security reasons.
* If so, there are many explanations on Web, to "take ownership" of folders. ( I have given some tips in my document joined).
This part is very important, because if there is problem of mix-up and you need to repair... it will be very difficult to act inside a folder where you haven't any ability.

STEP 3.    REPLACING DRIVER: sdbus.sys
* When renaming (and having right to do) is done
* Replace it by copying and pasteing  the "right" sdbus.sys file , proposed in Zip folder attached.
(The version which should be chosen is Win8.1 vers. 6.3.9600.16408, once more, pay attention to dot not mix-up 32/64b)

//////////////////////////////////
// FREE RECOMMANDATIONS : There is NO SPECIAL reason for you to follow this advice
// Just in case, and only, because you are actually in this folder, and it doesn't cost anything to do it !
// And perhaps in the future, you will need ? At least, it is ready...
// So, also keep a copy of "dumpsd.sys" and "sdstor.sys", by copying and pasteing, right in the same folder
// Rename the new files created, with shorter names, i.e. "dumpsd.sysa" and "sdstor.sysa"
// That's it ! For free, Just in case...
// And IN ANOTHER HAND:  Some people advice to also replace "dumpsd.sd" I do not recommend !
// You could do it later, if you want… But there is NO EFFECT and NO NEED for the actual test !
// Other reason is: fortunately, sdbus.sys is released by system after starting, thus you were able to rename/paste, etc.
// It is not the case of dumpsd.sys, which still stays busy in system. You must first cancel its function in Task Manager  
// if not, you could also o it through "windows prompt mode"...
//  FORGET IT !!!  TOO MUCH COMPLICATION … FOR NO REAL REASON !!!
// Later, if you really want to also replace it, there is way much more easy (explained in my document joined, section 6).
//////////////////////////////////

STEP 4.    END ! Close everything... REBOOT (normally) AND CHECK


* 99% it works ? Is it ? If so, you are the winner !

You can stop right here…

But I recommend to (re)change driver (rather, to let the system do this) in  a softer and  safer way, to avoid possible "unknown reaction" from system in the future,
and also to prevent system to stubbornly return to its previous drivers.
End of Round 2


If you are not satisfied with this change (and want to get back to original drivers) ?
Or if unfortunately, it doesn't work for you ? (I am very sorry, then Rendes-vous in Next Round: Section 3)
To get back, simply launch an "emergency first aid RESTART" mentioned previously and you are done !
- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

Wichu| Post time 4-22-2018 11:43:54 | Show all posts
Edited by Wichu at 4-23-2018 02:16

Third Round, Version 3: Big Surgery Operation ?
======================
I have added laterly, a complementary document, concerning SD (see previous post)
Please read, it could explain why method hasn't work
======================

Precisions,
I precise if I use my tablet for "experience", it is not a toy, and surely many of you use it for work.
(Unless you also like to experience), Do only what you need to do !
Actually, my proposal of reversing only one file, sdbus.sys, is surely the easiest and not dangerous (because still go back)
way you could find on web. And it is largely enough ! (I haven't seen any difference "in better" when changing dumpsd or sdstor, so, do not search the "bad", neither ! But you can...)

And especially, I don't recommended to use any ".inf file" to do anything !

If I have proposed a long list of Windows Version Drivers, it is not for you to copy/paste them, one by one, in concerned folder !
I have already done ! If some others have worked, I would have said !
They are for you... to try something else, if you like experienceing !

To be continued...
For me, it works (hope for you too !), it is thus difficult to search better when something is working (I precise "works well with Windows")
My actual investigation is:
- What to do for Android to work in a more stable way ?
(There is way to mount manually a SD card, but Android must be rooted. There is also batch, to mount automatically at each start)
- but better if I can find possible "relation" with Windows ? and if affirmative, right drivers (there are numerous)

See you soon.

- Do call me ‘witch oooo’ (With you) -
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list