Drivers Chuwi RZBOX (Working on Windows 11 Pro x64)_ NVME High Speed BIOS

Here you are, all the drivers (except Microsoft ones). We extracted them with Double Driver 4.1.0

RZBOX

Enjoy!!!

***If you upgrade your RZBOX with a High Speed SSD (1Tb or more), or if you add extra SSD, please follow these steps in BIOS:
Enter in BIOS / Advance / AMD PBS _ and set:
1- SSD Power Enable …[SSD x4]
2- GPP8/9 …Select [PCIE]
***For an optimal sharing of your RAM with the Vega 8 unit, please follow these steps in BIOS:
Enter BIOS / Advance / AMD CBS / NBIO Common Options / GFX Common Options _ and set:
1- iGPU Configuration…[UMA_GAME_OPTIMIZED]

5 Likes

Hello. Do you know where I can download updated BIOS drivers? i have a w10 and WD BLACK SERIES 2TB.
I connect the HD and the BIOS and w10 recognizes it but after a few minutes of use it stops working. You can help??

1 Like

Enter in BIOS / Advance / AMD PBS _ and set:
1- SSD Power Enable …[SSD x4]
2- GPP8/9 …Select [PCIE]

1 Like

The drivers here:
https://drive.google.com/drive/folders/1Auv92SMIzAT-aQsPj1kxzyWk2mTiSuxF?usp=sharing

1 Like

Hi!
I have put the BIOS settings. W10 recognizes the hard drive but after 5 minutes it stops working. It is as if it suddenly turned off. The hard drive is new and works without problems in other towers. Could you help me? tech support is useless.


This my HD. Not supported says Chuwi but in the specs
5tb Max storage
Whats happens??

From what I understand, the issue is the speed that the Chuwi will support in the drive - not the max capacity. Unfortunately it generally appears that the bigger the SSD capacity, the faster the drive is. What I believe is the optimal speed is about 2600mb/s and I’ve been successful in getting Corsair 2TB drives working reliably in mine, after I had to return my Samsung 980. I suspect you will be in the same situation as I was. You need a slower SSD. Now many have commented that this appears to be a BIOS limitation, so it might be that a firmware update will resolve this. I’m going to give a TEAMGROUP MP34 4TB SSD a try this week, and I’ll post back how it goes. I’ve done all the driver updates, and the BIOS updates per this thread and that seems to be fine with the 2 x Corsair 2TB drives in there, but I want to swap one out for a 4TB one, so will be interesting to see how this goes when it arrives in a couple of days.

2 Likes

If you updated the graphics card driver, there will be a conflict with the SSD and RAM. Uninstall the driver (removing everything) and go back to the OEM version of CHUWI.
Everything will be fine… for sure

If you updated the graphics card driver, there will be a conflict with the SSD and RAM. Uninstall the driver (removing everything) and go back to the OEM version of CHUWI.
Everything will be fine… for sure

using Double Driver 4.1.0 restore, I have installed the wifi driver but it is still not show in device manager and network setting, please help.

Hello,
I have another issue with the memory. I wanted to replace the memory and install 2x8GB DDR4 3200 dual channel 1.2V. Company G.Skill RipJaws. Unfortunately, the second RAM in the second socket is apparently not recognized. 1x 8GB in the first socket is recognized. I then also tried 2x16GB of the same RAM type, unfortunately the same result. 1x16 in the first socket are recognized. 16GB in the second socket is not. Then I put the original BWIN16GB 2666 in the second socket one by one, the first socket is empty, is not recognized. Can it be that the second socket is defective or can there possibly also be problems with the power supply here? Maybe there is also an adjustment to be made in the Bios? However, I do not know myself so well.

By the way, my RZBOX Ryzen 7 5800H was delivered and the cooling fan of the processor was not connected, is of course bad with the basic temperature issue. But the problem was already here in the forum.

On the subject of SSDs, the WD blue SSD 570 1GB seems to work well for me, SSDs with max. 4.5W power consumption seem to work well in principle. Thanks for the BIOS adjustments.

Can someone help me with the memory modules?

I have the rzbox Ryzen 7 5800h with windows 11
And I’m not sure the best driver setup.

Currently I’m using drivers for graphics and chipset from AMD website. Bluetooth and WiFi from a post on this forum.

I have an extra 2tb SSD installed.
Bios not changed and everything seems fine.

2 X 8gb for dual channel they are 3200 but I have no idea how to set that in bios. No xmp option.

Does that all sound like it is setup correctly?

Thanks