Error 0xc00000e9 Herobook- Solved

Recenlty i faced the problem of 0xc00000e9 Error in one Herobook 14.1
Windows 10 couldn’t load and i had a BSOD (0xc00000e9) every time after the CHUWI logo.
Also i couldn’t boot with any bootable usb , i have tried several OS , windows 10 , 7 , several linux distro, even with different settings (used RUFUS ) MBR and GPT ,FAT32/NTFS and several bios settings combinations of secure boot , UEFI etc , none of them worked. (Reset Bios Defaults also didn’t work)

Eventually i solved it with the following steps.
Attention !!! It will void your warranty .

You will need
-Hot air gun or solder iron (good skill in soldering)
-A Programmer (used TL866CS)
-A working PC
-A usb flash (4GB+)


  1. I have disassembled the laptop (there are 14 screws in the back , two pairs of them behind the top pads) , and got the motherboard out of the laptop.


  1. i have spotted the Bios (mine was a Winbond W25X40AL… )

  1. I have used a hot air gun and and a solder iron to get it out of the board

https: //imgur. com/g9udnTA

  1. I have used a minipro programmer (TL866CS) to reflash the bios

https: //imgur. com/MRUGkZY

  1. In Programmer’s Software i have chose Winbond W25X40AL (pick the proper one , whatever yours and keep a backup of your recent bios ) . To reflash it i have used the .bin which is inside the 165-166-EC folder, link:

https: //imgur. com/mUoObjY

  1. After the Bios flash , i solder it back to the mainboard and i have reassembled the laptop.

  2. I have downloaded all the parts of HeroBook RS6 CHIWEI-NQ14E-A.partX (X:1-5) that there are inside the windows/ HeroBook RS6 and then i have extracted them to a folder
    link of mediafire above

  3. I have formatted my usb Flash to FAT32 , and renamed it (Label) to WINPE

  4. I have placed all the extracted folders and files inside the usb

https: //imgur. com/CK0Ms2U

  1. The first boot i tried was without usb plugged in , and i had a black screen for about 3min. After that CHUWI logo appeared so i closed the laptop with power on button.

  2. Before plug the usb i powered it one more time to check bios settings.I got into the bios (Pressed ESC when powered up) and the only change i made was to pick Windows from Setup Utility -> Advanced -> Boot Configuration -> OS Selection -> Windows (FN+F10 to save and exit)

  3. Then i plugged in the usb ,i pressed Esc to enter the Bios and chose Boot Manager to boot from usb . I picked up the [UEFI] usb and the installation script of windows 10 finally worked .!

https: //imgur. com/OfciKlW

https: //imgur. com/QYOXoeN

Herobook is back .

1 Like

Thanks for sharing. The effort is appreciated

1 Like