Flashed GSI ROM on HiPad Pro and fixed reddish and blurry effects

Hi JOSHZ, Recording video from screen will not show the correct color and video codec will blur out the crispiness anyways. It’s best to see the different look on your Hipad Pro.

Before flashing GSI ROM, you need to unlock bootloader first. Otherwise all command lines to manipulate the system including all related partitions will not work.

1 Like

Super Hi again :)!
Two questions that turns out to my mind:

  1. This GSI comes with the Google application already installed? (e.g "PlayStore, Gmail, etc…)?
  2. Did you notice if now with this GSI the screen is all used? what I mean is…in many apps, you always size a black line on the camera side, and not completely on a full screen mode.

Thank you again for all your support for the community.

Hi Super, There are some problems, the 1st problem as I understand it is that the ADB drivers do not become, maybe there is an instruction on how to install them correctly?.. 2- it is a locked bootloader, how can you unlock it? the fastboot flashing unlock command has no effect.

Screenshot_7

Answers to your questions are as follow:

  1. Yes. Actually there is version with no GAPPS. But the link I added in this thread is for GAPPS version. Or you can click on this link for downloading GAPPS version of GSI ROM that I flashed on Hipad Pro.
  2. Yes. You can see my screenshot for baterry charging comparing between Chuwi stock system and GSI system. GSI system shows full display while Chuwi system shows a black bar along the left side.
1 Like

Answers to your questions are as follow:

  1. I found these links for installing ADB driver on Windows: 1st 2nd 3rd
    I have installed ADB ages ago. As I could remember, I installed by running .exe setup file of ADB driver.

  2. My Hipad Pro is unlocked from the factory or from the seller when arrived. I have no experience on how to unlock this device. I thought all Hipad Pro devices had been unlocked by default, but I was wrong about this. There may be an unlock tool from Chuwi for Hipad Pro being released if they allow to unlcok Hipad Pro. Or there may be some developers who develop some tools for unlocking Hiapd Pro. Both are uncertain at this moment.

I created a thread that collected tutorials on how to unlock bootloader in this link. If you can successfully unlock your Hipad Pro, please share your method in that thread.

2 Likes

Super what about the sound? Because with stock rom the sound is bad it creaks with this rom the sound is fixed?

JOSHZ, It sounds normal when watching movies with this GSI ROM. But I have no good sense in hearing.

Hi guys,
Unfortunately I have HiPad Pro too and in the Developer Options there is an option “OEM unlocking. Allow the bootloader to be unlocked”. I guess we can use this option to unlock bootloader instead of using fastboot utility.

Hi Shmorg,

I already tried to active that option, and it still keeps the bootloader locker.

But in your case, you could you manage to install the GSI?

Thank you

Hm, nope, I can’t install GSI. Cause when I use fastboot utility from Mac it says “waiting for any device”. I’ll get my hands on a PC this weekend so I’ll try to play with tablet on it. I’ll keep you posted.

1 Like

Hi Super in the meanwhile, while I’m still doing my research on what to unlock the bootloader.
Can you please share with the community the exact steps that you took to install the GSI! As I could see from this post, you had some “special issues”, so would be good to have already here the step by step :)!

I would appreciate it.

Thank you

Maybe to unlock the bootloader, chuwi must provide an unlock code using the imei and the serial number as in some other phone that I have had and the code would be: fastboot oem unlock XXXXXX … we will have to wait to see if they get one update or provide us with a way to unlock the bootloader.

Hi manuelbrunopt,
You can follow the tutorial that I added in this thread. Usually the steps to flash GSI ROMs are the same. The Hipad Pro community should push Chuwi to release the official unlock tool. We should figure out which way we can do this.

2 Likes

Hi,
So this Sunday I’ve tried to install GSI ROM to the tablet from my Windows PC, but unfortunately it’s the same issue as on Mac - fastboot utility displays message “waiting for any device” and that’s it.

It means your PC and Mac cannot connect with your Hipad Pro. Try uninstall and reinstall adb driver. You can find the link to download adb driver and how to install it in this thread.

While many users of Hipad Pro cannot unlock bootloader, you can try these to fix the reddish and blurry issues as follow:

  1. The reddish issue can be fixed by install some apps that can edit color profile of Hipad Pro and adjust saturation level of red color.
  2. The blurry issue can be fixed by using some editor to edit blur option or reduce anti-aliasing. If you need root access, you can use Magisk to install modified boot.img. But you need to dump boot.img from Hipad Pro and use Magisk to patch the file. Flash this modified boot.img to boot partition using fastboot by entering fastboot
    flash boot modified_boot.img
    But it’s possible that locked Hipad Pro may not allow fastboot to use flash command lines.

Please share your solutions for fixing these 2 issues to the community. it’s very appreciated for this.

1 Like

Sorry, I don’t think this is connection issue. Adb works pretty fine, I can install APKs to the tablet from my Mac. Also Android Studio works fine with tablet - tablet is recognized(as Chuwi HiPad Pro) and I’m able to install compiled projects to it. ‘adb devices’ command works too, I’m able to see the tablet. But fastboot still gives me ‘waiting for any device’ message.

If so, it probably means your fastboot is not updated. Try download and use the updated fastboot tool from the link that I added in this thread.

Having fastboot v31.0.3 and sdk Manager from Android Studio shows that there is no update available for platform-tools.
I guess I can just wait for any news/updates from Chuwi :slight_smile:

I would share an idea about the blurry effect. Note that the idea is an assumption only.

Sometimes with a LCD screen that are not the proper resolution to be set nor the proper refresh rate, there is some wrong image.
Because the display informations are 1908 x 1212p (see post number 9, October the 2nd), may the bad image is due to this wrong setting?