Lapbook pro 8/256 how to Linux and fix Black Screen

So, I got my Lapbook Pro with Windows, but I as many other people was trying to start their Linux partition unsuccessfully and getting a black screen, we were changing options in Bios and if you choose the Linux OS option WILL BREAK the BIOS and brick your device (no usb, no nothing, no bios) after this your only option would be to buy a cheap CH341A programer and fix it (for us who can’t afford to send it back to guaranty), flash the BIOS and Ta-da! it works again, but you’re in the same situation, will be able to start only windows, so what to do?..

The EFI partition isn’t being detected, what is detecting is a generic ubuntu/linux/etc? partition that is done from a previous installation before the grub installation and that option that is being displayed isn’t leading to any system so it shows a black screen with a little white line. What you have to do is this:

  1. Download Manjaro KDE (I did it with this) burn it in any USB, chose the DD option.

  2. Once there, at the bottom the last option has the booting options, once there you’ll be able to see your linux partition, chose it. IT WILL BOOT.

  3. Once in your Linux system, open the terminal and execute this command: sudo grub-install

  4. Then execute this: sudo update-grub.

  5. Profit :smiley:

Now when you restart your Lapbook Pro it should display the grub menu and that’s it.

*Info about flashing with ch341, the chip is the one that has a colored spot (in mine was a red spot) and remember the orientation of the red cable has to obey the black little spot in the corner of the chip, once in the software it should detect it as a GigaDevice 25q80 and it will be ready to flash.

Good luck!


Thank you for sharing:+1:

1 Like

Does not work.
Problem is the same: boot option Linux bricked my laptop.
Why Lapbook Pro is so buggy?
Chuwy support, how to restore BIOS?

The BIOS only needs to be used when the device cannot be turned on.If so, please tell me your serial number and I’ll send you the corresponding BIOS.

Please help, I need support. After receiving the parcel, the laptop
worked well. I installed Ubuntu and changed the OS to Linux in the
BIOS. Now the laptop does not turn on.
lapbook pro 8/256 sn: lap q256g41911ХХХХ

I wanted to be sure that the firmware is 25q80, the only way out. I have a CH341A programmer. But the laptop is 2 days old and I would not want to solder something on the motherboard.

You don’t need to use solder, there’s an adapter that works directly with the 8 pins in the motherboard.

OK. Thank you for the good news. But where to get the firmware and how to find out the pinout on the board?

How did you write 8Mb bios.bin to 1MB SPI 25Q80?

Hi. I took off and flashed both, 25LB64CVIG and 25Q80CSIG, two times. It didn’t help, the same black screen. I tried with both type of bios. Nothing happend, the same result. Who knows what happen what ‘os linux’ the bios settings set up does?

Serial number of my Lapbook Pro is: Q256G419110397. Pls send me the corresponding BIOS file. Thanks

Hi Albart, have you solved the your problem?

This chips are used for Bios and ME region (or some information for SoC), so you need to flash different firmware for them (if you lost origian ME firmware - you are in trouble) . I think you need to ask support to give files for your serial number or people to make known-good dumps of this chips.

I could not solve the problem and returned the laptop. I could not find anyone who could defeat this problem. all reports of a successful decision on this forum were ultimately refuted.

Can ME region affect the impossibility of loading BIOS?


*Why is there a limit of 20 characters.? lol*

Do somebody have right firmware ? How to detect that the firmware is correct ?

Ok, if say it because of IME (security feature from Intel) did somebody try this way ?
I didn’t propose to use Raspberry Pi like a programmer, I mentioned to get off IME.’s_EFI_Install_Guide/Disabling_the_Intel_Management_Engine

To determine the “correctness” of the firmware - it should be compared to the original one or it should be flashed into chips and checked the operability of the notebook.
Original firmware is “correct” only for your notebook, for others it may not work (it will differ in serial numbers, mac-address, windows key, ME settings).
ME region rarely causes a laptop not being able to function, usual it is causes long turning on or
immediate shutdown after turning on ((you can even don’t know that laptop is turned on and then turned off) (often laptops works 30 minutes, then just shut down)).