I need a way to reset BIOS settings to factory defaults

We have: motherboard G140J rev0.4
Gigadevice 25Q80CSIG - 3.3 V 1 MB (content analysis showed that it is ec.bin)
Gigadevice 25LB64CVIG - 1.8v 8 Mb (until I was able to connect, I continue to try)

archive with firmware E.G140J.D8.E1.006 & GLK_EC_G140J_V130906.zip
it contains bios.bin firmware file - 8 Mb
and ec.bin file - 131 Kb

CH341A adapter + clothespin + 1.8 adapter
Ch341a programmer 1.34 software

Firmware only ec.bin did not give anything.
The question is how to determine and flash Gigadevice 25LB64CVIG?

1 Like

What the problem with 25LB64CVIG ?

Flash only the one just called bios.bin. that one worked for me

25LB64CVIG, this is in the VSOP8 form factor. These are very short legs, unlike SOP8. And I could not connect to it tightly with a clothespin, I have it SOP8.
It seems that for the firmware you need to get it off the board.

Clarify, please. In which chip did you flash the 8MB bios.bin file?

In here I mention it at the end, it’s the one with the a colored spot (in mine it was red) is next to the metal plate that covers the processor. Use the 8 pins adaptor.

Yes, I read it. the volume of the chip with the red dot is 1mb, and the BIOS file cannot be written, it is 8mb

It worked just fine, I don’t know exactly the capacity but the software reads it correctly, all I did was to do a back up, then wipe it and at the end just flash it.

do you have a backup file? I would like to analyze it. maybe you writed with overflow and it worked.
Please write what software was used.

I need "archive with firmware E.G140J.D8.E1.006 & GLK_EC_G140J_V130906.zip
it contains bios.bin firmware file - 8 Mb
and ec.bin file - 131 Kb "
How do I get one?

I have it, tell me your email

Thank you very much!

Hi, could you send it to me too? The Bios linked on these pages (E.G140J.D8.E1.016&CHUWI_G140J_06V1403) apparently bricked my lapbook pro, if you have the E.G140J.D8.E1.006 & GLK_EC_G140J_V130906.zip I’ll try with that, thank you

My email is alessio.romano83@gmail.com

i have same problem with chuwi lapbook pro. Before i installed solus correctly on laptop. After i select on bios option “select Os and select linux”.
After reboot i have blank screen.
Now i send my laptop on specialized center to flash bios. This centre tell me bios chip is damaged. i believe than resolve my problem

1 Like

If they say that it is because they have touched something.

You shouldn’t have changed that option in the Bios. the solution, boot with an external linux system in USB and make the modification in the bios from there.

If they have already corrupted the bios, only a reprogram will solve the problem

I have same problem with mini pc Herobox. I’ve select in BIOS OS Linux and now have a brick.

write to service@chuwi.com

a mi tambien me serviria

Hello Joalruch, I have problem with BIOS in my Herobox, doesn’t show bios post anymore. May you be so kind to send me the bios file please? My email is marcobmwf800gs@gmail.com
Thank you in advance.

Si es posible proveer los archivos mensionados, muchas gracias.