Hi10 Air - Need Help With Bios Reflash


I followed the guide found in this post: https://forum.chuwi.com/t/topic/787/10 to get Android onto my Hi10 Air.

It all worked great including having android up and running until trying to flash the BIOS from the cross bios supplied in that guide back to the original bios. The serial number on my Hi10 Air begins with Q64G19103. I misread the 19103 as 1903 and flashed the 1903 bios provided in the forum. The bios flash begins, runs through the first round of flashing and then the screen goes to a smaller resolution and the bios keeps re-flashing itself over and over again. Once I realized I i should have used the 1906 bios I tried flashing again with the 1906 bios from this forum and got the same looping of bios flashing. Once again flashing back to the cross bios worked.

When i go into the bios the serial number is listed as 123456789ABCDEF cpu configuration is blank.

Is there a trick to getting the bios back to the correct 1906 or am I stuck now? I have cloudready now installed on the machine but touch is not working on the screen. Other than that it is functional.

Thanks in advance for any help!


Can you please offer some advice or help? You are quite helpful in the posts I have read.


Has anyone successfully flashed the bios on a Hi10 Air?

As I’ve said many times, the BIOS must be especially careful.You flash wrong BIOS, now can only contact after sale. aftersale@chuwi.com.

I appreciate your help and respect your advice. My apologies for causing headaches for you and your company. I am hopeful and confident a resolution can be reached.

Thank You,


There is a prominent thread in which I warn that never, unless it is corrupted, the bios are updated. The risks of brick are obvious and much more if an incorrect bios is used.
The only solution is now to flash the bios with a clamp: https://mega.nz/#!V9dRxSJB!5vAz9wpTcSyFfBH4eayIUlrjj67atC6DBjTkOMu72Xk

Sorry, I just realized. Does the tablet turn on normally and charge the operating system? If so, does it work correctly or are there devices that don’t work?

It boots normally and works fine. I have cloudready installed on it right now so the touchscreen isn’t working most likely due to missing touchscreen driver. If I could get touchscreen working in cloudready all would be perfect.

I also had issue downloading the windows back up files from the links in the forum. MediaFire required me to pay for a download account to download and then told me the files were too big to download as they exceed 300mb.

I also needed a paid account to get the Bios files. Is there a chance I am not supposed to use either of the 1903 or 1906 bios files and need a 1910?

Thank You for your help!

I have just tried reinstalling windows as I can’t get cloudready to work with touchscreen. I am using the windows files from the support and downloads section here. The RS4 and RS6 versions both boot to blue screen and say something went wrong and that the computer needs to reboot. When rebooting it goes directly into cloudready.

I am at a point now where I cannot get anything from the support and downloads section to work at all.