Ubook Pro (m3) gets very hot. Is it nornal?

Chuwi engineers are aware of the two keyboard backlight issues that you have stated. I was informed they are currently working on releasing a corrective software fix. I would assume that it will be sometime after their Chinese New Year holiday break.

For a work-around on the backlight coming on during the key press, you can disable the fast startup under power options/choose what the power buttons do. By disabling Fast Startup, the keyboard backlight will no longer come on with a keypress.

For the heat issue, I recommend changing the Minimum Processor State to 5% under Plugged In (and On Battery). I had the same issue with high temperatures until I change this setting and I noticed the UBook Pro running a lot cooler after that. I noticed no change in performance since the maximum process state is still at 100% and it has no problem scaling processor usage.

3 Likes

I checked my settings and it is already set to 5% for minimum processor state and I do not recommend to change the fast startup for laptops or tablets with Windows 10 because they should be made for fast startup.
I hope that Chuwi can come up with a fix for the keyboard draining the battery during sleep mode asap.

1 Like

Thanks for the detailed explanation.
I turned off the fast startup then I checked CPU min state. But it was 5% for both plugged in and on battery. I also reset to the default then it was still 5%. I changed other settings a lot so I’m not sure which setting affected, anyway my ubook pro is not hot now, actually not even warm. At first, the battery lasts only 5 hours but now it appears to run for more than 7 hours.

1 Like

Since the UBook Pro has a SSD drive, there really is no need to enable Fast Startup. It really won’t save that much time (maybe a few seconds).

There are other benefits to disabling Fast Startup. It will no longer create (or update) the hibernation file which can cause more wear on the SSD drive. It enters a deeper sleep mode which is better for conserving battery power during shutdown. There are other reasons as well which you can find on the Internet. I typically recommend disabling Fast Startup on laptops and tablets.

2 Likes

I just remembered regarding the heat issue, I also updated the drivers for the Intel Dynamic Platform and Thermal Framework (Manager and Generic Participant). You might want to try this as well. You can go into Device Manager and Update Driver for these two devices. Just choose the option to search automatically for an update, it should find them. I believe I updated other Intel drivers as well but I can’t remember which ones.

3 Likes

Thanks for this additional remark.
Microsoft should consider this for the next version of Windows 10.
It is really frustrating that the default settings from MS are all wrong for tablets and modern laptops.

I have also updated all the Intel components for which I was able to find updates automatically.

1 Like

When updating the Intel components I must have updated one which has caused the Bluetooth adapter to stop working completely.
Any idea if that is the Intel SD Host Controller? I updated it as well…

The SD Host controller should be for the SD Card. I wouldn’t think it has anything to do with Bluetooth.

If you are having a Bluetooth issue, you might want to run Intel’s Driver & Support Assistant. It should have the latest Bluetooth. Otherwise, maybe remove the Bluetooth driver, reboot and have Windows reinstall it.

Or you can just download the latest Bluetooth driver directly.

1 Like

Now it worked, I was able to update all Intel drivers in the device manager. But my Bluetooth is not recognizing my mouse at start-up anymore and I always have to switch Bluetooth off and on again.

Seems a strange issue. Have you tried to remove the Bluetooth mouse and added it back in? I have a Bluetooth keyboard and the only issue is that it takes a second to connect before it is recognized due to the keyboard going to sleep.

I found now what caused the Bluetooth driver to disappear, it is happening when I switch Bluetooth off via the Windows 10 notification sidebar, a click on the Bluetooth tile causes the complete driver to malfunction.
How to recover the driver is to deinstall the unrecognized device in the device manager and shutdown the tablet, thereafter reboot and the Bluetooth is back.
I am using the latest version of the Intel Bluetooth driver for my tablet which is BT_21.60.0_64_Win10.exe and installed via the Intel Driver & Software Update.

However, I still do not know why Bluetooth is not working on start-up and why my mouse is not recognized - I already detached and attached it several times.

When I get the Bluetooth mouse that I ordered, I will test and let you know if I come across the same issue.

I am using the Logitech M590 at the moment and only got it a few weeks ago.

I just got the Xiaomi Mi Portable Mouse. I have no issue with using it with the Ubook Pro. It reconnects fine from either sleep or from a complete shutdown. I almost purchased a Logitech Bluetooth mouse but I read several poor reviews about the same disconnect issue you are having. So I decided to buy a different make. I did purchase another cheap Bluetooth mouse but that one was broken on arrival and wouldn’t work. So then I bought the Xiaomi mouse.

The Xiaomi mouse is a little bit too flat for me and the scroll wheel doesn’t have the right feel for me (almost too smooth). But for now I will continue to use it until I find something else that will work.

Joern,

Did you resolve your Bluetooth mouse reconnect issues?

I bought another Bluetooth mouse, the Rapoo M100, and have no issues with re-connection. So using either the Rapoo or Xiaomi Bluetooth mouses, I saw no connection issues.

I recommend the Rapoo M100 Bluetooth mouse over the Xiaomi Mi Portable Bluetooth mouse. It is more ergonomic, glides easier, better mouse pointer control and a much much better scroll wheel. The Rapoo M100 is also cheaper than the Xiaomi mouse.

I can connect the Logitech Bluetooth mouse but it gets disconnected from time to time.
The only way to connect it again is to switch Bluetooth in the Windows Settings off and on again.
If I am trying to switch the Bluetooth off in the task bar or via the notification panel it will jam the Bluetooth controller and I have to shutdown and restart.
I am not sure if this is a problem of the hardware or the driver, would be great to get Chuwi to look into it.

Joern,

Sorry to hear that you still are having Bluetooth connectivity issues. I have not had any Bluetooth connectivity issues with either mouse or keyboard. I can turn off and on Bluetooth via the notification panel (action panel) without any problems. Maybe Chuwi support can assist you.

I bought via Amazon a 18€ Zienstar Mouse Wireless Bluetooth and BT works perfectly. Just to move and immediately reconnect from Standby…

I changed from my Logitech M590 to a MX Anywhere 2 and still have the problem that the mouse is very laggy and it is also disconnecting from time to time. The diver version of my Bluetooth receiver is 20.100.6.4 and it is installed via the official Intel Driver & support Assistant. I am very open for any suggestions to fix the lagging and the disconnects asap.

Do you have anything between your tablet and the mouse? Like a metal desk or something?

You can also try to change the 2.4 GHz channel used on your WIFI router. It might be an interference issue between your WIFI and Bluetooth.

Do you have any other 2.4 GHz devices running like CCTV, a security system or cordless phone? These can also cause Bluetooth interference issues.

If you take your tablet and Bluetooth mouse to a different location, do they work better?

Also, have you installed the latest Intel WIFI driver as well?