Unlock bootloader for Hipad Pro

You could show your device dispatcher when the tablet is connected.Can I have a problem with the drivers?Screenshot_9

Here is the result.

If you suspect these errors may cause your device unable to unlock bootloader, you can try uninstall the adb driver and reinstall with the adb drive in these like here or here.
This link shows how to install adb driver here.

Your fastboot commands look normal. But you probably need the official unlock tool to activate these commands. From your screenshot, it’s clear that the command to unlock bootloader is fastboot flashing unlock

If your device can flash boot.img to boot partition, I can dump my boot.img file and send to you for flashing. This method will allow your device to be able to use all fastboot commands that my device is capable of. But this risks bricking your device if it is not successful. So I would suggest waiting for the official stock firmware first. It’s too risky for bootloop using this method. I used to do this method and successfully fix fastboot command lines in my Xiaomi smartphones.

1 Like

Hi super, again thank you for your support to the community.

So…I follow all your above steps:

  • install adb drivers
  • download platform-tools
  • run the cmd
  • I can see my device and I also can see that is locked
  • when I enter on the fastboot I have tried all the commands but without any success

I was searching on the web and so far for the Chuwi Hipad Pro, there is not so much for information :(!
If you have any idea or someone for me to test, please feel free to share :)!

Thank you again super for all your help.

1 Like

Hi manuelbrunopt, Surely there are very few topics about Hipad Pro since this was barely released in July 2021. Usually it takes at least 6-12 months before there are more developers creating some tools or custom recoveries for Mediatek and Unisoc devices. But Qualcomm devices usually have bigger developers’s community.

There are 2 possible ways to unlock the locked Hipad Pro:

  1. The official unlock tool from Chuwi, if they allow their customers to unlock Hipad Pro. I tried to search about Chuwi policies for unlocking their Android devices. There is no announcement that they won’t allow this. So I guess there will be the official unlock tool to be released.
  2. The unofficial unlock tool from some developers.

I am now wondering how many Hipad Pro devices in the market that are already unlocked like mine. :thinking:

2 Likes

Hi Super,

Thank you again for your words.
About the Qualcomm devices you are so right, and what I was thinking is that for sure there is already some tool, that can unlock this device, the only thing is to know which tool can I use.
I will search in the meanwhile if I can find out, but I ask you if you kind of find something that could help us, please feel free to share :)!

About your unlock device, man, you were SUPER lucky :smiley: eheheh, I’m glad for you :)!

1 Like

Hi manuelbrunopt,

You’re welcome. I am trying to find out the method to unlock bootloader. Since flashing GSI ROMs is the only way for now to fix the 2 issues of the display. I want to have big community for Hipad Pro. This will benefit all Hipad Pro users from more developers for more tools and more parts and accessories available. The more parts availble, the longer this device can be used.

2 Likes

Dear all,

I’m a new “lucky” man who bought this tablet. However, I have one more problem with flickers on my screen. Chuwi service recommended to install new firmware which they provided. But, I have an issue “Sahara fail” when trying to install it.
My assumption I cannot install new firmware because of locked bootloader. Does anybody found a way how to unlock this hell device?
Thanks.

Hi @Zahar
Welcome to the club. Most of us are having the same problem about to unlock the Qualcomm Hipad Pro. So sad that Chuwi will not probably provide the official unlock tool or no support.
Actually you don’t need to unlock bootloader in order to flash Stock ROM. I also got Sahara server failed when trying to download Provision. I am trying to back up my unlocked boot.img to share with other users with the hope that will unlock their devices as well.
You can find the Stock ROM here.

Hi @super, thanks for response.

Were you able to solve “Sahara fail” issue? I tried several laptops with different cables and nothing on my side.

Nope. Always got Sahara server failed. I am new to QFIL so I have no experiences to work around this at all.
Maybe you can try different versions of QFIL. I read from some Android forums that some versions of Flash tool may work or may not work on different version of Windows.

Hi all, finally I was able to install new firmware on Hipad Pro. But it did not help and screen is still flickering. I’ve contacted service and they advised to send device to them to Hong Kong. Well, I did it. Currently, service does not want to receive my package and they keep silence. I do not know what I can do, lost money, lost workable device, lost time. Could anyone help me with the issue how I can solve this? Thank you in advance.

I had same problem when I bought SSD from Aliexpress. It was broken (I mean not physically broken) then I opened dispute. Aliexpress representative judged that I returned the SSD to the seller. And the seller has to pay for shipping fee. I contacted the seller to request the shipping fee by Paypal. The seller got silent. The time limit for me to return the product almost up. Then I returned the SSD by paying US$30 with FEDEX services. The returned parcel got inspected by CN Customs. Fedex could not contact the seller as the receiver. After around 1 week, the parcel got rejected and had to be returned to me. But I had to pay US$35 for returning fee. I refused to pay another US$35 for getting the damaged SSD back. Then the parcel has been trashed out already.

If you have the service staff’s phone number, you can add wechat and remind them about the parcel to be received. Or call them if you can. If they don’t receive the parcel, it will be returned to you. But you need to pay for returning fee.

Hello all Hipad Pro users (Qualcomm),
I have backup the partitions of my unlocked Hipad Pro. You can try flash them in order to unlock yours hopefully. Read this link for more details.
Any questions are welcome.

I asked the Chinese to help unlock the bootloader on Proshka. They sent these files. Who understands, tell me, does this really help to unlock?

Hipad Pro

@Andrej38 Thanks for sharing. But unfortunately this seems to be just Stock ROM that will have your Hipad Pro still locked. This file has been shared since last year, 2021. I thought this would help unlocked bootloader as well. But nope. You can try flashing this ROM by following the tutorial inside to see if this could unlock your bootloader.

I did everything according to the instructions, tell me how to check the bootloader now?

@Andrej38 Enter fastboot mode and check your unlock status by entering this command
fastboot oem device-info
or follow this link for more details.

By the way, I have backed up my partitions using QFIL. You can try flashing them using QFIL one by one and see if this helps to unlock bootloader. Follow this link here. The only 2 partitions that I have not backed up are data and super partitions. Data partition is not necessarily. But super partition contains other partitions like system, vendor, product partitions and so on. Super partition is too big to back up. This one is over 4GB size. If you flashed all the files in the link and get bootloop or bricked, that probably means 2 things: 1.You need to flash vendor partition by flashing super partition to be able to boot up 2.Unlocking by flashing backed up files like this is not able to unlock your device bootloader. And mainly my device is running on partition a. So flashing partition b may not be necessary.

Any questions are welcome. If you can unlock bootloader by flashing my back up files, please share the result. Hope one of the above methods helps you unlock bootloader.

P.S. I ordered Yoga Pad Pro to replace my Hipad Pro. It’s half way to reach me. And I will give Hipad Pro to my dad. So I may not be able to support about Hipad Pro anymore after that. But I will flash Android 12 GSI ROM and share the result before giving this device to my dad.

Updated according to the instructions, now on the main screen for the place of the date the search bar. how to remove it?