ChuWi Forum»Forum Chuwi Tablet Discussion Chuwi HiBook HiBook will no longer detect 64GB MicroSD Card

Follow Us

HiBook will no longer detect 64GB MicroSD Card

[Copy link]

SuperSeven|Post time:7-8-2016 04:31:11 View:12469|Reply:40

As the title says, when in Windows10 the HiBook will not detect the 64GB MicroSD card. This card works fine in Android/on other computers.

The Troubleshooting option in the Control Panel detects a broken/missing driver but cannot fix it.

Any ideas?


Use magic Report

SuperSeven| Post time 5-25-2016 06:28:28 | Show all posts
Bump. Anything?
Reply Support Not support

Use magic Report

hawkinspeter| Post time 5-25-2016 10:58:24 | Show all posts
I noticed a similar thing happened to my Hi12, but as I was only using the SD card in Android, I haven't investigated.
Reply Support Not support

Use magic Report

AnakiMana| Post time 5-25-2016 12:27:47 | Show all posts
If you or someone else can post info on which model of card reader they use, you can try downloading a different driver from somewhere and see if that fixes it.
Reply Support Not support

Use magic Report

TCIII| Post time 5-29-2016 07:34:09 | Show all posts
When I first received my HiBook 10.1 dual boot Tablet it recognized the SanDisk 64GB microSD card that I had inserted in the TF slot.
The next morning when I turned the Tablet on, it did not recognize the microSD card so I pulled the card and inserted it into a standard size carrier and tried to read it in my PC.
The PC would not recognize the card either so I took and inserted and removed the microSD card in the standard size carrier slot to burnish the microSD card gold contact.
After doing that the PC recognized the microSD card so I removed the card and inserted it into the TF slot and the Tablet successfully recognized the microSD card.
I think that sometimes there is transparent contamination on the microSD gold contacts and a little burnishing of the contact may get the Tablet to recognize the microSD card again.
Reply Support Not support

Use magic Report

SuperSeven| Post time 6-1-2016 06:38:57 | Show all posts
Edited by SuperSeven at 6-1-2016 07:45


It is an issue with the Windows partition. Android and my other PCs will recognise the card.
Device manager claims there is a problem with the driver but the troubleshooter cannot fix it.
Can someone explain how to manually fix this? Thanks.

edit: I downloaded the drivers and attempted a manual install. This results in a code10 error stating the device cannot start.
The card will no longer read on my desktop either. I can only conclude that the card is dodgy and tempermental.
Reply Support Not support

Use magic Report

Modelman1968| Post time 6-2-2016 04:43:17 From the mobile phone | Show all posts
I have the same problem. For the first couple of weeks everything was working fine. I used the micro sd and USB hubs. At some point when I unmounted my USB the micro sd also unmounted, but was still physically in the HiBook. Now when I remove/replace the sd card it momentarily registers the sd. It's acting as if it thinks the sd card is removed when it's put in and inserted when removed. I've tried everything i can think of, even flashed the bios update but no joy. I'm only using android so I don't think my problem is drive related. My next step is to root the device and try using stickmount. My sd card works perfectly in other devices of course.
Reply Support Not support

Use magic Report

donmorsa| Post time 7-4-2016 12:05:20 | Show all posts

i'm having the same problem here, my hibook sd reader was working fine but suddenly stop recognize my microSD card (128GB). In windows i have the same problem (code 10). Tried to uninstall, reinstall, alternate drivers doesn't work. In android i have another issue related: Android recognize a card but ask for format the SD card. if i set "yes", android tries to format the card but appear the message for format the card again, making a loop.

Of course, the card is working right in another devices. Consider that if i put the microSD in a USB adapter, and then i connect it to my hibook with a OTG, the card is recognized as a pendrive without any problem! so i think its a driver or hardware problem.

Any idea?? Please help!

(sorry for my basic english)
Reply Support Not support

Use magic Report

kostyamat| Post time 7-4-2016 13:10:05 | Show all posts
+1 i'm having the same problem
Reply Support Not support

Use magic Report

tux123| Post time 7-8-2016 04:31:11 | Show all posts
+1. Code 10 error.
Tried using different cards, no luck. Tried reformatting (ntfs,fat32) no luck. Micro sd card works just fine in android and on my other PC's, both windows and linux. Putting the micro sd card into an adapter and connecting via micro usb in windows works as well.
How can we find out what kind of model card reader they are using?
Anyone have any other ideas?
Come on Chuwi, we need some help here !!!!
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list