ChuWi Forum»Forum Chuwi Tablet Discussion Hi10 Unlock Bootloader, launch&install TWRP recovery, Roo ...

Follow Us

Unlock Bootloader, launch&install TWRP recovery, Root Android on Chuwi Hi10

[Copy link]

Tikilou|Post time:1-23-2019 02:07:20 View:5932|Reply:2

Hi, after many researches, i've found a way to install TWRP recovery and root android on Hi10 tablet, except touchscreen, it's seems be almost the same hardware & software of the HiBook.
Warning : unlocking the bootloader gonna delete all your system files and data of android, make a backup of all your data/apps before doing it !
First, you need :
-Your Chuwi Hi10 flashed for DualOS
-Your computer with Linux Ubuntu 16.04 (with adb-android-tools and adb-fastboot tools installed) or Windows 10
-µSDcard inside the tablet
-USB Mouse
Download (extract alls files on theses folders on the same directory) / (password archives is "") :
TWRP recovery and Supersu => ... persu_chuwi-hi10.7z
The system.img original of Android for Chuwi Hi10 => ... -Q64G421605XXXXX.7z
Drivers adb/fastboot for Windows (not needed on Ubuntu 16.04) => ... boot-win8&10.7z
ADB and Fastboot softwares for Windows (not needed on Ubuntu 16.04) => ... tboot_chuwi-hi10.7z
First, you have to boot on bootloader mode, on the selection screen with Android and Windows logos, press Vol+ for running Android and just after (quickly),  press and holdVol+ and Vol- together until the bootloader screen appears.
After that, put your tablet on the cable USB connect to your computer, and execute theses commands lines :
Go to your directory :
"cd the_directory_of_files"
"fastboot devices"
"fastboot oem unlock"
(The bootloader gonna be unlocked, and all the system, data, including internal memory of Android, will be losted ! It does not affect WINDOWS or external SDcard.)
For restoring system partition, execute :
"fastboot flash system system.img"
And finally, press the power button of your tablet to confirm reboot on the system, when the system is booted, and screen welcome options configured, execute theses commands for disable the security of files systems (otherwise the tablet gonna stuck on chuwi logo during Android boot) :
"adb devices"
"adb root"
"adb remount"
"adb disable-verity"
After that, reboot android, and we gonna prepare all files needed for load (without install) the TWRP recovery and inject Supersu inside Android.
"adb push /sdcard/"
"adb shell mkdir /sdcard/TWRP > nul"
"adb push .twrps /sdcard/TWRP/ > nul"
And we reboot in bootloader mode
"adb reboot bootloader" (or hold Vol+&Vol- together just after Android boot screen choice)
And we booting in ram TWRP :
"fastboot devices"
"fastboot boot chuwi-hi10-TWRP-recovery.img"
The TWRP Recovery will be launched, connect your USB Mouse on ther USB 2.0 port of Hi10, and swipe for confirm read-write access of internal memory, and go install/flash "", then reboot ! ;)
If SuperSU app appears on your list apps, you have successfully rooted your android system of Chuwi Hi10 Tablet ! =D
If you want it, you can flash TWRP recovery for replace the original recovery, but you won't be able to install android updates by Chuwi without restoring the original recovery.
"fastboot flash recovery chuwi-hi10-TWRP-recovery.img"
If you want to revert, install the original recovery :
"fastboot flash recovery chuwi-hi10-original-recovery.img"

And voilà ! You have access at TWRP recovery and Root on your tablet !
The next steps gonna be deodex/xposed/customs roms/kernels on Chuwi Hi10 with the easy way of TWRP recovery !


Use magic Report

xDaemon| Post time 2-1-2018 10:25:35 | Show all posts
Edited by xDaemon at 2-4-2018 00:04

Hello. i have a little issue
when i run command fastboot oem unlock  getting this error fastboot oem unlock ... FAILED (remote: unknown command) finished. total time: 0.004s
what is the problem? Thanks in advance!
EDIT : Its fixed! thanks anyway. ;)

Reply Support Not support

Use magic Report

franc| Post time 1-23-2019 02:07:20 | Show all posts
Edited by franc at 1-23-2019 11:39

How did you fix it?
I have the same error on my ChuWi Hi10 Plus with Build from 20170504.085712
I have no display lock and oem unlock is enabled in Dev. Tools.

EDIT: solved it, my fault. The trick was, that I was in the wrong fastboot mode. When the device is off I did POWER+VOL-DOWN+VOL-UP and got a little red note with fastboot but this was not the right one.
First (as in the first post here, which I didnt read before) I have to select Android (in the boot loader Android/Windows) and very fast after clicking the VOL-UP Button (for Android) I have to hit both VOL-UP+VOL-DOWN, then I get to the real android fastboot selection where I can set more things with VOL-UP / VOL-DOWN.

Now the fastboot oem unlock worked

EDIT: Btw, fastboot oem unlock didnt erase all data from my ChuWi Hi10 Plus. Root with SuperSU neither. Important is the dm-verity disabler from KonstaKang.

Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list