ChuWi Forum»Forum Chuwi Download Official Firmware Highlighted screen, but no picture. All other is wor ...

Follow Us

[HiBook] Highlighted screen, but no picture. All other is working.

[Copy link]

oeriel|Post time:2-22-2018 14:54:25 View:354|Reply:4

I have CHUWI HiBook 10,1. The problem with this device is, that everything is working (sound, system Windows, USB ports, battery, HDMI) but no display on tablet.

  • There is a little highlight on screen when I power it or power off when logged in Windows,
  • When Windows 10 is loading it dims some screen from bright do delicate light. Same is here but there is no picture,
  • It's not working in any place, in BIOS and in Windows,
  • When I connect through HDMI all is displayed on external monitor,
  • Touch is working,
  • Android on this tablet was deleted. So when I choose option to Android I have error - so it's OK, I don't need Android here,
  • When I connect similar display from other working Chuwi 10.1 tablet, there is the same - a little backlight an do picture. So it seems that LCD is ok. Tablet was not thrown or crashed so it's ok.
  • Checked ribbons, all connected properly. As proof, point above, connecting other screen from other tablet, on different ribbon acts the same, so ribbon seems to be ok.

BIOS Information
BIOS Vendor: American Megatrends

Core Version: 5.011
Project Version: I1D6_C109.224 x64
Build Date and Time: 05/07/2016 22:16:20

BIOS info at bottom: Version 2.17.1249

I have no other info from housing, because there is no info, like SN, model etc. Just blank.


Use magic Report

manonegra222| Post time 2-14-2018 22:23:18 | Show all posts
The fact that the system selection menu is displayed on the screen makes it clear that the problem with the tablet is software. You must update the screen driver with the help of the external monitor connected by HDMI. Download the drivers from the download section of this forum and from the device manager, change the driver. The system selection menu can be deleted using the executable that is attached. It is executed, it will ask for confirmation of change to Android, it will be answered no and in the next screen it is chosen to disable the system selection menu.

154.93 KB, Downloads: 3

Reply Support Not support

Use magic Report

oeriel| Post time 2-14-2018 23:18:22 | Show all posts
Edited by oeriel at 2-15-2018 00:27
manonegra222 replied at 2-14-2018 22:23
The fact that the system selection menu is displayed on the screen makes it clear that the problem w ...

OK, switch.exe is clear. I can do it later.

Explain me please, where I have to install this driver? I can log to windows usung an external monitor, but this screen is not showing up also when tablet is powered on, so even in BIOS display shw nothing. Also system selection menu is not displayed on tablet. All I see is through HDMI. Screen is backlighted only and when I change brightness in Windows, it dims a backlight too, but no picture. It looks like it's working, but not displaying because it has a bad resolution (too big)? But how it's possible to change this in BIOS?

Installing it in Windows help there too? Or I have to install it in some other way?
Thank you.
Reply Support Not support

Use magic Report

manonegra222| Post time 2-15-2018 01:24:35 | Show all posts
oeriel replied at 2-15-2018 08:18
OK, switch.exe is clear. I can do it later.

Explain me please, where I have to install this drive ...

I'm sorry, I had not fully understood.
If you do not see anything from the beginning, not even the Bios screen (pressing Esc when booting) is that something is wrong with the screen and, if you say that you have tried with another, the problem may be the flex connection of the board base of the motherboard.
In this case you will need the help of a technician and from here we can not give more support.

As the only option, you could try flashing the Bios in case if it was previously done with a wrong bios, but having no screen I do not know if it will start only the pendrive with the correct bios.
Reply Support Not support

Use magic Report

oeriel| Post time 2-22-2018 14:54:25 | Show all posts
Edited by oeriel at 2-22-2018 14:55

manonegra222, tried to clean that part when screen tape comes, no effect, all same.

Bad story so far
I've thought that I flashed bad BIOS and it sees wrong resolution - so I've flashed again with other. Downloaded here on forum. All process was seen on HDMI cable, so in EFI also. Flashed OK, but this BIOS is not showing up screen through HDMI. Only when it logged to Windows. So I have problem to flash back previous BIOS at dark. Not seen anything and tried to click and run from USB disk. Maybe because flashed BIOS is/was blocked - security?
So I decide to flash through programmer - but have problem with chip and clip. It can't catch a chip and at another try it broke legs from chip and also destroy pads...
So now device is rubbish. But I not give up. Tried to restore paths and pads. It works ok, I flashed chip with correct bios and have working tablet but with no screen but HDMI full workin.

Unfortunatelly, mu BIOS chip on one leg was soldered by needle. I can't cut it because of hardness, so after seen, tablet is working... desoldered it and tried to solder other micro cable. Unfortunately it was very hard, because fragment of pad path was almost under chip. So I desoldered whole chip to restore paths again and flash new chip, because second one was... destroyed (broken leg).

After that, something comes wrong. Tried signals on paths, seen that all is ok, but tablet is not starting up. When I connect LED lamp on microUSB port it flashed like seconds. When tablet was working this LED has still light. Yes, it flashes same but when I connect needle to broken path it lights still and tablet starts.

So... There is problem with connection with chip, because LED flashes and tablet is not starting (no charging light, no HDMI picture, nothing on screen).
Are there any places on mainboard, where I can solder jumpers from chip? All seems have ok connection (from chip to board and broken paths), but it's not starting up?

I know, many people could say - tablet is dead, but I know, it's alive, when it sees a chip. In this case there is a problem with connection.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list