ChuWi Forum»Forum General Discussion General Discussion Hi12 Q64G45170102XXX

Follow Us

Hi12 Q64G45170102XXX

[Copy link]

asdasd4578|Post time:9-16-2018 14:31:18 View:191|Reply:1

Hi,
my chuwi Hi12 with Z8350 CPU just dead today and i don't know why.
I tried every combo to turn it on, but even the official charger won't turn on the led.
I tried to see with an USB tester if the USB ports where on and, after 2 seconds of pushing power button, they starts working.
But there is no CHUWI logo on the screen or Led indication.
What i can do? I have this tablet from a year or less
Reply

Use magic Report

manonegra222| Post time 9-16-2018 14:31:18 | Show all posts
The first thing to discard is that the problem is the charger. Try connecting the tablet to another charger that has the same output values.
Leave the tablet charging for a couple of hours even if the LED does not turn on and then try turning on with the charger on and pressing the power button for one minute.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list