ChuWi Forum»Forum Chuwi Tablet Discussion General Brand new Lapbook SE not working

Follow Us

Brand new Lapbook SE not working

[Copy link]

joji|Post time:5-11-2019 22:18:04 View:153|Reply:2

Hello there!



Picked up a brand new Lapbook SE today and ran into some problems, I hope you guys can help me out since I’m about to go on vacation and I really need it to work.



Now here’s the problem,

When I first turned it on everything went good. Was setting up username, microsoft account, wifi..yeah all that. Suddenly the laptop turned off, I heard a little click just before it died?

What I’ve been noticed so far:

When I press the power button, the LED indicator stays blue for a few seconds before it shut down.
Sometimes the Chuwi boot logo comes up, but then the screen goes black (shuts down?)
Sometimes the Chuwi boot Logo comes up and next it says “preparing to repair windows”, and it shuts off.
Sometimes I can enter Bios with FN + F7 (or esc) but a few seconds later it dies.
The weirdest thing is that when the screen goes black (led power indicator goes out) I can still adjust the backlit keyboard



UPDATE 1: The longer I wait before I try to turn it on again, the longer it takes before it shuts down. Waited 15 minutes before I turned it on after last time, now it lasted 12 seconds, instead of 3…what’s going on ????



UPDATE 2: Had the Lapbook charged overnight, tried it this morning – got to windows setting up, as I did the first time – now it’s dead again



Can it be some sort of power issue?
Reply

Use magic Report

manonegra222| Post time 5-11-2019 13:35:28 | Show all posts
everything seems to indicate that the battery is not working properly.  Have you tried to keep it plugged in?  If it works with the charger on, but not with the battery, the problem is clearly the power of the battery and you will have to open a ticket at the seller.
Reply Support Not support

Use magic Report

joji| Post time 5-11-2019 22:18:04 | Show all posts
Sure, it's been plugged in for hours - makes no difference.

A side note..also tried to turn it on with the charger only having the battery disconnected, no success - same issue.

Update: The Lapbook booted up, came into Windows - was able to use it for around 5 minutes, then it died. I checked battery status (100% charged, plugged in)
Edit: The touchpad didn't work
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list