CoreBook X 14 no sound on win10

I installed windows 10 and the sound from the integrated speakers disappeared. When headphones are connected, there is sound, but of low quality, with distortion. I can’t find the drivers for the audio device and chipset. Help please.

Hi Yuri… Anthony from Dublin. If I could get back the time I have spent trying to get the audio to work on my Chuwi Laptop.

OK. Specs… So we are talking about same machine
Mine is the j4125 GeminiLake Intel Celeron. 8GB RAM. Sound Card Realtek.
I have tried 2 versions of Win10. Now on Win 11. I have a duel boot Linux system, Still no audio. But this is the strange thing. Use Bluetooth Speaker. I have sound. So its not the Reaktek Chip. Its a link between it and the speakers. Linux says the Audio Chip is a "DUMMY Output/Input’.
I have found on the Microsoft Update Cataloge Site these links.

Hello Yuri,

Yours is which version of Corebook X?
7th Gen, 8th gen, or 10thGen Intel CPU?


There was a question very much like this just a couple of days ago, and I see @antoneyz already shared the links I posted there in response:

These are the drivers that work for me. There are two parts to the audio driver.

You need HDXSSTEmdoor.inf for the device INTELAUDIO\FUNC_01&VEN_10EC&DEV_0897&SUBSYS_27820210. This also installs the services from: RealtekAPO.inf, RealtekHSA.inf, RealtekService.inf and potentially HDX_EmdoorExt_RTK.inf but I don’t think that’s necessary. This is the Realtek HD Audio ALC897(-VA2-CG) driver for Emdoor.

But there’s also the second part, which is the Intel Smart Sound Technology (SST) Audio Bus. This is the driver in IntcAudioBus.inf for the device PCI\VEN_8086&DEV_9DC8&SUBSYS_02102782&REV_30 and it also installs DetectionVerificationDrv.inf and IntcOED.inf.

Realtek drivers are updated continually. I have the version 6.0.9414.1 and it works for me. Maybe there’ll be a newer release under this link eventually but note you can’t just use any Realtek HDA driver package since they have different vendor-specific customizations. It has to include the .inf file for Emdoor, with the correct subsystem ID inside (SUBSYS_27820210).

As for the Intel part, there are no further updates and 10.23.4880.250 is the latest version (only for IntcOED.inf, everything else is 10.23.4880.0). Note that the higher versions such as 10.29 and 10.30 are for different hardware, so you can’t use them instead. Also they’re not necessarily newer. Intel driver version numbers can be confusing.

All of the above applies to the i5-8259U 2021 CoreBook X I have. Since there are so many different hardware versions, you might need different drivers altogether.

1 Like

Hello, hello! My laptop has a Intel® Core™ i3 10th gen processor.

Thank you very much, @fat_bird.

1 Like