Chuwi Laptop No Audio

I have tried 2 versions of Win10. Now on Win 11. I have a duel boot Linux system, Still no audio. But this is the strange thing. Use Bluetooth Speaker. I have sound. So its not the Reaktek Chip. Its a link between it and the speakers. Linux says the Audio Chip is a "DUMMY Output/Input’.
I have found on the Microsoft Update Cataloge Site these links.


Take a look on answer from @fat_bird in following topic that might help as well.

CoreBook X 14 no sound on win10 - Laptops / CoreBook X - CHUWI | Official Forum


1 Like

Bluetooth audio has nothing to do with your internal sound card. Bluetooth is in fact a virtual device that is encoded with usually SBC on Windows and streamed over the data link.

Whatever model your particular GemiBook, you need to find the correct driver pack for it using the search feature on this forum. For example, search “GemiBook J5125 drivers” and you’ll find a forum post with a rar archive to download.

1 Like

That’s what I wanted to hear. Thanks for taking the time to help me.

Karma. Help others. You get it back.

Regards Anthony

Get BlueMail for Android

1 Like