No sound on Linux

Hi. I have a similar issue as described in Linux on Chuwi GemiBook

I just got a new Chuwi Gemibook Pro and installed Linux Ubuntu 20.04 on it, and there is no sound. In “Output device” I see only Dummpy output, and after adding

options snd-hda-intel model=generic

in /etc/modprobe.d/alsa-base.conf

it changed to “HDMI / Display Port - Built-in Audio” but it still doesn’t work.
I tried different kernels (5.10, 5.11, 5.13) - all the same.
Unfortunately I removed Windows before checking the sound so I don’t know is it a hardware problem or not.

Can you help me?
Thank you

1 Like

So far, every thread that I’ve read about this seems that it’s either Ubuntu, or something that still uses an Ubuntu kernel.
I’d say try something NOT Ubuntu based. I’d definitely recommend Debian 11 or Arch-based (LTS kernel) since I know for a fact that sound works out of the box on those 2 OS’s, and it’ll let you know if it’s hardware or not at the least. Then go from there.

1 Like

I am having the same issue with my brand new HeroBox Pro and Ubuntu 21.04. There is no sound device associated to the analog output even though it did work with Windows.

1 Like

I am on debian 11 (antix linux 21) on my herobook air and I have the sound issue ( audio system only sees HDMI output … headphone and integrated speaker are unavailable …) … I also tried Arch with LTS kernel (Garuda linux), Manjaro (newer kernel) and Clear Linux live ISOs and I had the same issue …

(may be I can try with Fedora …)

PS : tried Fedora 35 & rawhide (from live ISOs) and their settings tool doesn’t seem to see the speaker either … tried to play sound and no success …

I can only comment on the GemiBook Pro, since that’s what I use, but I have Debian 11 on mine and sound has worked without issue since I got it (over a year now).

1 Like

Hey! What kernel do you use? And…how you install debian, it doesnt detect my network card

Currently it has the linux-image-5.10.0-9-amd64 (5.10.70-1) kernel.

I actually installed it while it was connected to my USB-C docking station, so had wired network via that when I installed.

Hello,

I cannot hear anything using the headset output, however, the sound works just fine using the HDMI out (I have an adapter HDMI <-> VGA).

I use linux Mint and kernel 5.13.0-22-generic #22~20.04.1-Ubuntu.

1 Like

yes @frayday : sound not working on internal speaker or headset is a well known problem with linux on some chuwi laptops with Everest Semiconductor sound chip , check Linux on Chuwi GemiBook for example …

1 Like

Hello. I have chuwi hi10 go n5100 intel

unfortunately, I have no sound coming from the box. I need help.


Great News :))

Install Manjaro kde plasma 5.24 . Kernel: 5.15.

the sound works through the adapter connector type C - 3.5 jack.