Bluetooth problems on Corebook X

My Bluetooth was working as usual until this afternoon, where its icon disappeared and it doesn’t show anymore the activate/deactivate button in the setting options.
I tried to use the troubleshooting but it only pointed out that the problem is that my laptop can’t be connected to Bluetooth without an adaptor for it, which is ridiculous bearing in mind it has always worked until this very moment.
When this happened, I was still using windows 10 and I just updated to 11 with all the updates windows offered me, even regarding the drivers, but it’s still not working. Any idea why?
From what I could see on the internet, apparently, it could be a driver problem, but I don’t really understand much of this matter and I can’t find useful information to solve my problem.

Thanks in advance.

1 Like Go to this site on the internet, it might help

Same problem for me on Lapbook Pro… Happened once before, I know there is a “software switch” meaning key sequence you have to press I just can’t find it any more…

has it worked? I have downloaded drivereasy now and scanned but the bluetooth was detected but i can’t see it in the laptop

Continuing the discussion from Bluetooth problems on Corebook X:

I have often found that when trying to connect a Bluetooth device I have often had to make several attempts to connect it. It may be worth while removing all Bluetooth devices and try to connect a totally different device. As regards to Driveasy I know on their website you can pay $30 to have for one year have them automatically update all and any drivers you need on up to three devices. You have for one year no issues on drivers as you will be always on the correct drivers. At the last resort and only if it it totally acceptable to you is to reinstall Windows but only if at a last resort. Try and see if you can contact Driveasy to ask for help.

Go online to Fortinet Guru adding smart switch. There is a comprehensive article on the smart switch which may help . A hard reboot may help or try removing all Bluetooth items then connect a totally different Bluetooth device.

What solved this for me was unplug from power and let it run out of juice, think Bluetooth can get this strange issue were it just disappear due to something like static electricity.

1 Like

This solution worked.