LapBook Pro - Linux Touchpad not working

Yesterday my new LapBook Pro got delivered and it i’m really happy with it. But since I’m a Linux user I tried to install Linux on it but after the installation the touchpad stopped working (while in the installer the touchpad worked perfectly). I tried several different Linux Distributions by now (Arch, Ubuntu, Mint, PopOS, etc.) and all had that problem. The interesting thing for Linux Mint was however that the touchpad first worked perfect like in the installer and then after I updated the system it stopped working as well. Any ideas hwo to fix that? The touchpad is working well on my Windows partition

Es un bug del kernel con los touchpad chinos synaptics driver con la suite se soluciona pero la mierda de empresa esta debe comprarlo e enviarnos mi lapbook es nueva y me hastie de esperar q estos imbeciles solucionaran con el driver q puse de nuevo windows nunca mas compro una porqueria de estas. desde la version 16.04 de ubuntu con sus derivados no han podido solucionar ese problema sin ese driver q te mencione anteriormente y pronto liberan la version 20.24 lts esperemos que con esa version se solucione asi migro a linux de nuevo.

I have found a solution that works for me using Manjaro, It may sound silly but using the touchpad during boot up by pressing the buttons and touching it seems to make it discoverable during the boot process. after doing that it works fine. Maybe the touchpad goes to sleep and powers off when it is not in use.

1 Like