Minibook 8100y Fingerprint Reader Device Missing

The fingerprint reader seems to be missing from Windows on my Minibook. There is no biometric device and one unknown device in device manager:
image

I tried installing the fingerprint drivers (from here Chuwi Minibook 8100y finger print sensor) for that unknown device with no success.

Has anyone seen this before? I already tried a windows reinstall. I’m on Windows 10 1909 build 18363.1082.

Device manager:

It’s a known bug that with the recent Windows10 update (type 2004) the sensor did disappear and won’t work. Welcome to the club :slight_smile: Chuwi won’t fix it, and most likely Microsoft doesn’t even know anything about this issue.

No solution is known yet…

I think it’s a hardware defect/bug with minibooks with EMCC installed. The fingerprint works fine on 8100y+8gb version with windows 2004.

Yep. The same things. On my book 8100/16GB all updates is installed. And Fp working without any problems.

2 Zenbob
Open your windows updates manager, and find “Optional updates”
Open it - and install all requirement drivers.

I’m not even on 2004 – still 1909. @Kobzar I’ve installed all available updates besides 2004 :confused:

Did you see two unknown devices after reinstalling windows?
If so, one of them is the fingerprint.

How did you install the driver? Perhaps you didn’t install it properly.

I was able to solve this problem, though I don’t understand what the root cause was. Something (maybe a bios update?) caused the hardware id of my fingerprint reader to change. The Unknown Device that showed up in device manager had a Hardware Id of ACPI\FTE4800:
image

If you look at ftwbioumdfdriverv2.inf from the Chuwi provided fingerprint reader driver, you can see that it expects hardware Id ACPI\FTE3600 on line 17:
image
I changed line 17 to reference the ACPI\FTE4800 value from Device Manager and was able to install the driver normally (though I had to enable unsigned driver installation, since I modified the driver files and thus broke their signature).

Not sure why this happened, but glad to have the fingerprint reader back!

1 Like